News, guidelines and various community projects
Recently active
The Proxmox Virtual Environment (PVE) Plug-In for Veeam Backup & Replication has been updated to version 12.1.3.217 as part of the Veeam Backup & Replication 12.3.1 release. This update includes several new features, enhancements, and resolved issues.Important InformationAutomatic inclusion: The plug-in version 12.1.3.217 is included when upgrading to Veeam Backup & Replication 12.3.1. Manual deployment: Customers on Veeam Backup & Replication 12.3.0.310 must manually deploy the plug-in. Uninstall previous versions: If version 12.1.3.197 is installed, it must be uninstalled before upgrading to the new version.System RequirementsVeeam Backup & Replication 12.3.0.310 or later. Proxmox Virtual Environment Plug-In 12.1.1.1024 or later.New Features & EnhancementsNon-Root User Access: Now supports using a sudo user for enhanced security. Open vSwitch (OVS) Support: Optimized for advanced network configurations in virtualized environments. Smart Object Storage API (SOS
During the latest local Veeam User Group in Belgium, we presented a Veeam Agent for Linux deep dive specifically around the CBT driver. In the past, I’ve seen a lot of confusion about this topic leading to people installing just everything. In this small post, I just wanted to summarise some of the findings that were presented and hopefully it will help somebody in the future.So first of all, what is the CBT driver or Kernel module that we ship. Well the CBT driver allows us to do two thingsCreate snapshots on block devices Create a tracking of the blocks that are changed between backups. This improves incremental backup as we only need to read the changed dataThere are two kinds of drivers. The reason being that some of the kernel functionality that the initial driver, “veeamsnap” was using have been deprecated. Therefore as a company, Veeam has decided to add new functionality in the Linux kernel (there is an ongoing effort to get it in the main kernel sources). The new driver “blksn
I realise there’s one topic from a couple years back which is close to this, but so far the potential fixes there didn’t apply or help.I’ve had a backup task now for around a year, 2x SSDs (1x500GB, 1x1TB) from a windows machine. At some point in the past month just after a client update, the read speed of the C drive has slowed down to ~8MB/s from a previous read speed of 150MB/s+. The disk is at under 50% capacity, and from Task Manager CPU is at ~25%, RAM (32GB) is at 60%, the disk fluctuates between 0% and 20% utilization, with the disk transfer rate at 0, peaking at about 125MB/s once every 12 seconds.The disk is about 4 years old, so not new, but also doesn’t show any issues, `winsat disk` shows the below:This is puzzling me, so any advice would be great.
What access does this role give a user in the Veeam Console? I cannot find a reference to it anywhere. Want to allow my Security team to look at Alerts and other details.
“Restore of OneNote notebooks from backups of Microsoft SharePoint, Microsoft OneDrive for Business and Microsoft Teams data for organizations with modern app-only authentication is not supported.”...and both other connection options require EWS, which is no longer supported. Therefore restoration is not possible? I know you can restore to a zip and do a copy later.If that’s correct, is there a solution in the works?Thanks. https://helpcenter.veeam.com/docs/vbo365/guide/vbo_considerations.html?zoom_highlight=onenote&ver=70https://www.veeam.com/kb4365
I was recently hospitalized due to a knee injury after a fall. While lying there, between medications and recovery, I thought — “Wouldn't it be great if we could restore our body to a previous healthy state with just one click?”Until that day comes (maybe in some sci-fi future 😄), I’m even more grateful that in IT, backup and restore is a reality — not just a dream.Over the years, I’ve had the opportunity to restore critical systems, save companies from major incidents, and bring entire environments back to life — thanks to Veeam.It's funny how life reminds us of what truly matters. Backup is not just about data. It’s about continuity, resilience, and the power to recover when it matters most.I may not have been able to restore my knee instantly, but I'm grateful that in my career, I’ve helped restore what really keeps businesses alive.
Hello,i would like to ask, if there is anything already ready to know develop something, what is readyI am thinking to use grafana for monitoring linux reasources like cpu, memory, number of concurrent tasks for hardened and nfs repository (on gateways), how many tasks/vmdks are used by proxy with hourly records to monitor, if something is not overloaded or too much under-designed like too many proxy servers, or if we have issue with backups to check resources of backup infrastructure.In current Veeam One is missing cpu, memory, ….Not sure, if something will be available in VO 13 …. We have already calculation in our design, what is officially recommended, but we are in point to look, if really we need so resources due costs, if backup infrastructure is not overloaded, if jobs are effectively spread during night, if tasks for nfs repository is enough (if its needed more, they are canceled, not waiting in queue), ….
Hello Community!Your input is needed. Almost two years ago, I created a PowerShell script that checks if one of the scanned files matches a SHA256 value by comparing the values to a list of known hash values. It only searched in specific directories.What would be better than using file-level restore? Right, Data Integration API!Since version 12.3.1, Veeam offers the possibility of working with the Data Integration API via the REST API. To improve the whole thing, I have created a Python script that scans the mounted backup file system for suspicious files by comparing their hash values against known threats stored in a local database. The database uses data from Malware Bazaar and the LOLBAS project (“Living Off The Land Binaries and Scripts”), a catalog with legitimate Windows system binaries that attackers often abuse. The script can detect such files when they appear in unusual locations. The analysis is performance-optimized through parallel processing and will export the result in
Hi all, Just making everyone aware of a recent security incident. Multiple news sources have reported that as of at least last week, the official RVTools installer contained a malicious payload. RVTools and Robware sites are currently down but without a specific statement on the software’s reported compromise. I personally would assume all builds of RVTools are compromised until we have a date the malicious payload was introduced, and avoid all use of the tool until further notice. Stay safe out there!
Hello,does anybody i using NFS repository.I am looking some guidance, which parameter could be reconfigured for better connectivity.Logs shows, that “NFS4.1 is timed out” and then is working again. This is not network issue.In case of plugin backup we have 5% failures due that.We has several cases, but is pointed into NFS protocol.So maybe someone found, which parameters could be increased to fix that between Linux repository and Linux gateway.Thank you
Hello VEEAM team, Does the roadmap include support for the XCP-NG / Xen virtualization solution?Damien
This week El Rickatron is back and @Madi.Cristil is on some well-deserved time off. I’m pleased to co-host with @JSeeger this week again! You can watch this week’s episode here:Featured Contentvia @Pybarra via @kristofpoppe via @abiwot Special Department News VUG Germany event 21-MayAfrica French Speaking online eventVUG Argentinga online event Who’s NewWe had +506 users WOW - but we haven’t checked in since VeeamON. Thank you @safiya! Coolest username pics are @Spoofer3000, @greenwall, @Techzelly, @mickymac, @DRLove, @chaoshead, @drzoffice and @buggsy! Alfred’s pick is @CheeseHeadChris → You have a badge coming your way. Have a great weekend everyone!
Hello,i am looking for siem with Veeam in private cloud - without sending logs to public cloud to analyze threadssomethings what could be isolated - logs cannot be sent into internet/public cloud.maybe with some AI (as main reason to have option to analyze logs for threads), which could update its signature from internet, is possibleAny suggestions are welcomedthank you
Hello, For "test guest credentials" does not exist any official powershell or API. Does anybody knows any workaround how to achieve that?Thank you
Hi, We’ve just upgraded our Veeam Backup and Replication server to 12.3.1.1139. All went very smoothly. I also upgraded the Backup and Replication Console, on my pc, to the same version. However, now my Veeam console will not log in to the Veeam Server. I get a message saying “Failed to connect Veeam Backup & Replication server: The logon attempt failed.” On investigation, I found that this occurred when I was using the server name (as the field was auto-populated with this info from before the upgrade). However, if I use the IP of the Veeam server, the console connects as expected. I tested this using the full FQDN of the Veeam server, but still did not connect - it only seems to connect using the IP. This was not an issue prior to upgrading and is problem as we need to be able to connect via FQDN. All DNS entries are checked and accurate, nslookup finds no issues. Even under managed servers tab in Veeam the Backup Server is set using the FQDN so there is nothing to change
Another great little thing is the possibility to display timestamps in job log in VBR console. As you know, logs in console look like this:You see start and end-time. But when happened steps in between? With v11 you can display timestamps too! Just right-click in headline and click Timestamp In my opinion this is very helpful!
I have single vmware backup contains 11VMs. In the details why there are 1 VM using default proxy and the rest using custom proxy? With this situation the 1 VM have slow backup.
This week @Rick Vanover had a conflict and @Madi.Cristil is off for some well-deserved time off! We have two special guests for this week’s recap: @Julia F Morgado and @JSeeger! Watch this week’s episode here: Featured Contentvia @Dynamic via @Geoff Burke via @marycordova Vanguard Blog Spotlight - Petr BouškaVeeam Backup & Replication - Entra ID backup part 1 | SAMURAJ-cz.com is this week’s featured post on backing up Entra ID from @Samuraj! Special Department NewsVUG Italy Meetup - 15 May VUG Finland Meetup - 15 May VUG Kansas City, USA Meetup - 15 MayProfessional Development Spotlight - Web SummitLast week Julia and Madi had an opportunity to attend a large cross-technology event → Those can be fantastic! They both took some time to write up their experiencevia @Madi.Cristil via @Madi.Cristil via @Julia F Morgado: My First Web Summit Experience – Rio de Janeiro 2025 | Julia Furst Morgado No Who’s New this week, but let’s hope everyone has a great weekend!
I have been having issues with the local file server/storage which is a Synology device running their latest up to date OS.I recently enabled SMB multichannel and Asyncronous read on the Synology. Unfortunately, my backups have started failing across multiple devices: 4/1/2024 12:32:10 PM :: Error: The network is busy. Asynchronous request operation has failed. [readsize = 4202496] [offset = 8585379840] Failed to restore file from local backup. VFS link: [summary.xml]. Target file: [MemFs://frontend::CDataTransferCommandSet::RestoreText_{04776693-5fd2-4b58-8adb-2a31e1e3d68e}]. CHMOD mask: [255]. Agent failed to process method {DataTransfer.RestoreText} While I understand I can disable the feature and NOT have SMB multichannel on, it’s been great and beneficial. I’d much prefer I was able to support and take advantage here. Is this something I can address in some way? This is using the Veeam agent.
I have been working on some ideas involving RAG and Vector Databases, this initial post just explains what they are and how they can be used. https://vzilla.co.uk/vzilla-blog/my-thoughts-on-retrieval-augmented-generation-rag-and-the-power-of-vector-databasesThe next steps is potentially a post on how do we protect these vector databases when bad things happen, the spoiler alert being these are like no other databases, they need protecting but also those backups can be used to do some interesting things.
When attempting to do a guest file restore we receive the above error message.The session report log shows green up to:“Mounting restore point to host:xxxx”then red at:“The device is not ready. Agent failed to process method (Mount.Generic Mount). Error: The deivces is not ready. Agent failed to process method (Mount.GenericMount).This occurs after pressing the “Browse” button.The backup repository is located on the same machine running Server 2019. All drives should have plenty of free space (750GB on C:, 4 TB on repository drive). 32 GB RAM and the processor or is below 10% at idle with momentary peaks at 57% when running the process.Both login and Veeam are run with an administrator account. The account has full rights to the drives.The security software does not report blocking anything.Looking at the Svc.VeeamBackup.log file I can see the above error message but nothing above or below that point appears to show an error.The backups are reporting as completed successfully and
When you designing your primary and DR kasten setup:both setup need to be installed at same namespace. Backup location settings need to be samecheck backup policy from catalog :kubectl -n kasten-io exec -it deploy/catalog-svc -c catalog-svc -- curl "http://catalog-svc:8000/v0/artifacts/search?key=manifest-policy&value=kasten-io-k10-disaster-recovery-policy"
Hi All, I trust everyone is doing well. Please assist one of our Backup Copy is not running due to the below error. File does not exist: [********.vib].Failed to open storage for read access[******.vib]. Failed to restore file from local backups. Agent failed to process method (DataTransfer.RestoreText). Thanks in advance. :)
Hi All,I’m receiving this error on within Veeam running a Backup Copy to a QNAP. I’m a novice at Veeam so any help is appreciated. Looking in the C:\ProgramData\Veeam\Backup folder, which log file in particular will detail where exactly this error is happening? Below is the summary of the Failed ‘Backup Copy to QNAP’ job.
I’d like to draw your attention to a small but significant feature that was introduced in Veeam Backup & Replication 12.1: Syslog support. As documented in the user guide (and in Veeam KB4522 with a few extra details), VBR 12.1’s syslog conforms to the industry standard RFC 5424 specification and supports UDP, TCP, and TLS transports.This feature opens the door to a huge array of security solutions. As you’ll see, this creates new opportunities for customers to incorporate VBR’s application events and malware signals into their broader security architectures and workflows to fortify their digital immune system.Veeam Backup & Replication, Meet Microsoft SentinelAs an example of what’s possible with syslog, I will walk you through how to set up VBR to send events to Microsoft Sentinel, Microsoft’s cloud-native SIEM.Solution diagram - Veeam Backup & Replication sends event data to Microsoft Sentinel using syslog and Azure Monitor AgentUsing Azure Arc and the Azure Monitor Agen
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.