News, guidelines and various community projects
Recently active
Hello. Looking for feedback on installing the Veeam Windows agent on a desktop machine that’s managed by Microsoft CoPilot We have a service account with a known good password. VBR requires that the credential be entered as “DOMAIN\username” . But since the target machine is managed with CoPilot, it seems to need logins to use “username@DOMAIN” When we try to use the “DOMAIN\username” credentials to push the agent, we are getting a “invalid username or password” error from the VBR console, even though we’ve tested the account and we know the password is good Is there any way around this account format issue? we did try entering the credentials in VBR as “user@DOMAIN” but that didn’t work either.
Result of my attempted backupHello again, As you can see from the image above, there was an issue with my backup and none of it saved, the rest of the error info that I could copy is: 22/05/2025 10:45:03 :: Error: Cannot process pending I/O request (offset: 598344892416, size: 65536): async reader terminated Corrupted block processing thread failed unexpectedly Failed to upload disk. Skipped arguments: [EmulatedDiskSpec>]; Agent failed to process method {DataTransfer.SyncDisk}. Exception from server: Cannot process pending I/O request (offset: 598344892416, size: 65536): async reader terminated Unable to retrieve next block transmission command. Number of already processed blocks: [453602]. Failed to download disk 'FA96EA97' Any advice on how to proceed? Thanks!
We have created a backup job for SQL Server, to generate Full + Incremental backup and transaction log backups, and configured GFS for all the database backups (physical servers with GFS policies as well).In the environment there are three SQL Servers as part of an Always On Availability Group cluster.The backup of the DB run and then finishes OK.The Transaction Logs portion, says that all the 44 DB has been skipped.What could be the posible causes that makes the transaction logs not been backed up?On the documentation I've found that to became subject to log backups there are some conditions: - Databases in the Always On Availability Groups for this node were successfully backed up for the last two processing intervals.The backups has been executed for the last 10 days, and no transaction logs has been backed up.Does the backups and transaction logs has to be run on the primary SQL Server?
Replication Job issues, unable to replicate virtual machine from the source to destination host. Error: VDDK error: 1 (Unknown error). Value: 0x0000000000000001 Failed to download disk 'VDDK:vddk://[Datastore-Replication] GTBHELP01_replica02/GTBHELP01.vmdk'. Shared memory connection was closed. Failed to upload disk 'vddkConnSpec>' Agent failed to process method {DataTransfer.SyncDisk}.
Hey guys,I have the same random problem with my Proxies (Windows), VMDK are still attached to my proxies randomly once the job finish. The proxies are not backuped during the different backup jobs. The Vms that Veeam processed is found to require consolidation.On the vmware side I found a log " Unable to access file since it is locked An error occurred while consolidating disks: Failed to lock the file. Consolidation failed for disk node 'scsi0:0': Failed to lock the file." at the end of the backup job.But I don’t find the root cause. Have any of you ever encountered this problem?
I’m encounter error when I adding the linux server for immutable repository. Anyone can help?
Greetings, community! For years, I have been working with many, if not all, Veeam APIs to build gorgeous dashboards and visualizations in Grafana, but I always had in my mind on using the truly comprehensive Veeam ONE API to build the Dashboard of Dashboards, or the Supreme View as Veeam ONE has pretty much all the other products information, and even more. Small spoiler: Since upcoming v13, even the Reports would available from API!!!!!Grafana Dashboards for Veeam ONE APII have prepared two views, for now, using Veeam ONE API, views that include absolutely everything (Onprem ALL Hypervisors, All Job Types, Public Cloud, and even VB365!). When you finish this article, if you follow all the steps, you should have something similar to this. It might be different in content of course depending of your environment.Job/Policy History like never seen beforeProtected Workloads view, including pretty much all platforms. Onprem, Cloud, and Microsoft 365Job Policy History - SummaryPlatform suppo
I am back with another PowerShell tip and again one more for the VB365 product.This one shows you how you can run a simple script to create all the required Windows Firewall rules for the VB365 component servers.You can check it out here - https://just-virtualization.tech/2025/06/03/powershell-tips-for-veeam-vb365-v8-firewall-rules/ PowerShell Tips for Veeam – VB365 v8.1 – Firewall RulesToday, I will discuss another interesting PowerShell script that I created. It allows you to add the necessary firewall rules to each server component in your Veeam VB365 Backup environment.Security is a necessity, especially when it comes to large projects for Government entities. So, the project I am working on needs to keep the Windows firewall turned on but allow all VB365 components to talk to each other on the required ports. That is where this script was born, and it also creates a group called “Veeam” to put the rules in so when you look in your firewall settings, you can sort by group and find
VBR Migration to New Server Error when accessing User and Roles.Did a test migration from an old VBR to a new server. Most functions and configuration migrated successfully, just need to re-enter credentials for the cloud, storage (NAS and immutable). Backup jobs are also running successfully and configuration backups are working. However when I went to Users and Roles, I got the error below, “Failed to unprotect data:…..”. I thought initially, it was just the encryption so I enabled but still get the same error. What is causing this issue? Thanks.
Ever scratched your head trying to figure out the real difference between deploying Veeam Backup for Microsoft 365 yourself versus opting for Veeam Data Cloud for M365? You're not alone! It's a common point of confusion that pops up in many of my demos. This post is here to clear the air, breaking down the distinct versions, deployment options, and how this powerful product has evolved to protect your Microsoft 365 data.When you hear "Veeam data cloud for M365," you're likely referring to Veeam Backup for Microsoft 365 (VBM365), Veeam's dedicated solution for protecting your critical Microsoft 365 data. Unlike some cloud services that have completely distinct product lines, VBM365 has evolved through significant version releases, each adding powerful new capabilities. Furthermore, how you deploy and consume VBM365 can also feel like a "different version" of the service.Let's break down these distinctions:The Evolution of Veeam Backup for Microsoft 365: Feature by FeatureVBM365 isn't a
I’ve been in the process of redesigning my Veeam network for the past month. I can’t decide between a management/security domain for my Veeam components, or just going the workgroup route. I consider our setup small and fairly basic: two VMware hosts in one location, and another in a backup location.Is a domain for Veeam that much safer? I already have my network isolation setup and configured with VLANs, and I just feel like adding another domain to manage is a waste of hardware resources, licensing, and my time.I’ve read the Veeam Best Practice Guide “Workgroup or Domain?” chapter so many times, I think I can recite it from memory.I appreciate any thoughts that other Veeam experts have on this subject. Especially for smaller setups like mine.
Received a notification from our NOC saying that the C drive was filling up, took a peek and noticed that there were a lot of log files in CheckpointRemoval but Im unsure if these are safe to delete or at the very least, zip up. Any help is appreciated!
VeeamON 2025 was a little over a month ago, and with it left a trail of new announcements and updates to soak in with its passing. This event is a huge event for everyone in the Veeam ecosystem, this means, customers, partners, community members and Veeam employees. This event is the premier event for data resilience, with deep dive content, platform announcements, networking opportunities and celebrations. During the keynote, we heard many of the features that are being included in the next version of the Veeam Data Platform –version 13! Along with all the announcements involving Veeam Backup & Replication, Veeam Data Cloud and new security integrations, came announcements about Veeam ONE’s new scalability and feature enhancements. This year, I had the opportunity to discuss these new features coming in Veeam ONE v13 (included in Veeam Data Platform Advanced and Premium) and beyond. This product has been one of my go-to products at Veeam since I started, it tells us so much about
In the June edition of the "RegKey of the Month" series, weelves into the Veeam registry key called BackupCopyMirrorAll. This hidden setting enables Backup Copy jobs in Immediate mode to replicate the entire backup history, not just the latest chain.By adding this registry key on the Veeam backup server and specifying the relevant job names, users can automate the mirroring of all restore points during the first synchronization. This approach is particularly beneficial for scenarios like offsite seeding or full backup migrations. However, it's important to note that the copied backups will adhere to the retention policies of the copy job, not the source.For detailed instructions and use cases, read the full post:👉 https://integriservices.blogspot.com/2025/06/regkey-of-month-june.html
We want to confirm the process/reason they are seeing repeated connections every 3 minutes to our linux servers during the backups being performed by Veeam. All linux servers have oracle and no redo logs configured Erased the Ip address on the 3r column which i actually Ip address of Veeam server]$ last | grep "May 29"l pts/4 Thu May 29 08:13 still logged inf pts/4 Thu May 29 06:53 - 06:53 (00:00) Initial findings:Ip in the 3rd column is Veeam server The started and end reported time is backup scheduled timeConformed Backup processing time is reported in logs . When backup is not running , I’ve checked on TestDB and the last login from Veeam was 07:49 – 07:52: and no 3 min repeated connections oracle pts/1 Thu May 29 07:49 - 07:52 (00:03)oracle pts/1 Thu May 29 07:46 - 07:49 (00:03)I need to know why Veeam is making the repeated connections during the backup and not just connecting and staying connected Is there a “keep alive” process or is the con
Hello,does anybody has usecase to backup VM by VBR1, vi copy job sent to offsite repository and read image from this repository and restore by VBR2? Environments are completely independent.My idea is to have script and copy to another folder and with another script make scan and import of images to have permanent solution.
Hi all,would you like a setting for a dark mode on the community side?Dark mode means dark background of the site and bright writing. I have switched to dark mode in many applications in the last time, because it's much more relaxed for my eyes when using the PC and/or phone the whole workday.What do you think? Does this make sense for this community site? Seems that you cannot add a poll after creating a topic.So I will count the positive and negative reactions in the comments by hand and update here 😎11 pro dark mode 2 contra dark mode 2 undecided
Hi everyoneI'm experiencing an issue with one of our Veeam backup jobs where the process fails consistently with the following error:Error: Failed to do TLS handshake.Possible cause: Unknown errorDetailed info: Reconnectable protocol device was closed.Context: Veeam Backup & Replication is being used for a daily VM backup job. The failure occurs for a single VM. The backup job retries multiple times, but ends with 0 bytes transferred and a final error after approximately 2 minutes. TLS handshake failure seems to prevent the backup from initializing. No successful backup was performed (0 B read, 0 B transferred). What we’ve tried so far: Verified basic network connectivity. Restarted both the Veeam Backup server and the affected VM. Confirmed that the VM is reachable and responsive. No recent configuration changes were made to the VM or the infrastructure. Questions: What could be causing the TLS handshake to fail in this context? Could this be related to certificate
Hello everyone,My Veeam B&R server is running on a Windows 10 VM and I’m about to migrate it to a Windows Server VM. I’m going to take the opportunity to migrate to PostgreSQL for the backend at the same time. I’m more comfortable with PostgreSQL than SQL Server and it will reduce our licensing costs.I recently went through a VMWare to Hyper-V migration (thanks to Veeam it was very straightforward).The downside is that I must maintain the legacy VMWare backups until the end of the retention period and maintain the new Hyper-V backups in parallel. I can’t afford a reset on block tracking or whatever references are maintained for XFS reflink usage.With a migration to a new server and new database engine, relying only on the Veeam B&R backup .bco file, is there any danger of losing changed block tracking data or resetting the reflink index, triggering a requirement for a full backup? With thanks,Simon
Hi All,In Vault Foundation the immutable retention is 30 days but does this works the same as immutable with object storage? Where 30 days is actually 54 days?Or am I missing up stuff?https://helpcenter.veeam.com/docs/backup/hyperv/hiw_immutability_os.html?ver=120Thanks
Hello Community!A few weeks ago at VeeamON in San Diego, the “Veeam Team” showed off a bit more of the new VDP v13 on Linux than what they did at VON2024. BTW, yes, it can still be installed on Windows if Linux still frightens you a bit 😜 ..more on this just below*.One new feature they showed off was the ability to configure Veeam Backup & Replication High Availability. In this Part 1 post, I will show how to do initial setup and then configure it. In my Part 2 post, I’ll show how to perform a quick failover so you can see how easy it is.A few Disclaimers:As you may be aware, the version of VBR I’m using is a BETA preview, so buttons, config links, and menus may be different at the time VBR v13 goes GA. Also, as with most any HA setups, enabling HA has a syncing mechanism between the primary and secondary nodes, and thus is not a backup. In other words, if something within the guest OS or Veeam gets “hosed” on the primary node, it will get sync’d (transferred) to the secondary nod
Hello,It’s possible to get job status (warning, failed or success) using powershell script?
Hi everyone,I encountered a strange behavior while migrating a customer this week and would like to share my experience and possibly get answers about the root cause. Scenario: Veeam Instant Recovery from Hyper-V to VMware Source: Hyper-V host (WS2019 Datacenter) and WS2019 Standard guest with 2 disks (OS=NTFS / DATA= ReFS)Destination: Esxi v8 (vSphere Enterprise plus)Backup Server: WS2022 standard with Veeam B&R Enterprise 12.1.2.172 What I did for many VMs with success and with a very short downtime :Backup source (running VM) to a local repository Stop source VM Backup (incremental) to the same repository Instant Recovery to vSphere Install VMware Tools Reboot VM Check if everything is working Migrate to productionBut on this WS2019 guest with a ReFS data volume, at step 4, just after the guest boot, the volume showed as RAW… I found this in the ReFS log on the guest :Event ID 7: "ReFS failed to mount the volume. Version 3.7 doesn't match expected value 3.4" After googling for a
Rickatron is in California this week and @Madi.Cristil is ready to rock some awesome content. Watch this week’s episode here:Featured Contentvia @Dynamic via @jorge.delacruz via @Iams3le Vanguard Blog Spotlight - Victor WuThis week, we feature @victorwu’s post: Installation of Veeam Backup & Replication v13 Beta – Victor VirtualizationSpecial Department Newsvia @Madi.Cristil → Vote for this month’s Blog of the Month!Who’s NewThank you @safiya for prepping the Who’s New this week! We are pleased to welcome +135 new members this week! The coolest usernames are @LessOfAnHumanBeing, @infernoIT, @Narcissus, @Piebaker, @sea-legs, @kubernator and @g40v02ay0 (What does that mean? → Tell us!). Alfred’s pick this week is @santaclause → You have a badge coming your way! Have a great weekend everyone.
Hello,I’m trying to add a Cluster object in a new Protection Group as `Microsoft Active Directory Objects` and at the credentials tab when I click on `Test Now` I get this error.9/23/2022 5:19:21 PM :: Processing Microsoft failover cluster XXXX.XXX.local Error: Failed to get cluster nodes
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.