Dell PowerStore Plug-In for OS 3.X has been released

  • 21 April 2023
  • 8 comments
  • 1190 views

Userlevel 7
Badge +14

As this was a hot topic on many plattforms, I thought it was worth sharing here.

Today Dell and Veeam have released the new storage plugin for PowerStore OS 3.x.

In general the plugin will only work with Veeam Backup & Replication build P20220302 or later. But what’s important to note, if you’re on P20220302 you need to install a private hotfix before installing the plugin itself; the details can be found in KB4243

The plugin is available for download in the Storage Plugin Section or directly here.


If you want to join the discussion in the R&D forums or give feedback, here’s the corresponding topic.

 


8 comments

Userlevel 7
Badge +20

Very cool thanks for sharing this.

Userlevel 7
Badge +6

Thanks for Sharing.  My PowerStore is still running on the v2 OS but needs to be updated.  I also should be getting a new physical server for a Veeam proxy and repo, so hopefully I’ll be able to leverage that device to access my powerstore at 25+ Gb connectivity.  Not that I need it, but I have the capability and I may as well use it.

Userlevel 7
Badge +6

Thank you @regnor for sharing!

Hi, is this version compatible with Powerstore 2.1? Thanks

Userlevel 7
Badge +14

@Fernando Ilheu Unfortunately I couldn’t find a definitive answer to that. The plugin page only mentions 3.X, the helpcenter says 2.0 or later.

https://helpcenter.veeam.com/docs/backup/vsphere/system_requirements.html?ver=120#dell-powerstore

I would suggest that you contact support to be sure, or ask in this R&D forums thread: https://forums.veeam.com/vmware-vsphere-f24/dell-powerstore-storage-plug-in-issues-and-future-release-t84328-60.html

Hi.

For upgrade upgrade from version 1.0.47 to 2.0.5 is only unnistall 1.0.47 and install 2.0.5? Have a necessary configuration?

Thanks

Userlevel 7
Badge +20

Hi.

For upgrade upgrade from version 1.0.47 to 2.0.5 is only unnistall 1.0.47 and install 2.0.5? Have a necessary configuration?

Thanks

Plugins should upgrade without having to remove the previous version. I have done that with the Hitachi and Pure Storage plugins.

Hi.

For upgrade upgrade from version 1.0.47 to 2.0.5 is only unnistall 1.0.47 and install 2.0.5? Have a necessary configuration?

Thanks

Plugins should upgrade without having to remove the previous version. I have done that with the Hitachi and Pure Storage plugins.

Thanks

Comment