News, guidelines and various community projects
Recently active
Hi,I’m using VBR 12.3.1.1139 and have already successfully migrated the configuration database to a local PostgreSQL server (which was installed during the VBR update/setup).Now I’d like to move from the local db server to a centralized one. Therefore I started the configuration “Restore” process and again chose”migrate”. Typed in hostname, database name, name and password of native authorization. But when clickin on “connect”, I get a dialog (from the db server?) that the connection is refused, the phrase is “no pg_hpa.conf entry for host <hhhh>, user <uuuu>, database <dddd>, SSL off”The problem seems to be “...database <dddd>...” whereas <dddd> is NOT what I entered into the migration dialog under “database name”. The centralized pg server only permits a certain database for each of their users.Our pg server tells me that VBR wants to connect to <dddd> where <dddd> is in fact the name of the user VBR is running with!? e.g. “BCKSRV2\horst”.Thi
Team,My SAP HANA DB are failing with below error. VEEAM Ver 12 hdbsql error: * 447: backup could not be completed: [110512] Backint reported 'BACKINT backup job into /usr/sap/KSD/SYS/global/hdb/backint/SYSTEMDB/COMPLETE_DATA_BACKUP_databackup_0_1 failed with error code ERROR' in file '/var/tmp/hdbbackint_KSD.wI4S0A', [110203] Not all data could be written: Expected 4096 but transferred 0 SQLSTATE: HY000 Your support is highly appreciated
Hi all,I have a feature request: can it be made possible to offload backups of Azure SQL databases created with Veeam for Microsoft Azure from VBR to Wasabi or other object storage using a copy job?At the moment this is possible for Azure VM's of which backups are made on blob storage. For Azure SQL it is only possible to make backups on blob storage so there is actually no offsite backup possible…
Hello I am running into this issue; any idea what could caused it
Congratulations @makacmar , you are the winner of Blog of the Month April edition! 🤝
The recording for Veeam Solutions Webinar - Veeam Data Cloud for M365 is now available.For those who missed the session or wish to return to the content, please access the recording directly here: Veeam Solutions Webinar - Veeam Data Cloud for M365
The recording for Veeam Solutions Webinar - Veeam Backup for Azure is now available.For those who missed the session or wish to return to the content, please access the recording directly here: Veeam Solutions Webinar - Veeam Backup for Azure
The recording for Veeam Solutions Webinar - Veeam Recon Scanner is now available.For those who missed the session or wish to return to the content, please access the recording directly here: Veeam Solutions Webinar - Veeam Recon Scanner
The recording for Veeam Solutions Webinar - VDP v12.3 and Vault 2 is now available.For those who missed the session or wish to return to the content, please access the recording directly here: Veeam Solutions Webinar - VDP v12.3 and Vault 2
Hello, just to let you know that we will be posting previous UKI Partner Solutions Webinars back to Dec 2024. I will put each session on a different post, so as to make searching for the content easier. After all future solutions webinars, the recording will be put here on this community forum. In the meanwhile, the playlist for all recordings is here: UKI Partner Solutions Webinars Recorded
April brought another wave of amazing content from our Veeam Community, and we’re here for it! We’ve selected six standout articles — now it’s your turn to have a say. Cast your vote and help us choose the top blog of the month before the clock runs out on May 6th (NYT)! ⏳🗳️Your vote means more than you think — it’s a big shoutout to our community members who keep the Hub thriving. 💚Best of luck to all the talented contributors! 😊@leaha , @saintdle , @makacmar , @mkevenaar , @marycordova , @matheusgiovanini Best, Madi
Sometimes, we need to remember some basic concepts to understand what happens "under the hood" in operations we perform on a day-to-day basis, such as performing an application-consistent backup and how to troubleshoot it. So, what is Microsoft VSS?Microsoft Volume Shadow Copy Service (VSS) is a volume backup framework in Microsoft Windows Operating Systems.It integrates with many applications and backup solutions, like Veeam Backup & Replication, to provide application-consistent backups. Why is VSS used? Some enterprise applications maintain transactional interdependencies between data files, logs, metadata, and in-memory data.For these applications, an application-consistent backup ensures that all these transactional elements are synchronized when captured by the backup requestHere, we show examples of applications integration with Microsoft VSS for consistent backups:Databases: SQL Server, Oracle, MySQL; Email Server: Microsoft Exchange; Enterprise Applications: SAP, Microsof
Hi AllI have been working on a 1 stop shop for everything Veeam Data Platform 12.3 documentation wiseThis includes a break down on the subscription offerings, and deploying and configuration information forVeeam Backup And ReplicationVeeam Enterprise ManagerVeeam ONEVeeam Recovery OrchestratorIts not an entirely complete guide, some bits I dropped out of the scope, as Veeam has SO much stuff and this was already getting long, so I covered what I felt was the most important featuresIts sectioned out to make it easier to read and due to the massive scope on itMost bits should adhear to best practicesI hope this helps people get the most out of Veeam, as I feels its the best out there and offers so much value in its feature sethttps://blog.leaha.co.uk/2025/04/22/veeam-data-platform-12-3-ultimate-deployment-guide/
Hi Everyone,Over the past few months, like many others, my role has shifted slightly.After years of working deeply with VMware technologies (vSphere, NSX, vSAN, Veeam integrations, etc.), I’m now also helping customers explore adjacent or complementary solutions — especially in Kubernetes-native environments.One technology that comes up a lot is KubeVirt — a way to run VMs inside Kubernetes clusters, alongside containers.It's not intended to replace vSphere, and it’s certainly not a "better vs worse" situation. It's simply different — and the learning curve can catch you off guard if you approach it expecting it to feel like vCenter.While working with KubeVirt, here are a few key takeaways I thought might be helpful to share: Storage is very different: Instead of datastores and VMDKs, you deal with Kubernetes PersistentVolumeClaims (PVCs) and CSI drivers. Live migration depends heavily on ReadWriteMany or block volumes. Networking needs a shift in mindset: Concepts like vSwitches and
I’ve got an Ubuntu 24.04 VM running in Proxmox VE which is backed up using Backup & Recovery Community edition. The VM failed recently and I restored the VM back to Proxmox VE, but it just boots to Grub recovery. From what I understand, the problem is the VM is encrypted with LUKS which is transparent to Veeam. I’ve read a few posts and guides on getting this to work, but I’m not having any luck. I’m able to decrypt and mount the volume in a live environment, but I cannot get it to permanently mount in order to boot. Is there anything special that needs to be done for encrypted Ubuntu VMs in Proxmox or any guide for restoring LUKS VMs?
This week we had a laptop fail on the road while @Rick Vanover was at RSAC, but no fear @Madi.Cristil and @safiya went full-on “ROAMING REPORTER” last week at VeeamON, so we have a special video to share:Featured Contentvia @saintdle via @SSimpson via @marycordova Vanguard Blog Spotlight - Keiran SheldenThis week’s Vanguard blog spotlight is @keiranshelden’s mind-blowing (pun intended) blog on mind maps of Veeam components. You have to check this out: Mind Maps – Ready, Set, Virtual! Special Department NewsUpcoming BeLux User Group: VUG BeLux May Meetup, Tue, 6 May. 2025 at 14:00, Europe/Brussels | Veeam Community Resource HubUpcoming Turkey User Group: VeeamON 2025 Güncellemeleri, Tue, 6 May. 2025 at 16:00, Europe/Istanbul | Veeam Community Resource HubUpcoming Brazil User Group: VUG Brasil Meetup, Tue, 6 May. 2025 at 19:00, America/Sao_Paulo | Veeam Community Resource HubNo Who’s New this week, but we’ll get back at it - but Rick needs to swap out laptops first! Have a great
I have moved VBR 12.3 to a Hyper-V VM as recommended. I would like to continue to use a set of USB drives for the backup copies. Is this possible?
Although this article on my blog is a bit older, it’s still relevant and maybe useful for some of you, who are running a DD with Retention Lock in Compliance mode. Let’s go: Here is a short step-by-step guide on how to expand the capacity on a Dell Data Domain with Retention Lock Compliance Mode enabled. For a 'normal' Data Domain system, this is relatively easy to do via the Dell PowerProtect DD System Manager website. You select the Licenses option in the Administration section and simply swap the existing license for the new/updated license (obtained via the Dell Digital Locker ). If you try this on a Retention Lock Compliance System, you will receive the following message: ErrorDD Retention Lock Compliance Mode is enabled. Operation requires Security Officer credentials and can be performed only via the Command Line Interface. Command Line Interface / CLI For example, connect to the Data Domain via Putty. After successfully logging in (in this example, with the sysadmin accoun
Does anyone have recommendations for time settings on a Veeam hardened repo? After researching, I’m seeing conflicting recommendations from use the internal CMOS clock, use an internal NTP server, or use an external NTP server. Just wanted to see what some of the Veeam experts recommend.
VeeamON is NEXT WEEK! I think it is fair to say that Rickatron is running hot and busy! Thankfully @Madi.Cristil is keeping the calm and peace in this week’s recap. Watch the episode here:Featured Contentvia @Chris.Childerhose via @leaha via @AndrePulia Vanguard Blog Spotlight - Dave KawulaThis week’s spotlight blog is from @Dave Kawula → Troubleshooting Veeam Backup Failures: RPC Server Unavailable Error #Veeam @VeeamVanguard | CheckYourLogs.NetSpecial Department NewsAll programs (Vanguard, Legend and VeeaMVP) are updated with the 2025 classes: Veeam Vanguard 2025 | Veeam Community Resource Hubvia @Beto Cardenas - Announcing the Veeam User Group Ecuador: https://community.veeam.com/groups/vug-ecuador-161Who’s NewThank you @safiya for prepping the Who’s New! We are happy to welcome +182 new members! The coolest usernames are @Jepper, @sun2kim, @admin_mars, @SiteLilly, @hotnoise and @Hifidelity84! Alfred’s pick is @DataBurger → You have a badge coming your way! Next week i
As of the 27th March we have seen a significant increase in incremental backup size for our Microsoft 365 backup… Peaking at 800GB+ on the 31st! We have different jobs configured for different sources, for example we have separate jobs for:User Mailboxes Shared Mailboxes SharePoint Sites OneDrive SitesLooking at the size of each backup job, I think the increase in backup size is primarily due to the user mailbox jobs; the other jobs look ‘normal’ in terms of their size. Is anyone else seeing a sudden increase in backup size in the last couple of weeks? Does anyone have any tips for pinpointing where the increase is coming from?
Products:Veeam B&R Community Edition 12.3.1.1139 (Windows Server 2022) Windows Agent 6.3.1.1074 (Windows 11 Pro for Workstations, version 24H2)Using B&R Console I accidentally uninstalled CBT Driver from the Windows 11 PC, and now I cannot reinstall it anymore.The CBT driver is also missing from installed Windows apps and program list in the legacy Control panel.I tried to uninstall completely all components on that client, I removed it from my B&R Protection group, restarted it many times, but no avail.I also tried to install the standalone Agent, but the CBT driver install/uninstall option is missing from settings.Even command line method fails:Veeam.Agent.Configurator.exe -uninstallCBTDriverExitCode: 0Veeam.Agent.Configurator.exe -installCBTDriverExitCode: 20Errors:Failed to perform the operation.File existsThe only way I haven't tried yet is with command line by booting the PC from Veeam Recovery Media.In attachment: log file.Any ideas on how to solve?BTW, I’m wondering
Following on from my previous post, I am now in a pickle because after uninstalling a failed install of VBR 12.3 and reinstalling 12.1 the system is incapable of backing up my VMs. Need to completely uninstall all 12.1 stuff and do a clean install and forget about importing the config. Stay tuned.
For those who follow the Veeam Data Trends reports, the latest 2025 report has been released. 1,300 organisations were surveyed, of which 900 had experienced at least one cyber attack in the past 12 months.This year’s research also includes insight from Coveware by Veeam’s own incident response data. Six Major Ransomware Trends for 2025 were highlighted:Law Enforcement Forces Threat Actors to Adapt Data Exfiltration Attacks Grow Ransomware Payments are Decreasing Emerging Legal Consequences of Ransom Payments Collaboration Reinforces Resilience Against Ransomware Budgets Rise for Security, but More is Needed Get your copy of the Risk to Resilience : 2025 Ransomware Trends & Proactive Strategies report here:https://go.veeam.com/ransomware-trends
Hello,When we have rental license how we can calculate how many VM can be protected by the available license?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.