Join discussions around Veeam community projects, Veeam events, industry and technology news
Recently active
I'm trying to set up a job to backup my Windows 11 laptop.I'm using the Community edition of Veeam Backup and Replication 12, and I'm running the job as admin. Everything fails, but the Rescan fails first. I’ve set up the job on my laptop as follows: The Job Mode is Server/Managed by Agent, the computer is localhost, I chose File level backup to backup a single folder as a test, but eventually it will be the entire laptop. The backup destination is a shared folder on my NAS that the backup user can fully access. What am I doing wrong? I’m backing up a simple laptop, not a VM. I see reference to an agent, but I don’t see where to download or configure it.I really do like using Veeam. It was working fine for years on the previous Windows 10 laptop, and version 6.3.1.1074 is working fine on my other Windows 10 laptop. I hope that you can help me with my issues.
Looking at using Veeam Backup and Recovery in AWS with a Veeam AWS backup server deployed. I had 2 questions, either one might be a deal breaker:SQL data resides mostly on Windows Dynamic disks. AWS documentation says Dynamic disks are not supported (or are not reliable) for regular application aware snapshots. Is this also the case with Veeam created snapshots on AWS EBS Windows volumes?I read there are limitations of how many SQL databases can be frozen at the same time because of the need for SQL worker threads we have hundreds though not all active at the same time). Can Veeam manually or automatically backup all databases but split into several smaller jobs?
Hi Community, This happened after yesterday's amazing live show, and I learned many points during the live show, which are very impressive and amazing. Summary:To effectively apply reliability metrics in your Veeam environment, begin by actively monitoring system alerts and backup job failures using tools like Veeam ONE. 1: Track Failures and Alerts (MTBF, MTTF)Use Veeam ONE to monitor system health and track how often failures occur in proxies, repositories, or even backup job logic. Create custom reports to calculate MTBF over time for key components like NAS storage, tape drives, or SOBR extents. For MTTF, log hardware runtime metrics and tie them to predictive failure analysis, helping you justify lifecycle replacement. 2: Analyse Patterns (MTBF, MTTF)Correlate high-frequency backup job failures with specific hardware or VM groups. Identify trends where MTBF is low and use these insights to adjust job schedules, storage assignments, or hardware specs. Establish a baseline MTTF for
Hey folks,I would like to know if any of you externalize backups sent to S3 storage onto tape?
Hello I have configured veeam backup for Oracle rman using veeam plug in. My OS is solaris 11.4 and running oracle database 19.3Backups are running successfully. Now I am using below script to restore the control file to another solaris server same os and database version but it’s failing. Can anyone please advise what might be wrong? Script used to restore:RUN {ALLOCATE CHANNEL ch1 DEVICE TYPE SBT_TAPE PARMS 'SBT_LIBRARY=/opt/veeam/VeeamPluginforOracleRMAN/libOracleRMANPlugin.so';RESTORE controlfile to '/tmp/stc.ctl' FROM 'c-42xxx701-2xxxx6-00_RMAN_AUTOBACKUP.vab';}EXIT; Error encountered:Starting restore at 26-MAY-25channel ch1: restoring control filereleased channel: ch1RMAN-00571: ===========================================================RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============RMAN-00571: ===========================================================RMAN-03002: failure of restore command at 05/26/2025 16:13:21ORA-19870: error while restoring backup piec
NFC storage connection is unavailable.. Storage Failed to create NFC download stream
I recently created a new backup copy job that targets 5 copy jobs. It appears that when the backup copy job runs that it processes all of these targets simultaneously rather than sequentially. Because the target repository is a spinning disk, I am concerned about what this means for performance and unnecessary disk fragmentation. Is there a way to change this behavior and have the job copy over the data from each backup job one at a time?
Dear Community, Another month, another wave of awesome content from our Veeam Community — and May did not disappoint! We’ve shortlisted six exceptional blog posts, and now it’s up to you to pick your favorite. Be sure to cast your vote before the deadline hits on June 3rd (NYT)! Every vote is a high-five to the incredible contributors who keep our community buzzing with knowledge and passion. 💚Wishing the best of luck to all the talented bloggers! 😊@kristofpoppe , @coolsport00 , @JSeeger , @Michael Melter , @Dynamic , @Iams3le Best, Madi
Did I have a fever dream about a year ago that said Veeam was being ported to Linux? I haven’t read/seen or heard anything about it in a long while. I did not see any installers to be had last time I checked.
As part of the Veeam Backup & Replication server v12.3.0.310 upgrade, the built-in PostgreSQL is installed like below:The installation successful without any error.However, there was no prompt or notification of what is the credential that can be used for accessing this default instance of PostgreSQL:Via the command line: "C:\Program Files\PostgreSQL\15\scripts\runpsql.bat" Or using the DB Configuration settings UI: I have also tried to manually install PGAdmin interface, but not sure what is the default credential I can use to login to this default instance installed by Veeam Backup: Any help would be greatly appreciated.
I have Veeam B&R installed in a lab. I’m trying to find a way to backup/restore remote Linux servers (agents) to the LAN. I want to have a Veeam server on the LAN initiate and pull the data from the remote servers using port 22 (SSH) so that I do not have to open any additional ports on the remote servers or on the LAN.Is this something that Veeam Cloud Connect can do? I’ve tried doing this with standard Veeam B&R but it just won’t traverse NAT.All of the videos that I’ve watched seem to indicate that Veeam Cloud Connect is geared towards providing a backup service to other companies. I’m just trying to backup my own servers and I don’t need remote access to the Veeam console.Also, everything on the LAN is behind a gateway device that provides WAF and SSL termination and I have a reverse proxy running on the LAN that can also terminate SSL.
We are working on to fix Security and Compliance Analyzer recommendations. We have run the script provided by Veeam. We are concerned about Item 28: "Hardened repositories should have the SSH server disabled." Since the Veeam Backup and Replication server connects to the Linux Hardened Repository via SSH, is it safe to have SSH disabled? Does Veeam Backup and Replication connect to the Hardened Repository over SSH on a port other than 22?
I realise there’s one topic from a couple years back which is close to this, but so far the potential fixes there didn’t apply or help.I’ve had a backup task now for around a year, 2x SSDs (1x500GB, 1x1TB) from a windows machine. At some point in the past month just after a client update, the read speed of the C drive has slowed down to ~8MB/s from a previous read speed of 150MB/s+. The disk is at under 50% capacity, and from Task Manager CPU is at ~25%, RAM (32GB) is at 60%, the disk fluctuates between 0% and 20% utilization, with the disk transfer rate at 0, peaking at about 125MB/s once every 12 seconds.The disk is about 4 years old, so not new, but also doesn’t show any issues, `winsat disk` shows the below:This is puzzling me, so any advice would be great.
What access does this role give a user in the Veeam Console? I cannot find a reference to it anywhere. Want to allow my Security team to look at Alerts and other details.
“Restore of OneNote notebooks from backups of Microsoft SharePoint, Microsoft OneDrive for Business and Microsoft Teams data for organizations with modern app-only authentication is not supported.”...and both other connection options require EWS, which is no longer supported. Therefore restoration is not possible? I know you can restore to a zip and do a copy later.If that’s correct, is there a solution in the works?Thanks. https://helpcenter.veeam.com/docs/vbo365/guide/vbo_considerations.html?zoom_highlight=onenote&ver=70https://www.veeam.com/kb4365
Hello,i would like to ask, if there is anything already ready to know develop something, what is readyI am thinking to use grafana for monitoring linux reasources like cpu, memory, number of concurrent tasks for hardened and nfs repository (on gateways), how many tasks/vmdks are used by proxy with hourly records to monitor, if something is not overloaded or too much under-designed like too many proxy servers, or if we have issue with backups to check resources of backup infrastructure.In current Veeam One is missing cpu, memory, ….Not sure, if something will be available in VO 13 …. We have already calculation in our design, what is officially recommended, but we are in point to look, if really we need so resources due costs, if backup infrastructure is not overloaded, if jobs are effectively spread during night, if tasks for nfs repository is enough (if its needed more, they are canceled, not waiting in queue), ….
Hi all, Just making everyone aware of a recent security incident. Multiple news sources have reported that as of at least last week, the official RVTools installer contained a malicious payload. RVTools and Robware sites are currently down but without a specific statement on the software’s reported compromise. I personally would assume all builds of RVTools are compromised until we have a date the malicious payload was introduced, and avoid all use of the tool until further notice. Stay safe out there!
Hello,does anybody i using NFS repository.I am looking some guidance, which parameter could be reconfigured for better connectivity.Logs shows, that “NFS4.1 is timed out” and then is working again. This is not network issue.In case of plugin backup we have 5% failures due that.We has several cases, but is pointed into NFS protocol.So maybe someone found, which parameters could be increased to fix that between Linux repository and Linux gateway.Thank you
Hello VEEAM team, Does the roadmap include support for the XCP-NG / Xen virtualization solution?Damien
Hello,i am looking for siem with Veeam in private cloud - without sending logs to public cloud to analyze threadssomethings what could be isolated - logs cannot be sent into internet/public cloud.maybe with some AI (as main reason to have option to analyze logs for threads), which could update its signature from internet, is possibleAny suggestions are welcomedthank you
Hello, For "test guest credentials" does not exist any official powershell or API. Does anybody knows any workaround how to achieve that?Thank you
Hi, We’ve just upgraded our Veeam Backup and Replication server to 12.3.1.1139. All went very smoothly. I also upgraded the Backup and Replication Console, on my pc, to the same version. However, now my Veeam console will not log in to the Veeam Server. I get a message saying “Failed to connect Veeam Backup & Replication server: The logon attempt failed.” On investigation, I found that this occurred when I was using the server name (as the field was auto-populated with this info from before the upgrade). However, if I use the IP of the Veeam server, the console connects as expected. I tested this using the full FQDN of the Veeam server, but still did not connect - it only seems to connect using the IP. This was not an issue prior to upgrading and is problem as we need to be able to connect via FQDN. All DNS entries are checked and accurate, nslookup finds no issues. Even under managed servers tab in Veeam the Backup Server is set using the FQDN so there is nothing to change
I have single vmware backup contains 11VMs. In the details why there are 1 VM using default proxy and the rest using custom proxy? With this situation the 1 VM have slow backup.
I have been having issues with the local file server/storage which is a Synology device running their latest up to date OS.I recently enabled SMB multichannel and Asyncronous read on the Synology. Unfortunately, my backups have started failing across multiple devices: 4/1/2024 12:32:10 PM :: Error: The network is busy. Asynchronous request operation has failed. [readsize = 4202496] [offset = 8585379840] Failed to restore file from local backup. VFS link: [summary.xml]. Target file: [MemFs://frontend::CDataTransferCommandSet::RestoreText_{04776693-5fd2-4b58-8adb-2a31e1e3d68e}]. CHMOD mask: [255]. Agent failed to process method {DataTransfer.RestoreText} While I understand I can disable the feature and NOT have SMB multichannel on, it’s been great and beneficial. I’d much prefer I was able to support and take advantage here. Is this something I can address in some way? This is using the Veeam agent.
When attempting to do a guest file restore we receive the above error message.The session report log shows green up to:“Mounting restore point to host:xxxx”then red at:“The device is not ready. Agent failed to process method (Mount.Generic Mount). Error: The deivces is not ready. Agent failed to process method (Mount.GenericMount).This occurs after pressing the “Browse” button.The backup repository is located on the same machine running Server 2019. All drives should have plenty of free space (750GB on C:, 4 TB on repository drive). 32 GB RAM and the processor or is below 10% at idle with momentary peaks at 57% when running the process.Both login and Veeam are run with an administrator account. The account has full rights to the drives.The security software does not report blocking anything.Looking at the Svc.VeeamBackup.log file I can see the above error message but nothing above or below that point appears to show an error.The backups are reporting as completed successfully and
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.