News, guidelines and various community projects
Recently active
Hello, Thanks,I need to restore a backup, but need that date/time to match the date/time that the backup was taken.For example, I have a .vmb, .vbk, and recovery agent isoNeed to restore full backup from 10/07/2023 into a hyperv vm.But no matter what I try, after restore and reboot, the date is not set to 10/07/20231. I have setup the hyperv vm not to use “Time Synchronization”2. disable network access, so not ability to contact NTP server.3. As soon as the vm boots, but before starting the restore, i open a command prompt and manually set date to 10/07/20234. then I run the recovery, reboot into the OS and the date is wrong.Any suggestions please?
UPDATE (Feb 2024):It was brought to my attention recently that some of the cmdlets have changed in v12.x that may have broken one or more of the above scripts. I’ve rewritten the one that was pointed out (Veeam Agent Jobs) and tested to make sure it works. I can’t vouch for the others, but will try to get around to updating them all (if needed) and posting the updates here. Just be sure if you’re on 12.x or newer that you do thorough checks to confirm it works in a safe environment before attempting to run anything in production.------------------------------------------------------Hello again, everyone! Just sharing another useful PowerShell script to enable/disable Health Checks for multiple jobs. It’s handy whenever you have a large number of jobs which all need to be adjusted and would take a significant amount of time to do so. Usually I wouldn’t share such a short script, but the way to locate and adjust this particular option in a job via PowerShell can be a little confusing if
I’m setting up a QNAP TVS-871 which has 4 x 1Gb interfaces. I just watch this video about performance related to different types of link aggregation. My switch (setup by someone else) is set for LACP was planning on using 802.3ad… but now I’m not sure.Does VEEAM gather the files and make them appear as 1 file transfer or can it transfer multiple at a time? Will link aggregation protocol make a difference for VEEAM?Can someone help me understand because I’m sort of new and working on a live office network of 30 people so I can’t play around too much.
Good afternoonI am having the following error when running a tape backup job [CTapeRepositoryStorageRelation] Cannot find record in table TapeStorages for tape storage Thank you very much in advancegreetingsMarcelo
Can non-domain joined VBR v12 servers use a gMSA?All of our Veeam servers are off our domain, but can communicate with AD, and I'm exploring if I can use gMSA instead of a service account.I've read the KB on gMSA for Veeam, but it's written in a way that tends me to believe its for domain joined VBRs servers. A few articles online show that non-domain joined containers can run gMSA, but doesn't read as if non-domain joined servers can do that or not.https://helpcenter.veeam.com/docs/backup/vsphere/using_gmsa.html?ver=120
Hello everybody and wish you a happy and successful new year. I’m starting with configuration of SureBackup for our environment.I’m still pretty new to everything so it would be great if someone can assist.We have a standalone Hyper-V Host that we are using for our Virtual Lab.Few of you are already familiar with our setup but I will write it again:Backup Jobs going on primary location (Synology NAS iSCSI connection formatted as ReFS to Windows Server) Backup Copy Jobs on secondary location ( Synology NAS iSCSI connection formatted as ReFS to Windows Server) Immutable Backups on secondary location ( Running Directly on Synology NAS as a VHR - isolated ) Now I want to add SureBackup to our Backup Strategy to complete the 3-2-1-1-0 rule. Currently I created an Virtual Lab with Hyper-V Host but didn’t configure anything than default settings that Veeam Already configured by itself.VM’s that we backup range from DC’s, FileServer’s, Revit Server’s and a lot of other applications.What would
I have found a ton of articles on how to fail over corporate servers and resources to a DR site. The process seems very straight forward and as long as your internal users can work and are able to access local resources / servers all is well.However we have the need to fail over several servers that provide external hosting of services like www hosting, VoIP PBX servers, mail servers etc.All of these servers at our production site have complex firewall policies and WAN static routes configured and ultimately top level registrar DNS pointing traffic to our various static WAN IPS and in turn routing to local server targets based on ports and traffic type. We have setup a VPN site to site with no issue and are easily able to replace VMS to the Dr site.The Datacenter site is 192.168.15.x and the DR site is 192.168.30.xWe can easily fail over a replaca and re ip them to 192.168.30.x IPS and have tested this. The problem is the VM is useless as there are no firewall routes to them once
I’m using VEEAM 12.0.0.1420.I’ve created a backup on a RDX drive with the option ‘This repository is backed by rotated drives’.Then i created a bootable recovery media → USB stickStarting machine from USB stick and open wizard ‘Volume Level Restore’Backup location is fine, full backupStarting progress will show the following lines:OK Loading backup filesOK Restore process started …BAD Restore failed: The requested security package does not existBAD Saving restore logs Error: Unable to save recovery logs to target repository. To do …Please advise.THX Reinhard
Currently I have 40 VMs, and 50 licenses. A little context: We have a server that creates a lot of images, it has been doing so since 2015. Last year I reconfigured the server, moving the oldest images to a NAS, and we are keeping the current years images on the server, for faster disk based backups, and disk copies. More recent imgaes are accessed much more than older images. The older images do not change. Somehow the file to tape and 500GB file share licenses did not really affect us untill now. Over the last couple weeks, I have been doing my final cleanup of the images we moved, deleting the fomer vmdks that they used to live on. Before finally deleting the vmdks, I started writing the oldest images to tape, and deleting the corresponding vmdk. A couple days, and 8TB, in, I get a licensing message. Now I am here. Incrediby disapointed. If there is no recourse, then the licensing cost, will more than double, just becasue I want to have a copy of this data on tape? Th
While helping an SE with a POC, I encountered an odd obscure error when trying to install a repository on one VM and a proxy on another VM. The error message was received after we added the VMs as managed Windows servers and during the actual repository and proxy install.The error I received was:“Installing package Transport Error: Error 1920. Service Veeam Data Mover Service (VeeamTransportSvc) failed to start. Verify that you have sufficient privileges to start system services.” I was a little panicked when I saw this as I have not encountered this error before, and the service installs work.After my initial panic, my attention immediately turned to an account permissions issue. The account being used is a domain account that was a member of the local administrators group on the servers. The account used was able to start and stop other services. A check of Google yielded little insight. It did point me to the Veeam KB 1059 – which discusses this error.The first step it mentioned
Hello, recently I had a problem on a production environment. I had to delete old replicas (old VMs that wasn’t on production site anymore), and after deleting 4 old VM replicas inside Veeam, two critical production VMs were also deleted from vSphere. Fortunately this mentioned VMs had backup and their replicas did the job on recovering, which also proves that there wasn’t accidental deletion on the Veeam side. From what I analyzed and read in some articles on the web, probably two of the replicas deleted were somehow linked to the production VMs. Maybe someone incorrectly managed replicas through vCenter/ESXi instead of Veeam, but is hard to know what happened exactly. But apart of finding exactly what led to this, we still have to delete old replicas and I’m not comfortable on proceeding without having a mean of ensure that no VM will be deleted from production site. So I’d like to know if anyone can help on how can I find some identifier of replicas that can lead to a comparison with
Is there any significant downside to using Windows 11 pro as the OS for the BR server roles instead of windows server OS? I ask because I’ve been evaluating how to migrate our BR infrastructure away from our domain joined servers and one path I'm looking at appears to require using a client OS. The BR documentation appears to show all roles as supported to be running on the client OS. We have a pretty small deployment. I would like to avoid using a workgroup for the BR infrastructure if possible, so my thoughts are either (1) use another AD domain in the AD forest. (2) use Azure Managed Domain Services (3) Use the Free Entra ID and device management. Option (1) seemed like a nice option at first, but looking at the actual support requirements, it seems like it will add a lot of overhead and I’m not even sure I can reasonably avoid any chicken/egg situation where I’m starting from no running infrastructure and just repository backup data. Option (2) appears to be way too expensive
A tape verification a day….😉Tape backups are an essential part of data protection strategies as they provide reliable security and offline storage capabilities. However, ensuring the reliability and consistency of tape backups can be critical for regulatory compliance and ensuring data integrity.So I wrote a Powershell script (which has been floating around in my head for a long time) that uses the available Powershell cmdlet "Start-VBRTapeVerification" to regularly check tapes available in a media pool and marks them as checked with time stamps and checks the tapes again after a certain time (default 270 days). It also helps to increase data reliability and reduces the manual effort involved in managing tape backups. The script can be downloaded here.The following parameters can be utilized to customize the tape verification:MediaPool: Specifies the media pool from which tapes will be selected for verification. This parameter is mandatory. NumberofTapes: Determines the number of tape
CHALLENGE launched!!! Would be great to have a more diverse Community where we can learn from different experiences??? Each Community member to bring a woman to join our WA-IT group and any other group of the Community, being for her a mentor and a tourist guide 😉 to show around the many benefits of being a member here. This will shape a more inclusive and diverse Community and create new opportunities to cooperation and dialogue. See the group here >> https://community.veeam.com/groups/women-and-allies-in-tech-115
Hi all,We have a problem with oracle archive log filesWe are migrating backups from HP Dataprotector to Veeam Backup & Replication 12. We create a job using Veeam Plug-in for Rman. In the "Database Prossesing settings" window’s, we choose the option "DELETE archived redo logs that were backed up". The ARCHLOGS are deleted, OK, but With HP DATAPROTECTOR we used a script with these commands: archivelog until time 'sysdate-3' not backed up 1 times;delete NOPROMPT archivelog all completed before 'sysdate -7' backed up 1 times to sbt;crosscheck archivelog all;How do we do it with Veeam?Adrian
connect to powershell: connection to remote server outlook.office365.com failed with the following error message: access denied veeam office 365
Hi, I have downloaded a trial of Veeam Office 365 backup after hearing how good it was in several places as we currently use another product but it's not the best in terms of features. Initial setup was simple enough but when it came to running the backup job, the performance was dreadfully slow. Averaging between 500-800kbps, it will take months to backup at this rate! Bandwidth is not an issue, we have a leased line and easily get 200meg down. Surely something must be wrong? I have read about auxiliary accounts but that option is greyed out for me...? I have the latest version, downloaded only last week. A bit disappointing since the rest of it seems to be pretty sweet.Any help is appreciated, thank you.
When Veeam Backup Server is backing up with SQL Server, SQL Server will send packet port 445 from Veeam Backup Server. What is the problem and how to solve it?
How to tell which backup proxy is being used by agent based backup job? NAS file share backups show the proxy server being used but not seeing the same for an agent based backup job.
I want to give copy job A 10 MB/s but copy job B 2 MB/s. Both go to the same target offsite repo
Hi team: I have a question: it turns out that I was going to read a tape in Veeam, I took out the previous one (tape3 that's what it's called), it came out without problems and I put the other one in (tape2). When it read the device, Veeam recognized the tape but with the same information as the previous one (tape3). When I took it out with Eject it came out without problems and when I put it back in it didn't read it as Idle or Free.What could have happened to make him behave that way? I played the tape I had at the beginning (tape3) and it reads it without incident.Regards,
Hi all and thanks for reading!!I have a socket liscencing in a host called “roma6-1”. Now, i updated the esxi and the new name of the host is “roma-linux-1”. Well, i revoke the liscence of the host “roma-1” but when i run a job, it still appears with the old name “roma6-1”, i dont know why doesnt appear the new hostname “roma-linux-1” as appears in the inventory of veeam for example. I have searched in my dns, esxi conf, idrac conf, etc. and all is fine. Id should be something cached in veem, i suppouse, but i dont know where looking for.¿Can you help me please?
I know theres immutable backups but i dont have that repo right now. How can i prevent admins from them inadvertently in 2 clicks delete an entire decade worth of backups ?
You may have seen this: https://www.bnnbloomberg.ca/softbank-backed-cohesity-reaches-deal-to-acquire-veritas-unit-1.2032340 I don’t know what this will mean. The backup world is huge but still. Any thoughts?
Well, I just did the upgrade to 12.1 and things could not have gone more smooth. I did have to uninstall the console on my desktop manually and reinstall it but the server side went great.It seems like it’s running quick, and the new features are fantastic. The malware detection is going to take a bit of tuning, due to the amount of files, and odd file types some of these video players use, but I am very excited that these are now included in B and R.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.