News, guidelines and various community projects
Recently active
When using preferred networks you might find your backup jobs take longer to initalise, commonly when you’ve got distributed backup components such as a physical proxy/repository and your Veeam Backup & Replication server isn’t performing any backup processing. This is because your Veeam Backup & Replication Server is also required to use your preferred networks configuration, even if it doesn’t have any network connectivity that resides within your preferred networks.This causes the job initialisation to take a lot longer than usual, and this grows even slower the more distributed your network topology and the more preferred networks you have. This is because your Veeam Backup & Replication server has to work through every preferred network match, before moving onto the rest of your network interfaces.Now, a quick reminder that the scenario above is just one example of why isolated networks might exist, but certainly not the only one. If you’re attempting to use preferred
HiI am a newcomer to Veeam. I am backing up to a remotely located NAS using iSCSI. The speed is sitting at < 1mb/s and has been for days. There are no checks in the limit read and write speed under the repository settings and there are no bandwidth restrictions under network traffic rules. Are there any other settings that could be causing this restriction? Many thanks
We're installing a storeonce 3660 FC and noticed quite a poor performance during network-free backup.The setup is as following:Primay storage alletra 5000 16Gb FCBackup Gateway server 8Gb FCStoreonce 3660 16Gb FCVeeam 12.2.The storeonce has been configured as repository with FC activated and the gateway server can reach it correctly, SAN has been zoned.The JOB is configured with storage integration and it creates the Alletra snapshot mounting it to the gateway server.Given such configuration the backup job is running at about 200MB/s where the same job using a diskbased target via FC as well is running at 1GB/s, which make sens of the 8Gb gateway server's HBAThe SAN Fabric is made of 2 switches, one is an 8Gb Blade switch and the second is a SN3000 16Gb switch.Th Gateway server is connected to the Blade Switch while the Alletra and the Storeonce are connected to the external 16Gb switch
Hello community! Recently, I ran into an issue where AIX backup jobs were taking longer than expected to start. After digging around, I came across a very useful Veeam KB article (KB2014) that suggests testing disk I/O to identify potential bottlenecks, especially useful when backing up to tape or dealing with performance inconsistencies.I decided to try out one of popular tools for benchmarking and simulating disk workloads: DiskSpd (for Windows).Step 1 – Install Disk Benchmark ToolMake sure you have the following installed: diskspd– Microsoft’s free disk performance tool for Windows. Step 2 – Run DiskSpd on WindowsHere’s the command I used:diskspd.exe -c25G -b512K -w100 -Sh -d600 D:\testfile.datExplanation of parameters: -c25G → Size of the test file (25 GB). This should reflect the typical size of your restore points. -b512k → Block size of I/O operations. -w100 → 100% write test (you can adjust for read/write mix if needed). -Sh → Disables hardware and software caching for a
We are a service provider and using VCC and VSPC. We have two repository like NAS and cloud repository. We had connected multiple company with VSPC through VCC and taking backup to VCC NAS repository. We need to make a secondary copy of NAS repository to redunent and highly available the customer data.How can we do the redundency of repository like NAS to Cloud in Veeam Service Provider?
Hello folks,I asked to the forum but maybe one of you have the answer. I configured a Veeam Azure Appliance, my policy is the following:DailySnapshots:Create 6 snapshots and keep 24 snapshotsBackups:Create 1 backup per day and keep for 30 daysWeeklyCreate restore point at:12:00 AMSnapshots:Keep 1 weekly snapshot (6 days excluded)Backups:Keep weekly backups for 1 month (6 days excluded)Monthly :Create restore point on:1st day of the month at 12:00 AMSnapshots:Keep 1 monthly snapshotBackups:Keep monthly backups for 12 monthsMy VAB is linked to a VBR. On my VBR when I browse the backup properties for each instance I see only Full Backup (vbk files), is that normal with VAB or I miss something ?
Hey folks, I am not going to present a new Veeam tutorial this time!I had some free time ahead of me so I had fun creating the starter pack for our dear Alfred. I think it can be improved, but here's my first version! I hope you'll like it!Next step a video of our dear Alfred?
I have single veeam backup policy with contains of 10 VMs.How we can get backup status for each VM to knowing the VM is backup is successful or not using powershell?
IntroductionIn the first of 4 blog posts of this [Migrate Veeam Infrastructure Off Production Domain series], we described the fundamental security reasons behind moving the Veeam infrastructure components OFF Production domain. Disclaimer: This is not intended to be a complete Security Best practice reference, nor does it address every possible scenario. A Veeam Solutions Architect can be engaged as needed to assist with VBR Security Best Practices, especially with complex deployments. Setup Namespaces:Veeamhol.local (this is the ‘Production domain’) Backupdomain.local (this is the domain in the separate forest, referred to as the ‘Backup Domain’)The scenario is comprised of the following servers:A Production Domain Controller / DNS server A Backup Domain Controller (with 1-way trust from the Backup Domain to the Production Domain) 2 ESX hosts and 1 vCenter Veeam Backup and Replication server (VBR) with local PostgreSQL database Veeam Enterprise Manager server (VBEM) with local Pos
I am currently going through the network segmentation best practices (Segmentation | Veeam Backup & Replication Security Best Practice Guide) and I’m wondering where would be the best zone to place my VB365 server. Part of me thinks Management since it’s a backup server, and part of me thinks Restricted since I am backing up to a local disk.Anyone care to share their thoughts?Thanks!
As some of the Veeam staff probably know, I am definitely NOT Veeam's biggest fan. One reason is because there always seems to be a need to sort of build an environment to suit Veeam. As a service provider, I've always looked for solutions that best fit existing environments with little to no modifications. I've also been very big on ease of installation, ongoing administration, and intuitive interfaces for managing everything, I wouldn't rate Veeam as the best at any of that.However I do continue to see a lot of people who say "Veeam is the best" and "Veeam is great" and "Veeam solved all of our problems", and also threads like this veeam-backup-replication-f2/broadcom-vm ... 91924.html where there's plenty of people discussing needing to find a way to build their entire infrastructure around "what works with Veeam", so in that case only considering VMWare alternatives if Veeam supports it, and so I've finally decided I need to just ask:What am I missing? What does Veeam have that no
We are thrilled to announce the release of new versions of Veeam Backup for AWS (v9) and Veeam Backup for Microsoft Azure (v8). These updates bring significant improvements and feature enhancements to our backup solutions, strengthening our Veeam Data Platform and offering even more powerful protection for cloud workloads.What’s New in Veeam Backup for AWS (v9)?Veeam Backup for AWS has undergone several upgrades to streamline and enhance your cloud backup experience:Amazon Redshift Serverless Protection: We’ve added support for protecting Amazon Redshift Serverless, providing users with an easy and efficient way to back up and restore their data across serverless clusters in AWS. AWS Organizations Support: Enterprise customers will benefit from the addition of AWS Organizations support, allowing centralized management of backup tasks for multiple AWS accounts. This significantly simplifies the configuration and protection of workloads across hundreds of accounts, perfect for large-sca
Good morning community,just a quick question regarding the Linux hosts authentication. Regarding Security & Compliance Analyzer, it’s best practice to set this to manually.Is the only option, to get information about the current acknowledged systems so far, by exporting them, and check the exported file? Is there an option to get these informations from the config-database or from anything else?Couldn’t find anything int the user guide: Adding Computers to Trusted Hosts List - Veeam Plug-ins for Enterprise Applications thanks in advance, best regards Markus
Good day. Our enterprise manager server has crashed and we wish to create a new server. How do we go about that.
Hi Folks,I would appreciate if someone can offer a suggestion on how to troubleshoot the following error: Error: Failed to create snapshot: Backup job failed.Cannot create a shadow copy of the volumes containing writer's data.VSS asynchronous operation is not completed. Operation: [Shadow copies commit]. Code: [0x80042306]. This is the result of an attempt to backup a Windows folder, which is on an ReFS disk F: (the folder has about 5 GB of content and the disk F: has 150+ TB of free space). The backup repository has about 28 TB of remaining capacity. The repository is on a ReFS disk mounted as disk E:.Stuff that I already tried:Rescanned the backup repository Recreated the backup repository Restarted the backup server Tried to backup other folders on drive F: with same resultsAppreciate any input.Thank you!-sul.
We are setting up a test backup job for a VM. After creating and running the backup it fails with the following error: “Failed to create processing task for VM Error: No such host is known” I’m also a newbie to the Veeam environment. I logged into the Veeam server to ping the VM in question and was able to get a response. Any suggestions?Thanks,
Hi AllLong time lurker, first time poster, I have collated a bunch of info from my home lab setup with Veeam Data Platform to create a full upgrade/patching guide for all the products to try and help people plan upgrades and keep on top of patchingIt includes the upgrade paths and guides forVeeam ONE, Veeam Enterprise Manager, Veeam Backup And Replication and Veeam Recovery OrchestratorHope this helps some peopleAny feedback is always welcome <3https://blog.leaha.co.uk/2025/04/10/veeam-data-platform-12-3-upgrade-guide/
Yesterday Veeam launched its newest accreditation track - Veeam Technical Specialist. Find more details about this new course and start the course via ProPartner Portal:https://propartner.veeam.com/veeam-technical-specialist/
We started sending backup copies to S3 (backblaze) and I noticed that I had to configure the backblaze repositories to use Direct connection type or specify the vbr server as the proxy. Since this is a new configuration to Backblaze is there something else that needs to be done configuration wise on VBR or Backblaze to use a Gateway server or is it better to use Direct?
When decommissioning a Veeam Backup & Replication server instance, the log collection in Backup Enterprise Manager continues to run for those Veeam servers. Due to this, the collection logs always show as failed because the server is no longer in existence. Since I need to retain the backup logs for audit purposes, I cannot remove these Veeam instances from the BEM console since that also removes all audit logs for that Veeam instance. I’d like to request a feature to disable log collection for Veeam instances that no longer are functioning but still need to be retained in the console for audit purposes. This way I know if the log collection is successful on existing servers that still need it.
I don’t know what to do anymore, perhaps somebody knows to help.There were a minor problem on the local target RAID6, which was solved by the RAID controllers patrol read.Before i noticed the issue the 3 chained B2D job were already running, failing and stopping. I remember hard stopping one because it was hanging in infinite loops.From that time i was trying since a few days now to get those 3 chained B2D jobs running again.But doesn’t matter what i do, if i try to run the job(s), run a health check, try to use the repair option which is given for the 1st of the chained group, if i try to disable the job and try all again…. it always ends very fast with the error:”Some metadata sections are missing or corrupted”.It’s the same on all 3 jobs in the chained B2D group.The source isn’t the problem, cause a backup to tape job running without any issue.From my understanding since i didn’t find any other repair option in Veeam, the only route left is to delete and loose all restore points in
Hi ALLWe got hit with FOG Ransomware and i am looking for tools that can help Decrypt the VBK file. Please post any suggestions.
When I add and rescan the server in VEEAM backup and replication communication, error is appear : 4/7/2025 5:47:12 PM Warning Failed to connect to xxx.xxx.xxx.3 Details: Failed to call RPC function 'EpAgentCollectSystemInfo': [WMI] Empty result. I was enable all services and inbound firewall related RPC such as WMI ; RPC ; WRM on domain. (server in domain active directory)Log file : [07.04.2025 17:45:47.498] <17> Info (3) -------------------------------------------------------------------------------------[07.04.2025 17:45:47.498] <17> Info (3) STARTEPAGENTDISCOVERYJOB[07.04.2025 17:45:47.498] <17> Info (3) b1977272-5e9e-47bd-bdae-e91d23f5506a[07.04.2025 17:45:47.498] <17> Info (3) 58612558-af3f-4225-a21c-72c77993cae5[07.04.2025 17:45:47.498] <17> Info (3) -------------------------------------------------------------------------------------[07.04.2025 17:45:47.501] <17> Info (3) [CJobLogsManager
So i have a SQL server that wanted to have a backup of. Today i setup veeam BandR console on another machine with a portable ssd as repository. Right now i have the job running a full windows backup thinking in case i need to restore the whole server i can restort to a VM or another physical server is SQL-1 goes down ..correct? Now my job has appl aware on for SQL and trunking trans log. Would that be correct? Or should i change to SQL veeam plugin and Windows Agent server edition instead of using console. Im looking at the fastest recovery process. Now im getting another server to mirror SQL-1 so would be SQL-1 < < > > veeam console < < > > SQL-2 so the backup its just a precaution. Is it my current job correct? Thanks.
Hello, As of this morning one of my Veeam consoles is having jobs with Guest Processing enabled fail.Veeam Version 12.3.1.1139Failed Connecting to guest OS via RPC Error: Retrieving the COM class factory for component with CLSID {Removed} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). Steps I’ve tried:Rebooted server with Veeam Console installed. Rebooted source VM whose replication & backup jobs have guest processing enabled. Confirmed that the credentials in use are still accurate by signing directly into the VM using them. Verified neither Veeam console nor VM being backed up had Windows updates installed last night or this morning. Tested guest processing using a different domain admin account to rule out profile corruption. Ping from Veeam device to VM works with no dropped packets. Verified it was possible to browse from the Veeam console server to the VMs Admin$ share with the original domain admi
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.