News, guidelines and various community projects
Recently active
Deprecated: This script will not work with Veeam Backup & Replication v12. For v12 support, please use the VSPC-HostedUsage scripts. The PowerShell script to retrieve Veeam backup usage for VMware Cloud Director (VCD) Organizations is now available on VeeamHub! Below is a brief description of its functionality. For more detailed information, please follow the VeeamHub link.For each organization, the following is provided:Total number of VMs in backups Total amount of space used in repositoriesThe usage data can be aggregated on the Organization-level or the Org VDC-level. This is useful when backups for different Org VDCs are billed differently.The scope of the usage returned is also customizable. It can be limited to self-service backups, created by the Veeam Self-Service Portal (VSSP) for VCD, or it can also include backups created directly on the backup server by the provider.NOTE: Before using this script in a production environment, I recommend you verify that numbers match up
Hi All, I recently migrated some replicated VM’s on our VMWare infrastructure to a new DVSwitch and updated VLAN names, so I had to update all the Veeam replication jobs, when i tried to automate this using the Veeam powershell library I got the following error on 95% of the jobs. I did a little investigation but didnt manage to figure out what the difference was between all the failed jobs and the 3 that successfully updated. Has anyone ever seen this error message before ? Set-VBRViReplicaJob : Broker service has not started hierarchy collection for host xxxxx Here is a simplified version of the script i was using:# get all replication jobs$jobs = Get-VBRJob | Where-Object TypeToString -eq "VMware Replication"foreach ($job in $jobs) { $jobOptions = Get-VBRJobOptions -Job $job # get list of network objects on new target dvswitch $destSwitchNets = Get-VBRViServerNetworkInfo -Server "<server with new dv switch>" | Where-Object SwitchName -eq "NEW SWITCH" # build array
Hello,As I know the VBO we will charge per users, how if I want to backup sharepoint only? The license still count per users, or per sharepoint site to be backup?
so I am using Windows backup agent for Windows on my desktop stored on my NAS. however, I wanted to test it so I went to Virtualbox created a generic Windows 11 VM added some files and programs and installed Veeam for Windows, and created a backup. the backup finishes with no problem. I then created a different VM using the same settings as the first one. and tried to recover the test VM. but every time I attempt a bare metal restore I am faced with Restoring (C:) Error: Failed to decompress LZ4 block: Bad crc (origaal crc: e230c ...Restore failed: Failed to decompress LZ4 block: Ba Restoring (C:) Error: Failed to decompress LZ4 block: Bad crc (original crc:Saving restore logs Error: Unable to save recovery | e230c2bb, current crc: d7baf3cf). Failed to download disk'Volume[227052a4-8674-407e-9278-b900d454d9f3}'. Agent failed to processmethod {Data Transfer.SyncDisk}. Exception from server: Shared memoryconnection was closed. Failed to upload disk. Skipped arguments:[2714b7c9-3652-4f04-
I got this error in Backup job Action for the VMware Virtual Machine running Linux OS. Linux Credentials is added to the job and action is passed. Also requirement packages is installed. Linux Veeam agent is not installed.Connecting to the guest OS via VIX Error: The session is not authenticated.Why this happened? And I don't understand what is VIX, its work only with Veeam agent?
Hi Team,I've protected an Azure VM and now I want to restore only specific files and folders. However, the "Restore files and folders" option is grayed out and I am unable to click on it.For the VM protection policy, I selected both the snapshot and backup VM options.Can you advise on why the file restore option might be disabled and how I can proceed with restoring individual files and folders?
From June 3-5, 2024, some of the smartest and most attractive minds from around the globe gathered in Fort Lauderdale, Florida to listen and talk and then listen some more about all the fantastic new features coming to the Veeam family of products. There are lots of blogs that have already been published or will be soon covering the great innovation that’s coming from Veeam. This article highlights the ones specific to the Veeam public cloud products and SaaS products. So here we go! New in Veeam Backup for Microsoft365 v8Primary Backup Immutability Linux Proxies Proxy Pools MFA for console Private and shared channels support Microsoft Backup Storage Integration New in Veeam Backup for AWS v8FSx Windows File Server Lustre OpenZFS NetApp ONTAP Can be configured as hybrid to migrate or synchronize from on premise file-system Highly available leveraging Availability Zones Veeam can backup and restore FSx files shares Safely store data in AWS Backup Vaults Incremental backup method
Hello, I encountered this error today while checking my backups as usual. Has anyone encountered this before? How can I solve it?
I am trying to take backp of MS Teams chat per users, but while adding user in a backup job the team chat option is not showing. I am confirm that user has teams chat data.
hello everyone,I'm trying to install the update from both executable and ISO always returns this error.- Veeam with PostgresSQL DatabaseInstead if I launch the same executable with a SQL database it works.has it happened to anyone yet? Is there any bug?thx p.s.solved by stopping the following services
Hi Expert, Is it possible to set backup retention as "Permanent"? If yes, how to?Because customer has the requirement to keep long-term backup as “permanent”.
Customer is running Windows based ERP system with MSSQL. There is Windows domain on premise. Customer is looking to test backup where we need to bring up environment in sandbox, so they can login and manually verify data. What would be best way to do it?
Regarding the backup configuration for a 2-node cluster with SQL Always On: Am i doing the correct process for backup ?add the cluster in the protection group. Create the backup job as a Failover cluster. Backup entire computer. Enabling guest processing for taking SQL Backup & Log backups. Concerning restoration:What are the types of restores that can be performed ? How to perform the restore the complete failover cluster and the SQL Application with Always on using Veeam if the failover cluster servers are crashed.
Hello everyone,is it possible to run Veeam for Salesforce with gui (ubuntu) or is only the ubuntu server variant approved?Best regards
I’m running 11a on an Enterprise sub on Server 2016. Initially, I was trying to upgrade 11a (11.0.1.1261 P20230227) to the latest 12.1.2 via ISO, but later I updated to 11.0.1.1261 P20240304 just to see if the 12.1.2 upgrade would work.Everything is fine until after I select my license. At that point, I get the error that “Version string portion was too short or too long. (Parameter 'input')” and the installer crashes out. I’ve got a support case open, but it’s been a week and we aren’t making any progress. I’m wondering if anyone else has come across this? Should I just uninstall everything and then hope the existing DB will update successfully when I install 12.1.2 and point it to the DB?[ERROR] System.ArgumentException: Version string portion was too short or too long. (Parameter 'input') at System.Version.ParseVersion(ReadOnlySpan`1 input, Boolean throwOnFailure) at System.Version.Parse(String input) at System.Version..ctor(String version) at Veeam.Setup.PrereqEngine.Prereq
I have a job that failed job finish unexpected and it stuck on stopping .i restart the services , the server , the proxy and nothing works what should I do ?
We have Veeam Backup and Rep. We are currently backing up vSphere VMs and AWS EC2 instances (using Veeam agents).We want to start backing up the AWS EC2 instances without the Veeam agents. In the deployment guides, it looks like you have to deploy an EC2 instance called “Veeam backup appliance.”We have a site-to-site VPN between our on-prem and AWS tenant.Is there any reason the appliance couldn’t be in vSphere? Does its existence in AWS allow it some additional access that it can’t get while in vSphere?
Trying to install Veeam 12.1.2.172… from a downloaded ISO. Setup goes to the 2nd screen, to tell me that it needs to be run by an account with Local Admin privs. Same result on 3 machines - 1 physical and 2 VMs. Two standalones and 1 Domain connected. OS: Windows Server 2025.26227 Any ideas?
I have a different error- Failed to index guest file system. Failed to zip folder 'c:\users\.....Appdata\Local\Temp\GuestIndexData.zip. I am seeing the below warning on backup jobs. We have VEM installed so cannot disable Guest indexing. Backup will complete successfully with this warnings. Using Domain admin account for Guest processing and indexing. Warning :Failed to index guest file system. Failed to zip folder 'C:\Users\tn\AppData\Local\Temp\66ddcb73-b3b1-4fea-8333-ffa67ef9aace' to file 'C:\Users\tn\AppData\Local\Temp\66ddcb73-b3b1-4fea-8333-ffa67ef9aace\GuestIndexData.zip'VBRCatalog is saved in C: drive and have 386 GB free of 599 GBVBR 12.1 version VEM 12.1 Please advise.
Can we use Azure Blob Cold Tier (not cool) for VBO repository?
Had a system go down it is backed up with Veeam however I need to ensure that the last backup is not deleted automatically. I inherited this system recently and have not had time to explore it. I am waiting on my support purchase to go through to get assistance but this is critical that I don’t loose this back up file. I found the option to export it and did that. But how to I tell Veeam not to delete it? This seems like it should be a simple Right click mark as don’t delete. Am I missing something. Any help appreciated.
I am trying to figure out how to use Veeam Community edition from the DOS commandline. The application mentioned in https://helpcenter.veeam.com/docs/agentforlinux/userguide/backup_job_start_cmd.html?ver=60, so veeamconfig job start --name <job_name>, is however absent on my system.Is this a Community edition limitation?
Veeam for Mac is a data protection and disaster recovery solution designed for endpoints and virtual machines running macOS. With Veeam Backup for Mac, you can back up all user profiles data or individual files and folders. When disaster strikes, you can restore individual files and folders from backups to their original location or a new location.Why use Veeam Agent for Mac?Using Veeam Agent for Mac and not the default “Time machine” offers numerous benefits as mentioned above. But, let us look critically into some of the core benefits.Veeam Agent for Mac supports various backup destinations, including local storage, network shares, and cloud storage thereby providing users with the flexibility to choose the most suitable option based on their needs in order to adhere to the 3-2-1 Rule. With Veeam Agent for Mac, you can continue an interrupted backup session from where it stopped. Regardless of whether this is due to a network outage or someone closing your laptop while your backup jo
VeeamON 2024!Well, VeeamON 2024 in Ft. Lauderdale is officially over and like after all previous 5 I've been to, I'm reflecting on all that happened while there. For those unaware, this was Veeam's 10 year VeeamON Conference anniversary, and I must say…what a way to celebrate it with a BANG 💥 Opening Day General Session/KeynoteThe "main" conference got underway not with Anand (Veeam CEO), but with a customer: Ft Lauderdale's CIO Tamecka McKay. She shared how the city used Veeam to recover from a rain disaster over a year ago. After she spoke, Anand shared some interesting numbers, one of which I'm proud to contribute to – "99.4% of questions posted on Veeam's Community sites/resources were answered by Veeam Influencers and the Veeam Community." WOW! What an impressive number! He also talked about "Data Resiliency", what this means, and how to achieve this with Veeam via 5 pillars -> Data Backup: using Veeam's various Backup options such as Backup From Storage Snapshots or Replicati
I am trying to understand how to deploy Veeam Backup and Replication in 2 DC’s hosting with VMware Virtual Infra in an active-active environment. Scenario VMs being replicated from DC1 → DC2 and DC2 → DC1 both requiring near-zero and CDP. Number of replicated VMs in each DC is between 20-30 and data size is 6-10TB with average change rate.My thoughts:Deploy a VBR + Backup repo instance in each DC. Deploy backup proxy each in DC1 and DC2. This pair will be managed by the VBR in DC2 and used for near-zero replication Deploy backup proxy each in DC1 and DC2. This pair will be managed by the VBR in DC2 and used for CDP Deploy backup proxy each in DC1 and DC2. This pair will be managed by the VBR in DC1 and used for near-zero replication Deploy backup proxy each in DC1 and DC2. This pair will be managed by the VBR in DC1 and used for CDP Kindly provide your comments or suggestions. The Veeam documentation for a two way DR are not very clear. Can someone also provide links to any clear docum
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.