Join discussions around Veeam community projects, Veeam events, industry and technology news
Recently active
I need to migrate a bunch of Hyper-V VMs to a new Windows server for the first time. While researching different options I have seen some info online that Veeam can do this, but I can’t find clear instructions for VBR. Does anyone have any info or links on a guide? Or does this require additional Veeam software? I see various methods are available, but I’m getting into VBR and VBO and want to see what other tasks I can do with Veeam. Plus it seems like it may be an easy task with Veeam since we are already backing these up with VBR.
Hi, In a customer’s VBR 12.3.1.1139 server (free license) we are having some trouble achieving reliable backup times. It’s a big deduplicated file server (11TB of disks total) running on a Hyper-V VM. The software is installed on the host (WS 2022) and it backs up both host and vms. The backup repository is a QNAP NAS with 30TB of space connected via NFS with 10GB/s network. We tried having a job with periodic synthetic fulls and sometimes it took “only” 10 hours, but more often than not it would take more than 2 days.When this happens it seems to get “stuck” at a certain percentage so we cancel the job to leave room for it to continue making its daily backups.Same when merging backups in a forever incremental situation, sometimes it merges data in 3 hours, sometimes it takes 30, for the (presumably) same reason. The console says bottleneck is Target, but the NAS is pretty much new and it’s DEDICATED to backups only, there is nothing else there, the CPU does not work hard and the disk
升级到 veeam v12.3.1.113,但此客户端更新界面无法关闭。我该怎么办?
When updating a vcenter server appliance, part of the process is to replace the old vcenter VM with a new VM that has the same name.The problem I encounter is that the Veeam backup job fails because it seems like it’s trying to continue to backup the old VM which was deleted.…Processing vcenter Error: Cannot find Linux guest credentialsUnable to connect to guest OS for guest processing. Cannot find Linux guest credentialsError: Cannot find Linux guest credentials …Keep in mind that this VM was previously excluded from guest processing and indexing. I even removed the vcenter exclusions and re-added them to the job but when you run the guest credentials test, vcenter is listed twice and fails the tests even though its excluded. That VM shouldn’t even be tested since guest processing and indexing are disabled for Windows and Linux.Below are the errors from the guest credentials test:…6/5/2025 5:03:47 AM Failed Photon OS guest OS requires Linux credentials or a transport service installed
I have veeam latest version v12.3 and an existing redhat 9.3 server which I want to convert to a hardened repo. I know there are steps to setup a new server but this is an existing OS with the storage mounted already. I need to add all the STIG hardening etc so can someone share these steps before I add it as a hardened repo.thanks.
当前的 VBR 版本是 v12.1.156,我需要升级到最新版本的 veeam,即 v12.3.1.113,但它提示备份任务正在运行。我该怎么办?
Hello. Looking for feedback on installing the Veeam Windows agent on a desktop machine that’s managed by Microsoft CoPilot We have a service account with a known good password. VBR requires that the credential be entered as “DOMAIN\username” . But since the target machine is managed with CoPilot, it seems to need logins to use “username@DOMAIN” When we try to use the “DOMAIN\username” credentials to push the agent, we are getting a “invalid username or password” error from the VBR console, even though we’ve tested the account and we know the password is good Is there any way around this account format issue? we did try entering the credentials in VBR as “user@DOMAIN” but that didn’t work either.
Result of my attempted backupHello again, As you can see from the image above, there was an issue with my backup and none of it saved, the rest of the error info that I could copy is: 22/05/2025 10:45:03 :: Error: Cannot process pending I/O request (offset: 598344892416, size: 65536): async reader terminated Corrupted block processing thread failed unexpectedly Failed to upload disk. Skipped arguments: [EmulatedDiskSpec>]; Agent failed to process method {DataTransfer.SyncDisk}. Exception from server: Cannot process pending I/O request (offset: 598344892416, size: 65536): async reader terminated Unable to retrieve next block transmission command. Number of already processed blocks: [453602]. Failed to download disk 'FA96EA97' Any advice on how to proceed? Thanks!
We have created a backup job for SQL Server, to generate Full + Incremental backup and transaction log backups, and configured GFS for all the database backups (physical servers with GFS policies as well).In the environment there are three SQL Servers as part of an Always On Availability Group cluster.The backup of the DB run and then finishes OK.The Transaction Logs portion, says that all the 44 DB has been skipped.What could be the posible causes that makes the transaction logs not been backed up?On the documentation I've found that to became subject to log backups there are some conditions: - Databases in the Always On Availability Groups for this node were successfully backed up for the last two processing intervals.The backups has been executed for the last 10 days, and no transaction logs has been backed up.Does the backups and transaction logs has to be run on the primary SQL Server?
Replication Job issues, unable to replicate virtual machine from the source to destination host. Error: VDDK error: 1 (Unknown error). Value: 0x0000000000000001 Failed to download disk 'VDDK:vddk://[Datastore-Replication] GTBHELP01_replica02/GTBHELP01.vmdk'. Shared memory connection was closed. Failed to upload disk 'vddkConnSpec>' Agent failed to process method {DataTransfer.SyncDisk}.
Hey guys,I have the same random problem with my Proxies (Windows), VMDK are still attached to my proxies randomly once the job finish. The proxies are not backuped during the different backup jobs. The Vms that Veeam processed is found to require consolidation.On the vmware side I found a log " Unable to access file since it is locked An error occurred while consolidating disks: Failed to lock the file. Consolidation failed for disk node 'scsi0:0': Failed to lock the file." at the end of the backup job.But I don’t find the root cause. Have any of you ever encountered this problem?
I’m encounter error when I adding the linux server for immutable repository. Anyone can help?
VBR Migration to New Server Error when accessing User and Roles.Did a test migration from an old VBR to a new server. Most functions and configuration migrated successfully, just need to re-enter credentials for the cloud, storage (NAS and immutable). Backup jobs are also running successfully and configuration backups are working. However when I went to Users and Roles, I got the error below, “Failed to unprotect data:…..”. I thought initially, it was just the encryption so I enabled but still get the same error. What is causing this issue? Thanks.
I’ve been in the process of redesigning my Veeam network for the past month. I can’t decide between a management/security domain for my Veeam components, or just going the workgroup route. I consider our setup small and fairly basic: two VMware hosts in one location, and another in a backup location.Is a domain for Veeam that much safer? I already have my network isolation setup and configured with VLANs, and I just feel like adding another domain to manage is a waste of hardware resources, licensing, and my time.I’ve read the Veeam Best Practice Guide “Workgroup or Domain?” chapter so many times, I think I can recite it from memory.I appreciate any thoughts that other Veeam experts have on this subject. Especially for smaller setups like mine.
Received a notification from our NOC saying that the C drive was filling up, took a peek and noticed that there were a lot of log files in CheckpointRemoval but Im unsure if these are safe to delete or at the very least, zip up. Any help is appreciated!
We want to confirm the process/reason they are seeing repeated connections every 3 minutes to our linux servers during the backups being performed by Veeam. All linux servers have oracle and no redo logs configured Erased the Ip address on the 3r column which i actually Ip address of Veeam server]$ last | grep "May 29"l pts/4 Thu May 29 08:13 still logged inf pts/4 Thu May 29 06:53 - 06:53 (00:00) Initial findings:Ip in the 3rd column is Veeam server The started and end reported time is backup scheduled timeConformed Backup processing time is reported in logs . When backup is not running , I’ve checked on TestDB and the last login from Veeam was 07:49 – 07:52: and no 3 min repeated connections oracle pts/1 Thu May 29 07:49 - 07:52 (00:03)oracle pts/1 Thu May 29 07:46 - 07:49 (00:03)I need to know why Veeam is making the repeated connections during the backup and not just connecting and staying connected Is there a “keep alive” process or is the con
Hello,does anybody has usecase to backup VM by VBR1, vi copy job sent to offsite repository and read image from this repository and restore by VBR2? Environments are completely independent.My idea is to have script and copy to another folder and with another script make scan and import of images to have permanent solution.
Hi all,would you like a setting for a dark mode on the community side?Dark mode means dark background of the site and bright writing. I have switched to dark mode in many applications in the last time, because it's much more relaxed for my eyes when using the PC and/or phone the whole workday.What do you think? Does this make sense for this community site? Seems that you cannot add a poll after creating a topic.So I will count the positive and negative reactions in the comments by hand and update here 😎11 pro dark mode 2 contra dark mode 2 undecided
Hi everyoneI'm experiencing an issue with one of our Veeam backup jobs where the process fails consistently with the following error:Error: Failed to do TLS handshake.Possible cause: Unknown errorDetailed info: Reconnectable protocol device was closed.Context: Veeam Backup & Replication is being used for a daily VM backup job. The failure occurs for a single VM. The backup job retries multiple times, but ends with 0 bytes transferred and a final error after approximately 2 minutes. TLS handshake failure seems to prevent the backup from initializing. No successful backup was performed (0 B read, 0 B transferred). What we’ve tried so far: Verified basic network connectivity. Restarted both the Veeam Backup server and the affected VM. Confirmed that the VM is reachable and responsive. No recent configuration changes were made to the VM or the infrastructure. Questions: What could be causing the TLS handshake to fail in this context? Could this be related to certificate
Hello everyone,My Veeam B&R server is running on a Windows 10 VM and I’m about to migrate it to a Windows Server VM. I’m going to take the opportunity to migrate to PostgreSQL for the backend at the same time. I’m more comfortable with PostgreSQL than SQL Server and it will reduce our licensing costs.I recently went through a VMWare to Hyper-V migration (thanks to Veeam it was very straightforward).The downside is that I must maintain the legacy VMWare backups until the end of the retention period and maintain the new Hyper-V backups in parallel. I can’t afford a reset on block tracking or whatever references are maintained for XFS reflink usage.With a migration to a new server and new database engine, relying only on the Veeam B&R backup .bco file, is there any danger of losing changed block tracking data or resetting the reflink index, triggering a requirement for a full backup? With thanks,Simon
Hi All,In Vault Foundation the immutable retention is 30 days but does this works the same as immutable with object storage? Where 30 days is actually 54 days?Or am I missing up stuff?https://helpcenter.veeam.com/docs/backup/hyperv/hiw_immutability_os.html?ver=120Thanks
Hello,It’s possible to get job status (warning, failed or success) using powershell script?
Hi everyone,I encountered a strange behavior while migrating a customer this week and would like to share my experience and possibly get answers about the root cause. Scenario: Veeam Instant Recovery from Hyper-V to VMware Source: Hyper-V host (WS2019 Datacenter) and WS2019 Standard guest with 2 disks (OS=NTFS / DATA= ReFS)Destination: Esxi v8 (vSphere Enterprise plus)Backup Server: WS2022 standard with Veeam B&R Enterprise 12.1.2.172 What I did for many VMs with success and with a very short downtime :Backup source (running VM) to a local repository Stop source VM Backup (incremental) to the same repository Instant Recovery to vSphere Install VMware Tools Reboot VM Check if everything is working Migrate to productionBut on this WS2019 guest with a ReFS data volume, at step 4, just after the guest boot, the volume showed as RAW… I found this in the ReFS log on the guest :Event ID 7: "ReFS failed to mount the volume. Version 3.7 doesn't match expected value 3.4" After googling for a
Hello,I’m trying to add a Cluster object in a new Protection Group as `Microsoft Active Directory Objects` and at the credentials tab when I click on `Test Now` I get this error.9/23/2022 5:19:21 PM :: Processing Microsoft failover cluster XXXX.XXX.local Error: Failed to get cluster nodes
Hi all,from idea of @kristofpoppe I propose this to share the many scripts we use and would like to share with the Community spirit.Every month we will share a script that you send me with a description of the functionality, accompanied by some screenshots and if the source is not you if you can provide it.What do you say we start?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.