News, guidelines and various community projects
Recently active
IntroductionHPE VM Essentials offers a streamlined virtualization solution designed for small to medium-sized environments. In my previous blog post, Navigating HPE VM Essentials Part 1, I introduced this platform and discussed its potential impact.In this update, I aim to provide a high-level overview of the user experience with HPE VM Essentials and demonstrate how to configure backups in such an environment. This includes insights into the provisioning interface and the integration with Veeam's backup solutionsEnvironment SetupFor this functional test, I configured a simple environment to explore backup strategies for HPE VM Essentials. A physical Windows server was set up to act as the Veeam Backup & Replication server. All necessary Veeam roles, including the backup server, proxy, and repository, were installed on this single server to streamline the testing. Additionally, the test leveraged a physical HPE VM Essentials cluster, which housed the source VMs designated for backu
Hi all im new to veeam and i have been testing the software. to put it simply, i have the following testing envrionemnet and i want to achieve the following test env1 x Veeam backup server1 x Hyper-V cluster (2 Hyper-V host)1 x VM runnin on the Hyper-V Cluster1 x iSCSI Volume for hyper-v that is running on NetApp Storage (ONTAP) what i want to achieve is to integrate netapp to veeam so that it can leverage ONTAPs snapshot technology to backup the hyper-v vm in a faster manner. i have following numerous diffrent sources on the internet to integrate netapp to veeam but the volume just doesnt appear, only if i include the option for VMware, it shows the volumes on the storage infrastructure section. if there is any official document regarding veeam x netapp x hyper-v integration, it would be more than appreicated if anyone can point me to the right source. if anyone has achieved what im trying to achieve, it would also be appreicated for you go gvie me some tips! thanks in advance all
I am new to Veeam, so I apologise if this is a stupid question.I have a number of remote sites that each have a Proxmox server. Each of these servers is connected to my home using a TailScale network. There is a Linux VM acting as a subnet router.I am trying to use the latest version 12.3 of Veeam to backup the VM’s on the remote sites to a small NAS installed in each site. Basically, I want to manage the backups from a central location, but the backups actually take place at the remote sites.I can register the remote Proxmox servers centrally, but when I run the test on the worker created at each site, it looks like it will run OK; it starts the worker, connects to it, but then always fails on the connect to core services, and occasionally fails on failed to obtain IP address.As a test, I have disabled the firewall on the central backup server and the worker VM. But the errors are the same.I have tested the connection between sites using several other applications, and it works well a
Hello,I wanted to verify if the Veeam Management Pack for Microsoft System Center v9.1.0.3107 is supported in System Center Operations Manager 2025.We have it running on our test environment and it seems to work but we want to validate before we upgrade our production SCOM environment.Kind Regards,JM
Heads up, all threat hunters.I recently encountered a problem with several customers using ThreatHunter. It happened that mounting the file system needed to crawl the system didn't work. However, mounting the file system for a single file restore worked fine. It turned out to be a small bug in the code and there is already a private fix for this, and it will be included in the next release:So if you encounter this problem, just file a case with Veeam support and get your private fix in the meantime. According to the registry keys that come with the fix, it seems to have something to do with certificate revocation.However, everything works as expected once the fix is in place.
We have installed Veeam in a Standalone Hyper V host, and we can perform backups of all virtual machines in this Hyper V host. All the VMs are in drive D of the Hyper-V host. Is there a way that I can do a backup of the C Drive of the Hyper V host so that we can restore the server and then restore the Virtual machines in case the Hyper-V Host fails? Do I need to install a Windows agent in the Hyper V host? What is the best approach?
Hi All,Does veeam also upgrades the database version during the upgrade process? (ms sql or postgres)Because when upgrading from 12.1 to 12.3, Postgres version was still 15.8,how do I know if there will be an update? Will vulnerabilities be patched to address them?
Hi allWhen I try to install the hyper v component for veeam on a hyper v windows 2016 virtual machine I get the following error.I turned off UAC. Other things I can do? It doesn't recognize it as a hyper v machine
Hello Community,I prepared an article to report my experience in backing up Oracle databases with FS agent and RMAN plug-in. I hope it can be useful.Thanks to my colleagues @marco_s @ggrippo Keeping backup data from an Oracle-type database is always complex. The world of Oracle DBAs is strongly inclined to remain locked in the comfort zone shell, and getting through it is never too easy. Meanwhile, they wonder why, if any backup tool uses RMAN commands, they have to rely on other people when they can do everything themselves.Today I am going to present a real scenario of installations on Oracle Linux VMs.But I start by showing the schematic of how Oracle backup works with the pluginSCENARIO: All the machines on which Oracle is present are Linux VMs on OLVM so it was necessary to provide for the installation of the File System type agents and Plug-ins for Oracle RMAN.The databases were both RAC type and single databases. A network card was added to all vms on a dedicated backup VLAN t
Hi!Ubuntu 22.04 server has veeam agent 5.0.2 installedbut the backup job shows this error: Error: Failed to execute agent management command startBackup. table JobSessions has no column named end_timeUnable to run query.
Oracle backup fails with error "failed to execute plug in manager command: no data to read"
When we backup our outlook using VDC, the processed object mean total of our users?In this pic can i say 829 is total user backup by VDC?
Introducing Linux Proxies in Veeam Backup for Microsoft 365 v8: A Step-by-Step GuideWith the release of Veeam Backup for Microsoft 365 version 8, the introduction of Linux proxies brings new flexibility and scalability to your backup infrastructure. These proxies can now be pooled, offering enhanced performance and resource management. However, setting up a Linux proxy may not be a routine task for many users, which is why I’ve created a straightforward, step-by-step guide to simplify the process. Deploying a Linux proxy is not always straight forward...This guide provides a clear, easy-to-follow "recipe" to deploy a fully functional Linux proxy with minimal effort. By following the instructions and using the provided commands, you can quickly set up your proxy and get started. For the full tutorial, visit: Instant Recipe for Veeam Backup for Microsoft 365 Linux ProxyWhile this guide focuses on the core setup, it’s important to note that additional considerations such as security h
Hi,Whilst I appreciate Netplan isn’t Ubuntu 22.04 specific, I thought I’d note the version in the title for any eventual changes.As the title suggests, I was building a bonded interface for a server recently and was having troubles with Netplan not utilising the configuration properly.For background information, I was trying to create a simple active-backup bonded interface, so that should one NIC fail, another interface should carry on serving traffic. When I’m working with network switches of shall we say, questionable quality, I sometimes prefer utilising a simpler active-backup network resiliency mechanism vs configuring active-active methods that can cause compatibility issues between server OS and switch, especially when you’re playing with 10/25GbE. Ways of Monitoring Interface Failures As a primer, there are two ways of monitoring an interface failure, these are: MII Monitoring:Set with ‘mii-monitor-interval’ within Netplan, MII (Media Independent Interface) is the monitoring o
Hi all,i have currently an environment with multiple jobs in VBO365 (latest version).All regular jobs are running fine.As a fallback, we have defined a catch-all job. Under normal circumstances, there shouldn’t be an object in it…And that’s our case - if the job has nothing to backup (as it’s processed in other jobs), the state will trigger a warning message → this will create an alert in the customers Monitoring Solution. Is there any option to disable it? Or do you have some suggestions for me?Thanks and best regards, Markus
Dear Community, We have agent-based backup configured for database backups, but our DB team has raised concerns regarding I/O Frozen occurrences while the jobs are running. Additionally, the logs are being truncated every 30 minutes. If anyone has insights or best practices to address this issue, please share your recommendations if anyone has insights or best practices to address these issue recommendations. Your guidance would be highly appreciated. Thank you.
I create a file level job backup and only need to backup .xls files like below picture But when the job is running, why my backup consume more than 300GB? Actually when i filter in the machine, all xls files under E:\ is not more than 50 GB.Capacity of my E drive is 7.4TB and now the job say is 5% progress which mean the VBR like backup all entire disk without any file filtering.Anyone know why?
I’m attempting to backup an entire Ubuntu 24.04 computer with the Veeam Agent for Linux. The destination is an external USB drive. I can do this with a Windows 11 computer and the Veeam Agent for Windows with no problem.However, when I try to do the same thing with the Veeam Agent for Linux, I’m given an error message that the destination path is included in the backup. As far as I can remember this used to work.Why does this work now only in Windows but not Linux?
Well here we are! Episode 200! What can we say, this is an awesome community. I decided to do something special in this week’s recap and go back to where we started. That’s right, I reached out to @Kseniya → And we are happy to check in with her to see how she is going on in her new role. A big thanks to Kseniya on starting the operations here but also ongoing tireless work from @Madi.Cristil, @safiya and @NikolaPejkova. Beyond that, many don’t know that also @Viperian, @Rin, @kirststoner12 and @Julia F Morgado also do a lot with our community. We couldn’t do it without you all!Back to business as usual, we have a solid list of content to share. Check out this week’s episode here (and be sure to see the surprise I put in the video): Featured Contentvia @SSimpson via @coolsport00 via @Michael Melter Vanguard Blog Spotlight - Muhammad Adelvia @mhmdadl The Amazing Adventures of Backup squad - How to explain backup to a 4 years old kid - Archtonic Special Department NewsIf you
What happen if we use file level backup then we have connectivity issue and the job is failed, will in next retry the VBR continue the backup or will start from beginning?
Fellow Veeam Legend @MarkBoothman shared an interesting post on the VUG UK Community page and I thought it highly relevant to also be shared with the main Community as a whole as well.Today Anton Gostev, Chief Product Officer at Veeam, created a couple posts on the Veeam Forums I think those anxious for the release of Veam Backup & Replication v13 should be aware of. Starting in v13, Veeam is beginning to deprecate some features, as well as streamline system requirements to make their product better, more secure, and performant. The posts can be viewed at the links below:VBR v13 Deprecated FeaturesVBR v13 System RequirementsOne item of note some of you Linux gurus should really be aware of in the Systems Requirements is the deprecation of CentOS completely → whether VBR or Agent for Linux. So keep that in mind. Some older OS and application versions are also being dropped. So if you haven’t migrated your systems/applications to a newer OS/version, you might want to start consideri
Hello Community,I am facing the following problem.We are using an archiving (HSM) solution where the archiving application uses the NetApp Fpolicy Engine for mirgation. After migrating files off a NetApp smb share to s3 storage, the NetApp fpolicy engine leaves a stub at the original location. This "stub" is used to recall the file back to the original location when it is accessed. These stubs cause problems when backing up through veeam. During Nas backup (Share and using the NetApp storage integration) the stubs are not backed up, it causes a recall from the archive. (This is not what you want). On a Windows Fileserver veeam handles these stubs well. These stubs are called NTFS Reparse points. The stub file has the L (Reparse) and O (Offline) attribute set. When doing a Windows Fileserver backup these reparse points are, by default, skipped. No setting needed. This is the correct way to handle stubs. I assume this is because of the "L" attribute of the reparse point. The NetApp Fpoli
Hello, we added file-indexing on our ubuntu 24.04 lts-servers today and started the backup of each workload.Veeam detects all files with extension .sophos and .lynx as malware.The files with extensions .sophos are 100% clean, these is our sophos endpoint detection for linux.The lynx-files looks also normal and not like malware. Can we exclude thee files for each workload? I only see the option to exclude a complete workload. Detected files:/opt/sophos-spl/.sophos/usr/share/doc-base/lynx-common.lynx/usr/share/doc/w3m/keymap.lynx/usr/share/doc/w3m/ja/keymap.lynx/usr/share/doc/w3m/ja/examples/keymap.lynx/usr/share/doc/w3m/examples/keymap.lynx/usr/share/wazuh-dashboard/plugins/wazuh/node_modules/brfs/test/
Hello, In this article, I will talk about Veeam Direct Restore to Azure feature. What is Direct Restore to Azure? Included in Veeam Backup & Replication ™, Veeam Direct Restore to Microsoft Azure allows users to import and restore on-premises VMware and Hyper-V virtual machines, physical servers, and endpoints to Microsoft Azure. Restore Microsoft Windows and Linux-based virtual machines, physical servers, and endpoints with Restore to Microsoft Azure. Today's modern data center is not limited to the location of the physical data center. IT organizations can optimize resource allocation and further improve operational scalability and efficiency with the Microsoft Azure cloud. With Veeam Direct Restore to Microsoft Azure, administrators can restore and migrate physical (P2V) or virtual (V2V) workloads to Azure without the need for complex configurations or additional hardware investments, thereby minimizing operating expenses. Quickly restore workloads to Azure Quickly and efficient
Hello everyone!In this post, I will explain how to utilize one of the key features of Veeam Backup & Replication, which is the ability to test the integrity of created backups. Introduction Creating the Virtual Lab Creating the Application Group Creating the SureBackup Job Testing the SureBackup Job Introduction SureBackup uses created backups to initiate VMs in an isolated environment within the hypervisor and then perform tests like heartbeat, ping, and application validation using scripts. It's a fantastic functionality to ensure that your backups are intact when needed.SureBackup utilizes the following components:Application Group - Group of VMs to be tested together. With the Application Group, we can define the startup order of VMs and set tests for each of them. Virtual Lab - The Virtual Lab is an appliance created by Veeam B&R on the hypervisor to act as the gateway of the isolated network that will be created. SureBackup job - The SureBackup job where you can schedule
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.