Join discussions around Veeam community projects, Veeam events, industry and technology news
Recently active
We have licensed Veeam via Socket License and want to Backup our Windows DCs from a different Console than the Rest.They are running on the same ESXI Hosts as the other VMs we already Backup.Is this possible with our license?
Hi, I’m trying to make room in my backup repository for new backups. My previous retention was set to 90 days and the oldest backup is from 45 days ago. I changed the retention to 30 days, thinking that Veeam will then delete the backups between 31 and 45 days ago to make room, but it’s not doing that. Is there a way to prompt it to do that? I’ve tried to rescan the repository and also re-running the Backup Job, but neither seems to work. Thank you!
Since this product is part of the Veeam family now I headed over to checkout what there was on the website. Very interesting courses. I did the ones that they offer to non customers and wrote for the other two requests to be allowed in given the fact that they really could use some Veeam evangelists on their side now 😁. We will see if they give in. Either way head over to their site and check out the courses, very interesting stuff https://education.securiti.ai/certifications/ai-governance/
Hi,Previous I have turn on backup notification but now after turn off, email is still send ? Any idea where I can turn off ? Sample email notification
Hello Community! I am new to Veeam (last used 7 years ago, so might as well be new). Here is my current setup: I have two Mini PC’s running Proxmox as the “Compute”.They are connected over 10GB to a different server running TrueNAS, via iSCSI.So the VM “Data” does not actually reside on the Proxmox machine, it just acts as the compute side. Now, I have installed Veeam on a Barebones Windows machine. I configured the Veeam software to connect to the Proxmox servers (success) and it installed the proxy’s.First backup tested was successful, but the others failed.They show “succeeded” but with “Warnings” and no actual data has been backed up.“disk scsi0 has been skipped due to unsupported storage type” I find this odd since the storage type on the successful backup is the same as the other VM’s I am running, (Three Ubuntu VM’s & Home Assistant OS). Any insight would be appreciated!
I just updated the Veeam Agent version to 6.3.2.1302 on my home computer. I don't use a server because it's a single machine with a single backup job, although I do use the Community Edition in other environments.I re-burned the recovery agent to a USB drive, and when I tested it, neither the keyboard nor the mouse worked. The BIOS recognizes them fine, but when the agent starts loading, it disconnects them.I've tried having up to three different keyboards connected to different USB drives, and re-burning the USB drive four times, making sure the option to copy drivers is enabled, but nothing seems to work. I've never had this problem on this computer before.With this and the previous bug that prevented me from recovering backups from a network drive, which has since been fixed, I'm starting to think I spend more time trying to fix Veeam errors than actually using it.Any ideas on how to fix this?
Hi,I would like to backup with Veeam backup and replication 12 my new physical NAS with TrueNas Core.How can I proceed ?Do I need to add my TrueNas like an “unstructured data source” ?If so, what option should I choose in next window? File server, File share or NAS filer ?Thanks for your helpRegards,
Hi, new install of veeam with a dell poweredge server and powerstore connected via iSCSI. this will be a hardened repo.Has anyone tested the optimal settings for Veeam including immutability against the powerstore so the powerstore can still perform the data reduction tasks?
Hi Community,Recently i install Veeam Agent on Windows Server 2008 R2 via VBR 12 Inventory and got an error Failed to Verify C:\Windows\Veeam\Backup\Upload\VeeamDeploymentDll.dll Signature I found this page https://www.veeam.com/kb4677 and explain 2 possible causesAntivirus Block → Root and Intermediate CA is missingTo confim the issue we look at C:\ProgramData\Veeam\Backup\Svc.VeeamInstaller.log and gotFailed to verify file using the Authenticode provider. Verification status: A certificate chain could not be built to a trusted root authority. (-2146762486), last error: A certificate chain could not be built to a trusted root authority. All are pointing to Certificate Issue, so i install all CA listed on Veeam here https://helpcenter.veeam.com/docs/backup/vsphere/trusted_root_certificates.html?ver=120.After installing all CA still got same issue here. Are i missing something here? Any insight would be appreciated!
Hi All, I have a VBR 12.3.2 server running in AWS as an EC2 instance. Use Windows agent on other EC2s to back them up to an S3 scale-out repository. The backups work as expected. I am able to do file level restores with no problems. When I try to do a restore to EC2 (create a new EC2) I get the following error “Unable to import the instance from an encrypted volume snapshot” when I click Next on the Reason screen. I do have it set up to use a helper appliance. Do you have any thoughts on how to get this working? The volumes of EC2 that are backed up are encrypted with an AWS-managed key (aws/ebs). But shouldn’t it be pulling from S3 for the restore? Thanks for any help you can provide.Scott
Query related a IAM user and IAM role: Suppose if any customer has a Multiple AWS Accounts with Control Tower Environment AWS setup, approx. 50+ account and want to take a backup of instance and DB backup using veeam backup for aws appliance, is it possible using single IAM user and single IAM role to take backup of all workload of this separate account . Require a IAM role permissions for Control Tower Environment AWS setup, In veeam documentation it is not available.
Additional Details: Veeam Agent for Linux backup job fails with the following errors:[error] Failed to create volume snapshot[error] Failed to take volume snapshot[error] Failed to perform backup [error]Veeam snapshot kernel module not foundSystem informationSO: SUSE Linux Enterprise Server 12 SP4Kernel: Linux version 4.12.14-95.32-defaultkernel-default: kernel-default-devel-4.12.14-95.24.1.x86_64kernel-default: kernel-default-devel-4.12.14-95.32.1.x86_64kernel-default: kernel-default-devel-4.12.14-95.128.1.x86_64dkms version: dkms-2.6.1-9.1.noarchveeamsnap: veeamsnap-kmp-default 6.3.2.1207_k4.12.14_94.41VBR Console: 12.3.2.3617VAL: v6.3.2.1207I read ready the list of compatibility with extended Linux distributions of veeamsnap and blksnap https://www.veeam.com/kb2804 couldn´t see the compatibility for a 4.12.14-95.24 or 32 or 128 also on rpm veeam repository I don't see a version(*)After to installed manually veeamsnap-kmp-default-6.3.2.1207_k4.12.14_94.41-sles12.4.x86_64.rpm and cons
I have VBR installed in Site-B to backup VM under hyper-v and vmware in Site-A.Connection from Site-B to Site-A using ipsec vpn site to site with 2 internet link for redundant.The VPN have same policy for both connections. When the link use primary link then the VBR can backup the VM but if the primary link and connection switched to the backup link then i got error only for Vmware when using backup proxy.I try to ping from the backup proxy in Site-A then the proxy is able to reach HS-W2019.This error mean the backup proxy is not able to connect to the HS-W2K19 on port 2503? Error: Failed to connect to the endpoint [HS-W2K19:2503]. A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
I have recently installed the Scale Computing plugin into our Veeam B&R 12.3.2 server. If we are currently using Microsoft Agent Backups, is there a migration path to moving to direct VM guest backups via the Scale plugin? If not, can I utilize VM guest backups via Scale plugins for 'new' guest servers and also back up pre-existing servers using the Microsoft Agent method?
Because of the new v11-feature of immutable backups on XFS filesystem, I am looking for real-world experiences with XFS as Repository.I just read through this forum entry:https://forums.veeam.com/veeam-backup-replication-f2/v10-xfs-all-there-is-to-know-t65222-30.htmland the closing experience of user ferrus:https://forums.veeam.com/veeam-backup-replication-f2/v10-xfs-all-there-is-to-know-t65222-30.html#p388579 Sounds very good to me so far. I can remember first implementations of ReFS Block Cloning. Lets say, it does not work that fine at the beginning.Would you share some of your experiences with XFS as Veeam Repository? I would be interested in:stability performance (over time) needs for troubleshooting administrative effortThanks!
Hey everyone,As we prepare for the upcoming update that introduces support for Veeam v13 on Windows, I wanted to ask:What migration strategy are you planning to adopt and why ?Will you simply upgrade your existing Veeam Windows server to v13? Or do you plan to migrate to v13 and then transition to the Veeam Software Appliance?So far, I haven't found any official discussion about the migration process from Windows to Linux. Ideally, I'm looking for a solution that allows me to back up and restore my settings during this migration. Personally, for all new projects, I’m planning to propose the new Linux-based appliance, even though some aspects still require optimization and improvement. In cases where migration is possible, I would tend to recommend switching to the appliance for smaller infrastructures as well — mainly to benefit from the native hardening layer and eliminate Windows licensing costs. Smaller companies often have limited time to dedicate to cybersecurity.For larger infras
Hi all,the in place upgrade of Veeam ONE 12.3.x to 13.x doesn’t work. The MSI packet for the monitor client won’t be found. The path to the MSI file is shown as “1” and giving the correct path to the mounted ISO ends in an error message that the MSI doesn’t fit to the system (Windows 10 22H2).What can I do? At the moment I do not plan to update my Windows machine. My way is to go away from Windows in the next months.Kind Regards
You might have found the same information when you upgrade the previous version of Veeam Backup and Replication server to v12.3.2.4165.The version shows 12.3.2.3617, not 12.3.2.4165.After the upgrade is complete, verify the Veeam Backup & Replication version from the Veeam Backup & Replication console (Help | About). It shows the correct version information.
Hello everyone!Veeam 12.3.2.3617, Community Edition, Workstation Backup by veeam agentI’m having an issue with one of my home PCs. When I try to back it up, an error appears.29.09.2025 21:31:17 :: Error: Unable to resend traffic block '15863' because traffic history doesn't contain this block. History low block id '15869'.Failed to upload disk. Skipped arguments: [EmulatedDiskSpec>];Agent failed to process method {DataTransfer.SyncDisk}.Exception from server: There is no traffic block '15863' on the source side.Unable to retrieve next block transmission command. Number of already processed blocks: [25496].Failed to download disk 'bdd448f6-e7b0-4f2b-93b3-6eb675ad51c3' Backups of two other PCs to the same storage complete without any problems. What could be causing this behavior?I tried replacing the target HDD — it didn’t help; the error can also appear when backing up the SSD (the drive’s health is normal, no errors).I tried different backup types (volume, file-level, entire PC) —
Hi everyone,Im going to update Veeam from 12.3.2.3617 to 12.3.2.4165. How much storage should I keep free to upgrade it?Regards.
Here’s one to find out who has the largest backup in the forums. Currently my largest server I backup is 45.1TB. The largest one I had backing up was 115TB. It took a while but worked fine. I’ve been working on splitting it up in to multiple file servers to allow more concurrent streams to our backup/tape jobs.
Hi everyone, So we just made the switch from Symantec Backup Exec to Veeam a couple months ago, and so far I'm very happy. With Backup Exec however, you had the option to permanently retain backups, which seems to be missing from Veeam. For Windows Agent backups, Veeam forces you to choose a retention period for a maximum of 730 days or restore points. Problem is, this customer requires permanent retention with the ability to restore data from 10 or 20 years ago, if possible. What are my options here with Veeam? Isn't there a way to disable the retention policy or retain data beyond 730 days? And believe me, I've looked at all of Veeam's program options and haven't been able to find anything to this effect. We can't be the only company with a permanent retention requirement. Thanks for your help!Kurt
I’m running Veeam B&R v12. Veeam is the only backup software I’ve used that doesn’t have the option to backup a single server from a Backup Job. It’s all or nothing.
Seeking field experience for a Veeam repository on HPE Alletra 4120 (Linux Hardened repo) does SSD cache drives deliver measurable gains (ingest/synthetic/merge) compared to simply adding spindles?
Hello All, I need to take backup from postgres cluster using Veeam, the postgres is deployed in clustered nodes (3-nodes).As I know and did it before, we can use Veeam Agent for Linux to backup single node holding the postgres database, then I can perform the restore for the file using Linux FLR. Here I have some points to be discussed :1- I know we can perform image-level backup for the VM holding the postgres, and ask the DB admin to provide us pre or post-thau script. In this cause, would it be better to use Linux agent backup on the VM instead of VM-backup? What is the pros and cons for using Agent or VM back with postgres? 2- can we create a script from our end as backup admin as simple script if the customer does not have his own script? In this case appreciate if someone explained how the script works? 3- how can we backup clustered machines, do we have to install Linux agent on all cluster nodes? How can I point the nodes to take backup and restore? Comparing to Microsoft SQL
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.