Question

Veeam Sleep Timer after waking from sleep


Userlevel 3

My Veeam is set to wake, backup, and sleep at around 4am. When I later wake my computer during the day a pop up comes up saying “Veeam completed backup and will sleep in:” and then a 60 second timer before it autosleeps. I assume this is the same timer that is used at 4am to autosleep my computer, but for some reason that dialog stays active after sleep and I need to cancel it. I will try to get a screenshot the next time it comes up tomorrow.


16 comments

Userlevel 7
Badge +10

Hi @sarmen94 

assuming you’re talking about Veeam Agent on your workstation/laptop I’m pretty sure this message is not by Veeam. 

please share your screenshot when is possible. 

Thanks

Userlevel 7
Badge +21

As mentioned please share the screenshot and confirm the agent is installed and version.  Based on what you have said it appears to be agent.

Userlevel 7
Badge +19

Hi @sarmen94 -

See here in the Agent for Windows job Guide and how this setting works:
https://helpcenter.veeam.com/docs/agentforwindows/userguide/backup_job_schedule_free_desktop.html?ver=60

Veeam then directs you to another Guide section for “post-job actions” explanation.
https://helpcenter.veeam.com/docs/agentforwindows/userguide/post-job_activity_prompt.html?ver=60

It appears the prompt which displays should have a ‘cancel’ option, at which is supposed to let you continue to work...and this is assuming the prompt which displays is a Veeam Agent Backup prompt.

VAW Post-Job Action

If the prompt which displays is Windows-based, then you’re subject to Windows behavior. As others have shared, a screenshot would provide more info for us to assist.

Userlevel 3

So this is the prompt, the issue is that when it runs backup at 4am and the computer goes back to sleep, I feel like this window should close. However, the next time I use my computer it pops up automatically, and if I don’t see the window (sometimes its under other windows) my computer sleeps after 60 seconds a SECOND time.

Userlevel 3

Also here is the version of the agent

Userlevel 7
Badge +21

So this is the prompt, the issue is that when it runs backup at 4am and the computer goes back to sleep, I feel like this window should close. However, the next time I use my computer it pops up automatically, and if I don’t see the window (sometimes its under other windows) my computer sleeps after 60 seconds a SECOND time.

Not sure why it would do this.  It might be a good idea to open a Support ticket to see why this is working this way as I too would think it should not come up again after going back to sleep.

Userlevel 3

And this is how the backup job schedule looks

Userlevel 7
Badge +21

And this is how the backup job schedule looks

So based on this is should sleep after the backup and then when you use the computer not prompt about sleeping.  It is like it is not dismissing the window.  Still think a support ticket is the best route as we can only provide suggestions here as it is a community not technical support.

Userlevel 7
Badge +19

Hi @sarmen94 -

Thanks for the screenshots. So yes...this is obviously a Veeam Agent screenshot. You should be able to select Cancel and it not go to sleep. Obviously, if it is under other Windows and you forget about it, it doesn’t do much good. You have a few options here, although none would directly resolve the issue you’re experiencing → 1. open a Support ticket and see if they have some resolution which isn’t stated in the User Guide; 2. make a feature request on this behavior in the Veeam Forums.  Product Managers can give you insight on the probability of being able to make your requested change and/or at the very least possibly provide a resolution; or, 3. something you may not want to do...change from Sleep to either ‘Keep Running’ or Shutdown, altho my guess is “Shutdown” would behave similarly as “Sleep” but instead of Sleep actually shutdown your computer.

Userlevel 7
Badge +19

Hi @sarmen94 - I’m just following up on your post here. Do you still have questions? If not, and one of the comments helped you, we ask you mark one of the comments as ‘Best Answer’ so others with a similar question who come across your post may benefit.

Thank you.

Userlevel 3

Hi @sarmen94 -

Thanks for the screenshots. So yes...this is obviously a Veeam Agent screenshot. You should be able to select Cancel and it not go to sleep. Obviously, if it is under other Windows and you forget about it, it doesn’t do much good. You have a few options here, although none would directly resolve the issue you’re experiencing → 1. open a Support ticket and see if they have some resolution which isn’t stated in the User Guide; 2. make a feature request on this behavior in the Veeam Forums.  Product Managers can give you insight on the probability of being able to make your requested change and/or at the very least possibly provide a resolution; or, 3. something you may not want to do...change from Sleep to either ‘Keep Running’ or Shutdown, altho my guess is “Shutdown” would behave similarly as “Sleep” but instead of Sleep actually shutdown your computer.

  1. I have the free version so I can’t make a support ticket.
  2. The feature exists already, I think it just might be a Windows setting or something causing the issue?
  3. I will try this today and report back!

Thanks

Userlevel 7
Badge +19

Hi @sarmen94 -

You actually can get support with the free Windows Agent. See the Guide on how to proceed:

https://helpcenter.veeam.com/docs/agentforwindows/userguide/support_report.html?ver=60

Well, the behavior is initiated by the Veeam Agent. The process under the covers is Windows. But it seems the Agent isn’t behaving accurately. It would be beneficial to at the very least report what’s happening to Support.

Keep us posted.

Userlevel 3

Just opened a support ticket, thanks!

Userlevel 7
Badge +19

Just opened a support ticket, thanks!

No problem.

Any chance there was a resolution found for this? This is happening to me as well with the latest Veeam Agent release with Win 11 23H2. It seems to only affect Windows 11. I’ve updated two computers to Windows 11, both now have this sleep message upon awakening and and it was fine with Win 10. 
 

Thanks

Userlevel 7
Badge +19

Your best bet is to probably open a support case with Veeam @kghoops

Comment