Solved

Use local storage for Agent on VM


Userlevel 3

Hi,

I have installed Veeam agent on my windows 11 VM. I have a external hard drive connected to the physical host and shared the drive.

I have it mapped on my VM.

I cannot see it in my options for destinations.

Is there any thing I can do to get this working?

 

Thank you in advance.

Colin

 

icon

Best answer by dloseke 22 September 2023, 18:06

View original

18 comments

Userlevel 7
Badge +21

If it is a shared folder on the USB drive, try using SMB to connect to it through the Agent.  These are the options you have to back up to.  Note the SMB (CIFS) section.  Would need to use \\hostname(IP)\sharename for connection.

 

Userlevel 7
Badge +19

Hi @IT Admin - can you share a screenshot of the issue you’re having?

Thanks

Userlevel 3

 

@Chris.Childerhose I have tried the smb option and I get the below

 

 

Userlevel 3

Hi @coolsport00 , so i have the drive shared from the hyperv and mapped on the VM like so below.

Once I select local storage I have nothing displaying in the drives here.

 

Userlevel 7
Badge +21

Can the VM ping the host with the drive attached?  You cannot use mapped drives in the Agent that is why it does not show up.

From the VM, try accessing the SMB path just within Windows to see if you can get to it.  If not, there could be Firewall or something blocking it.  Also try to ping the IP/FQDN of the host with the drive for backups to see.

Userlevel 7
Badge +21

 

@Chris.Childerhose I have tried the smb option and I get the below

 

 

Also, for this if you type in just the \\IP and then click Browse - does the share show up then?  The Veeamdrive label - is that the sharename?  Just wondering on this one.

Userlevel 3

@Chris.Childerhose Ya veeamdrive is just the label i have on it.

 

I have tested the ping ok and tried just the Ip as you said.

 

 

Userlevel 7
Badge +19

Hi @IT Admin - what virtualization product are you using? To see the drive on your Win11 VM as a local storage option, you would need to configure USB passthrough to your VM and make the storage a USB-attached Volume within your VM. You won’t be able to see mapped/shared storage in the Local Storage option of the Agent Destination area.

I am playing with a VAW job myself and am not able to browse to a file share as well. But, how I know I can connect to the Share?...if you click the ‘Populate’ button and see the storage amount display. I can’t figure out at the moment why when I click Browse I can’t browse to the Share to actually see the remote directory. I know this happened before and I ended up figuring it out...but can’t remember what I did. Hmm...🤔

Userlevel 7
Badge +21

@Chris.Childerhose Ya veeamdrive is just the label i have on it.

 

I have tested the ping ok and tried just the Ip as you said.

 

 

Maybe for the shared folder enter in - \\192.168.1.6\”sharename”

You don’t require the volume name in the SMB path - then try clicking populate to see if it will.  Also, you might need to check the share requires access credentials and put those in to test.

Userlevel 3

@coolsport00 I am using hyperv-manager. I have looked up to try and attach the HD to the VM from the manager application in settings but it has not worked for me.

Userlevel 7
Badge +19

@IT Admin ok...I haven’t played around too much with HV, so not sure how to go about doing passthrough with it. But, you should be able to use your Share as a Repository to store your VAW backup, as I can. When you click the Populate button, does the storage space display?

Userlevel 7
Badge +19

@IT Admin I believe I found why network discovery doesn’t work with VAW. I found this forum post which states Veeam is using the SMBv1 protocol for network discovery. As Windows and most other things disable this protocol due to its security flaws, the Browse function will never work unless 1. SMBv1 is enabled on the remote device, or 2. Veeam changes the network discovery protocol used for VAW. I’m quite surprised they are using this protocol, to be honest.

Userlevel 7
Badge +21

@IT Admin I believe I found why network discovery doesn’t work with VAW. I found this forum post which states Veeam is using the SMBv1 protocol for network discovery. As Windows and most other things disable this protocol due to its security flaws, the Browse function will never work unless 1. SMBv1 is enabled on the remote device, or 2. Veeam changes the network discovery protocol used for VAW. I’m quite surprised they are using this protocol, to be honest.

So based on this typing the full SMB path and using populate should work.

Userlevel 7
Badge +19

Yes...as I shared above. My backup works to the Share..I’m just not able to Browse to the Share directory.

Userlevel 7
Badge +6

@IT Admin I believe I found why network discovery doesn’t work with VAW. I found this forum post which states Veeam is using the SMBv1 protocol for network discovery. As Windows and most other things disable this protocol due to its security flaws, the Browse function will never work unless 1. SMBv1 is enabled on the remote device, or 2. Veeam changes the network discovery protocol used for VAW. I’m quite surprised they are using this protocol, to be honest.

Wait...what?  SMBv1 (CIFS)?  How strange.  I’d suggest changing over to using NFS if you have to use a Network file protocol.  I’m using that in my homelab and it’s been working great.

Edit:  Not sure of VAW can do NFS.  I was thinking of VBR.  

Userlevel 3

@coolsport00 @dloseke So I got it working there thank you all for the help.

I did enable the NFS windows features and then used the shared folder and populate as said above.

I was advised by manager not to enable SMB but its working perfect with NFS.

Userlevel 7
Badge +21

@coolsport00 @dloseke So I got it working there thank you all for the help.

I did enable the NFS windows features and then used the shared folder and populate as said above.

I was advised by manager not to enable SMB but its working perfect with NFS.

Great to hear you got it fixed 👍

Remember to mark an answer so others will see if they have the same issue.

Userlevel 7
Badge +6

Great to hear.  I believe NFS will give you better performance than SMB/CIFS as well, plus SMB v1 is considered insecure and would get flagged by vulnerability scanning if you have compliance requirements such as PCI.

Comment