[Quicktip] Overwrite Guest processing when VMs selected by vSphere Tags


Userlevel 7
Badge +5

Probably the following is widely known. But I did not know up to now and found out today. Maybe it is new for others too.

After the Upgrade to v10, suddenly Linux VMs are not getting backed up any more, because defined guest interaction user was domain-based and could therefore not login into Linux VM. So solution would simply be to disable guest processing for this VM. Problem was, VMs were selected by vSphere Tags for this job. Fortunately solution is quite simple:

  1. Edit the job and got to Guest Processing and  click Application

    Here you can see the selected vSphere Tag. When you edit this line, options are set for all VMs this Tag was assigned to.

  2. Press Add → VMs and Tags → expand Tag of choice → select exception VM
     

  3. Select new line and press Edit

    Set option as desired for this/these VM(s)

That's it! This also works for custom Guest OS Credentials:

 

BTW: If you suffer from the same behavior after upgrading to v10 (and probably to v11 as well): Curiously this is not a bug, it is a bugfix. Read in the forum more about this:

https://forums.veeam.com/veeam-backup-replication-f2/veeam-b-p-v10-problem-with-linux-backup-t64978.html#p361284.

You should also enable Guest quiescence in advanced settings this case.

 


5 comments

Userlevel 6
Badge +2

I actually ran into this and wondered what setting the account to Linux:veeam would actually do? VMware Quiescing is set somewhere else and there is no VSS writer 🙂🙂 for Linux.

Does is just allow you to run the job on those vm’s and skip the MS login attempts?

 

By the way and this is probably known but just in case, remember a good idea to use freeze and thaw scripts even if you have vmware quiescing turned on if you are running databases like Mysql. Or just do application dumps. 

 

Userlevel 6
Badge +2

This is very interesting as I have seen this before then ran across that forum post.  Hopefully, this helps anyone that runs into this problem.

Userlevel 7
Badge +3

Great spot!

Userlevel 7
Badge +3

Good description.

I had seen before that you can select anindividual user for each VM, but not, that you can select the guest processing...

Userlevel 7
Badge +5

I actually ran into this and wondered what setting the account to Linux:veeam would actually do? VMware Quiescing is set somewhere else and there is no VSS writer 🙂🙂 for Linux.

Does is just allow you to run the job on those vm’s and skip the MS login attempts?

 

By the way and this is probably known but just in case, remember a good idea to use freeze and thaw scripts even if you have vmware quiescing turned on if you are running databases like Mysql. Or just do application dumps. 

 

Sorry for the late response, @Geoff Burke ! As far as I know, Veeam tries to connect to OS to trigger a VSS snapshot. With Linux you get an error. Application aware means here to run a propriate script.

Please correct me if I am wrong!

Comment