Question

Network path not found, or invalid credentials supplied


Userlevel 1

I have setup a new server on our network. Connected to domain, network, hyper-v installed and I am unable to add this server to the Virtual Infrastructure > Microsoft Hyper-V > Standalone Hosts > (server).  I have my Veeam server trying to contact our new server and there seems to be a road block. I am running Veeam V11a trying to setup a new 2019 windows server. During the hyper-v setup process I have added the name and/or IP address, I have selected the last option (standalone) which matches the description of the new server.  My credentials do work because I ran a test to setup a VM running server 2019 and I was able to set that up right away. For some reason the physical server is blocking the Veeam connection.  Is there a firewall exception I need to add?  I did attempt to manually add the physical server to Veeam so the agent might create its own firewall exceptions. I was unsuccessful at that as well.


14 comments

Userlevel 7
Badge +3

Hi @dhammett 

I would open the windows firewall on the hyperv, connect the hyperv to veeam and close the firewall again after successfull configuration.

For veeam Agent, that always works for me. The necessary ports are open after the agent installation and enabled windows firewall. Could work for HyperV too.

 

You can find more about the required ports on this page for manual configuration:

https://helpcenter.veeam.com/docs/backup/hyperv/used_ports.html?ver=110


For the credentials, please make sure to use the following format:

DOMAIN\USERNAME

Userlevel 7
Badge +6

Hi @dhammett 

I would open the windows firewall on the hyperv, connect the hyperv to veeam and close the firewall again after successfull configuration.

For veeam Agent, that always works for me. The necessary ports are open after the agent installation and enabled windows firewall. Could work for HyperV too.

 

You can find more about the required ports on this page for manual configuration:

https://helpcenter.veeam.com/docs/backup/hyperv/used_ports.html?ver=110


For the credentials, please make sure to use the following format:

DOMAIN\USERNAME

I think this about covers it. One of these steps should address the issue. :thumbsup_tone2:

Userlevel 7
Badge +3

If that works, then it was firewall.

But I remember a topic in this forum that there was a problem abount special characters used in password. Just a tip, never knows.

Userlevel 1

I opened the firewall on the hyper-v host side and then tried all the same steps as before. Still I receive the same error. 

 

Referring to Marcofabbri’s reply could my password with special characters really be the reason I am unable to connect this server? I tried avoiding using the previous two accounts linked because I cannot confirm they are secure enough or not.

Userlevel 7
Badge +6

I opened the firewall on the hyper-v host side and then tried all the same steps as before. Still I receive the same error. 

 

Referring to Marcofabbri’s reply could my password with special characters really be the reason I am unable to connect this server? I tried avoiding using the previous two accounts linked because I cannot confirm they are secure enough or not.

That might be a possibility but the only way to check that would be to change the password on the account you are using or test the connection with one of the other accounts to know for sure.

Userlevel 7
Badge +3

I opened the firewall on the hyper-v host side and then tried all the same steps as before. Still I receive the same error. 

 

Referring to Marcofabbri’s reply could my password with special characters really be the reason I am unable to connect this server? I tried avoiding using the previous two accounts linked because I cannot confirm they are secure enough or not.

Very well, so using older password is working? If yes, we hit the spot!

For strong password, is better use passphrase. Long passphrase with “common special” character kill guessing and bruteforce. 

Userlevel 6
Badge +3

I opened the firewall on the hyper-v host side and then tried all the same steps as before. Still I receive the same error. 

 

Referring to Marcofabbri’s reply could my password with special characters really be the reason I am unable to connect this server? I tried avoiding using the previous two accounts linked because I cannot confirm they are secure enough or not.

Can you verify that you are using Domain\Username format in the credentials?

 

This may seem weird, but try something for me. The domain password you are using, type it into Notepad++ on the local host/server/hypervisor you are using, copy it, and then paste it into the credentials setup in Veeam on the backup server, and then save the credentials. Weirdly, sometimes copying and pasting is the best way to deal with passwords in VMs. Caps lock may be on, something weird may be happening behind the scenes. It is a best practice taught to me by an IT veteran. It sounds dumb, but give it a shot.

Userlevel 1

@marcofabbri I will try a different account then! 

 

@bp4JC My account credentials worked once before when I was testing a VM backup as a file storage device. I assume that first verification is enough to know my account will work. Although if Marco’s idea doesn’t work then I will certainly test your theory and re-setup the server.

Userlevel 1

I changed the account with no luck and I also realized that my enterprise/domain/network account was not an admin on the server.  I already have admin access via domain admin account but I added it to netplwiz to see if that would fix the problem. Still no luck….

I also enabled file sharing on the server to see if that would allow information to be exchanged between the two servers but that did not seem to improve the situation.

 

I will copy and paste my credentials in next week. Have a great Thanksgiving!

Userlevel 7
Badge +3

 


​​​​​​
​​​​I will copy and paste my credentials in next week. Have a great Thanksgiving!

You can always open a support case with veeam. With the logs, you get your answer in 1-2 days for such cases.

Userlevel 7
Badge +3

I changed the account with no luck and I also realized that my enterprise/domain/network account was not an admin on the server.  I already have admin access via domain admin account but I added it to netplwiz to see if that would fix the problem. Still no luck….

I also enabled file sharing on the server to see if that would allow information to be exchanged between the two servers but that did not seem to improve the situation.

 

I will copy and paste my credentials in next week. Have a great Thanksgiving!

Local admin rights has nothing to do with windows' folders access permission. Try check credentials.

Userlevel 1

I copied and pasted my credentials in and received the same error… Any last suggestions?

 

@marcofabbri 

and 

@Chris.Childerhose 

Userlevel 7
Badge +6

I copied and pasted my credentials in and received the same error… Any last suggestions?

 

@marcofabbri

and 

@Chris.Childerhose

At this point opening a Support ticket if you can would be the best thing.

Userlevel 1

Turned off the firewall on the server, went ahead with the config and turned the firewall back on. All looks to be good now. We’ll see how it performs overnight. 

Comment