Solved

Network path not found

  • 18 February 2023
  • 9 comments
  • 5005 views

Userlevel 1

I have 3 issues that I cannot resolve nor find answers to.

I’m running the Windows Community Edition V5.0.0.4708 on two Windows machines.  One is Windows 10  22H2 and the other is Windows 11  21H2. 

These two machines are being backed up to a file share on my TrueNAS server.

The first issue is that from time to time the backup fails with the following error message: “Error: The network path was not found. Failed to get free space on disk '\\xxx.yyy.zzz.nnn\Clients' --tr:Error code: 0x00000035 … The network path was not found”.  I configured the back to use either host name or IP address as the backup target, but it seems to make no difference.  This happens on both machines.

I thought that it might be a timing issue that when the computer wakes up to do the backup, the backup starts before the computer has established a network connection.  On the Windows 10 machine, using the BIOS I able to create a wake up event approximately 2 minutes before the Veeam agent started.  This lessened the issue, but did not completely resolve it.  On the Window 11 box, this option was not available to me to even try.

So, is there a way to have the Veeam Windows Agent wake the computer, then wait a period of time before the backup actually kicks off?

Second question goes hand in hand with the first. 

When the computer fails with it’s backup, sometimes it just goes back to sleep without retrying.  When I see the failure in the morning, I sign on and re-run the failed backup.  No problem there.  But on the last two Saturdays when this happened, the backup was supposed to run an Active Full Backup, but instead, ran just another incremental.  Did the backup not know it was a Saturday?  I don’t know.

My backup schedule is set to run at 01:30 every day creating Incremental and then on Saturday an Active Full is created.  On Sundays I do a health check.  I do a Volume Level backup to a Shared Folder on my server (i.e.\\ServerName\Clients or \\192.168.1.101\Clients) with a retention time of 28 days.  I have specified both a UserName and Password to the share which I know is valid.

The third question probably has no bearing on the first two, but I thought I would ask anyway.

When researching the reasons for the failures in the first two questions, I was looking at the Windows Event log to see if I could see any network issues.  But what I noticed was that the backup on the Windows 11 machine, while scheduled to start at 01:30, did not start until 01:36 or 01:37.  This is an Intel i7-12700 Z690 based machine using only nVME Gen4x4 solid state disks (no spinnners in this system) and it boots very quickly! 

One last thing; I have both Windows 11 and Windows 10 on this machine; not a dual boot, but a completely separate nVME boot drive that I move in and out when needed.  But both Windows versions show exactly the same timing issue.  Both also show the same network issue as in the first question.

I really appreciate it if anybody could answer any of these questions.  The backups mostly run OK and I feel reasonably confident that if needed, I could recover my systems from their backups.

Thank you.

Greg

icon

Best answer by regnor 20 February 2023, 07:41

View original

9 comments

Userlevel 7
Badge +17

Question 3 should be the easiest, Veeam has a random delay to start jobs. This is useful in bigger environments to not start many jobs at the exact same time.

 

Btw, Windows 10 22H2 is not fully supported with Veeam Agent 5. For this you should use Agent version 6 which is available since last week.

Userlevel 1

Joe, thanks for that information!

I have two machines that I backup and I have always started one at 01:00 and the other at 01:30 so that their backups did not conflict.  The one at 01:00 has always started at 01:00.  I used to have a third machine that was scheduled to start at 02:00 and it always stated at that time.  So when this new machine had start times 6 or 7 minutes late, I started to worry that something might be amiss with that machine.

Greg

Userlevel 7
Badge +14

Just like you wrote, I would also have the feeling that the network connection isn't up when Veeam starts the backup. Could it be that your machines install Windows Updates at that times?

Regarding the active full backups. Veeam does them one the first run on the scheduled day. If that fails and you start it manually later on, it will not try to do another one. In that case it's better to directly create an active full backup.

Like @JMeixner said, there's an update available and I would suggest that you try it and see of this improves your situation.

Userlevel 7
Badge +8

Hi there,

Correct me if im wrong, but are you running two instances of the community server in two different machines for being backed up?

or one server, two agents (version 5) to a TrueNas CIFS repo?

I would suggest to scan the net for networking issues, disconnections,
if not unified the unification of 1 server, many clients.
check windows updates time, to not get bandwidth disruptions / high consume

if the client is not active by the time of the task, it should be trigged when the client is back online, am I right?

try and let us know.

cheers-

Userlevel 1

Max, one of the first things I checked was whether the machine was running Windows updates at the same time as the backup.  According to the event viewer, the machine was awakened by Veeam and no other processes where running.  This is not a new problem for me, but going on for quite some time.  That is why, instead using \\ServerName\Clients, I use the explicit address of the server (.i.e. \\192.168.10.20\Clients) as the backup location.  My server has a static address while my clients get their dynamic addresses thru dhcp.

Greg

Userlevel 1

Luis, no, I’m not running any instance of the community server.  I built a file server (ASUS Server motherboard, XEON E-2236 CPU, 64GB ECC memory and 4 x 4TB Seagate Ironwolf drives)  running TrueNAS 12.0-U8.   I use this server as a SMB File server, Plex Media Server and Veeam Backup repository.  I have two clients; one Windows 10 22H2 and one Window 11 21H2.  Both clients have the Veeam Windows Community Edition 5.0.3.4707 installed.  The client that I’m having the problems with is a new build with an ASUS Z690 motherboard, Intel i7-12700 CPU, 32GB memory and two nVME Gen 4x4 SSDs.  While no other updates are happening while the backup runs, this machine would easily be able to handle both task simultaneously.

I’m going to change the time of the backup to much later in the morning 05:00am to see if that helps.

Greg

Userlevel 1

Joe, further to your answer regarding the time the backup starts, I’ve been doing some further testing.  If the backup is scheduled to start at 5:30 and I put the computer to sleep at around 14:30, then the computer seems to wake at 05:39, instead of 05:30.  But lately, I’ve turned the computer off at 14:30 in the afternoon, then powered it up at around 07:30 next morning.  I had previously set Veeam to skip the backup if it misses it’s schedule so no backup occurs.  After I powered up the machine, I modified the backup job to start at 08:00, then put the computer to sleep and wait.  Bang on 08:00 the computer wakes and the backup takes place.  This is how my two other computers work; both wake at exactly the time specified in their respective jobs and do the backup.  Both those machines are Windows 10 Home editions.  The problem computer is a Windows 11 Pro on 21H2, but I have done a BMR to reload Windows 10 Pro 22H2 on this hardware and again, let the computer sleep overnight, the backup starts 5 to 9 minutes late.  Power off the computer, restart next morning, reschedule the backup to start at 08:00 and it starts right at 08:00.

Hope this makes sense to you.  Any more ideas as to why the backups don’t start on time?

Thank you

Greg

Userlevel 7
Badge +6

Hello @GChuck 

If the power scheme on the Veeam Agent computer does not allow using wake up timers, Veeam Agent for Microsoft Windows will not be able to wake your computer from sleep for backup. You can manually change the power scheme settings on the Veeam Agent computer. To do this, navigate to Control Panel > All Control Panel Items > Power Options > Edit Plan Settings.

https://helpcenter.veeam.com/docs/backup/agents/agent_job_schedule_workstation.html?zoom_highlight=wake&ver=120

Userlevel 1

Moustafa, thank you for replying.

The power plan settings for the computer already were set to allow wake up timers.  The computer does wake up, but not at the correct time.  I’ve scheduled the wake up to happen at 05:30, but the actual wake up does not occur until between 05:36 and 05:39.

I think the issue is with some BIOS setting which I’m not familiar with.  The computer is a home built machine with an ASUS Prime Z690-P WIFI D4 motherboard with an i7-12700 CPU, 64GB of memory and two WD nVME SSD drives.  The motherboard is a “gamer” type of board, but I’m not a gamer, but do a lot of video editing so wanted something fast.  Probably should have gotten a Dell or something.

Greg

Comment