Solved

cannot perform instant restore of a linux vm


Userlevel 5
Badge +1

Hello, Thanks, I am not able to perform an instant restore of a linux VM.
I am stuck that the helper appliance dialog box.

I select a server from the list, but the OK button is disabled?

Using VBR 12.1.0.2131

I searched around the forum and internet, could not find the answer
Please advice, thanks, David

 

 

icon

Best answer by coolsport00 25 March 2024, 14:32

View original

16 comments

Userlevel 7
Badge +17

Hi @asdffdsa6132 -

It appears you're needing to choose a proper network on the virtual host for the helper appliance to use to connect to the network with. This virtual host seems to not have a network set up thus the ok button is not enabled. 

Userlevel 7
Badge +5

Hello @asdffdsa6132 ,

do you perform a recover VM from storage snapshots ?

The helper appliance is an auxiliary Linux-based VM registered by Veeam Backup & Replication.

https://helpcenter.veeam.com/docs/backup/vsphere/instant_recovery_helper_appliance_vm.html?ver=120

Userlevel 7
Badge +21

You need to have the helper appliance for Linux restores but as Shane noted the network is not configured on the host.  Also see this for the limitations with Helper Appliances for restores.

Considerations and Limitations - User Guide for VMware vSphere (veeam.com)

Userlevel 5
Badge +1

Note: using hyper-v, not vmware.

This virtual host seems to not have a network set up thus the ok button is not enabled. 

this is a standalone server, WS2022, it is only server
for sure, the host has networking

Windows IP Configuration

Unknown adapter Tailscale:
   Connection-specific DNS Suffix  . : tail0337.ts.net
   IPv4 Address. . . . . . . . . . . : 100.122.213.46
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . :

Ethernet adapter Ethernet:
   Connection-specific DNS Suffix  . : localdomain
   IPv4 Address. . . . . . . . . . . : 192.168.62.233
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.62.1

 

Userlevel 5
Badge +1

Note: instant restore of a windows vm works as expected.

 

Userlevel 7
Badge +21

Note: using hyper-v, not vmware.

This virtual host seems to not have a network set up thus the ok button is not enabled. 

this is a standalone server, WS2022, it is only server
for sure, the host has networking

Windows IP Configuration

Unknown adapter Tailscale:
   Connection-specific DNS Suffix  . : tail0337.ts.net
   IPv4 Address. . . . . . . . . . . : 100.122.213.46
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . :

Ethernet adapter Ethernet:
   Connection-specific DNS Suffix  . : localdomain
   IPv4 Address. . . . . . . . . . . : 192.168.62.233
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.62.1

 

This is the network of the physical Hyper-V machine - we are referring to the networking within the Hyper-V configuration settings.

Userlevel 7
Badge +21

See this page for Hyper-V networking and configuration - Create a Virtual Network | Microsoft Learn

Userlevel 7
Badge +17

Hi @asdffdsa6132 -

Yes, but you need a VIRTUAL network set up for the virtual appliance. Not the physical host network. 

Userlevel 7
Badge +17

Note: instant restore of a windows vm works as expected.

 

Yes, because Windows doesn't require a helper appliance to be set up 😊

Userlevel 5
Badge +1

VIRTUAL network so up for the virtual appliance. Not the physical host network. 

Thanks, that solved it.

Userlevel 7
Badge +21

VIRTUAL network so up for the virtual appliance. Not the physical host network. 

Thanks, that solved it.

Glad to hear that solved the issue.  Be sure to mark the answer in your post that best answered the question so others will see.

Userlevel 7
Badge +17

Glad to hear it's working for you now. 

Userlevel 7
Badge +21

Nice to see the answer marked was completely off from the question and answers given!

Userlevel 5
Badge +1

@coolsport00, Thanks for the solution.
I selected the wrong post to be the answer, but I cannot undo that and select the correct post.

How do I change which post is the answer?

 

Userlevel 7
Badge +21

@coolsport00, Thanks for the solution.
I selected the wrong post to be the answer, but I cannot undo that and select the correct post.

How do I change which post is the answer?

 

You cannot as Admins need to change it.  @Madi.Cristil @safiya - can you undo the answer selected.

Userlevel 7
Badge +17

@coolsport00, Thanks for the solution.
I selected the wrong post to be the answer, but I cannot undo that and select the correct post.

How do I change which post is the answer?

 

@Madi.Cristil or @safiya can unmark this so you can choose the one you want. 😊

Comment