Question

adding hyper-v host failed with "invalid credentials" noting that we dont have domain and the veeam and Hyper-v are on the same subnet


Userlevel 2

adding hyper-v host failed with "invalid credentials" noting that we don't have domain and the Veeam and Hyper-V are on the same subnet.


16 comments

Userlevel 7
Badge +5

Hello @M.Mamdouh !
Please share version of Hyper-V and Veeam you go to use.

Userlevel 7
Badge +17

Hi @M.Mamdouh '

Welcome to the Community. Have you added your HV servers to the VBR hosts file? Also, make sure when adding, use the LOCALHOST\username format. Sometimes, updating the HV host, rebooting, then reattempting to add works.

Try those few things & let us know how it goes. 

Userlevel 7
Badge +9

Hi @M.Mamdouh

I resolved a similar issue here: https://techdirectarchive.com/2024/03/11/invalid-credentials-fix-failed-to-connect-a-hyper-v-standalone-to-veeam-backup/

Userlevel 7
Badge +17

@M.Mamdouh -

We discussed this issue at length in a previous post here on the Community Hub. I provided several other post links as well. The author of the below post shared what worked for him (DECOM security issue with Windows 2022, if you’re using that). You can go through the handful of suggestions there and see if any work for you:

 

Userlevel 2

@M.Mamdouh -

We discussed this issue at length in a previous post here on the Community Hub. I provided several other post links as well. The author of the below post shared what worked for him (DECOM security issue with Windows 2022, if you’re using that). You can go through the handful of suggestions there and see if any work for you:

 

yes we are using win 2022 but the latest updates are installed.

Userlevel 7
Badge +17

Hi @M.Mamdouh -

Is KB5005102 installed? I believe it's an 'out of band' update to where you have to download it manually from the Catalog.

And, if you do have it, have you looked at all the other suggestions I provided above? You also should make sure UAC is disabled and verify Windows firewall is off, or proper rules set.

Let us know. 

Userlevel 7
Badge +9

@M.Mamdouh -

We discussed this issue at length in a previous post here on the Community Hub. I provided several other post links as well. The author of the below post shared what worked for him (DECOM security issue with Windows 2022, if you’re using that). You can go through the handful of suggestions there and see if any work for you:

 

yes we are using win 2022 but the latest updates are installed.

Have you gone through the link I shared above and still having this issue?

Userlevel 7
Badge +9

Hi @M.Mamdouh -

Is KB5005102 installed? I believe it's an 'out of band' update to where you have to download it manually from the Catalog.

And, if you do have it, have you looked at all the other suggestions I provided above? You also should make sure UAC is disabled and verify Windows firewall is off, or proper rules set.

Let us know. 

UAC only needs to be disabled if a new administrator account is created. Else, he only needs to apply windows updates both on the HyperV and VBR server. Else, he might be missing other prerequisites which i have documented in that link above

Userlevel 2

thanks all , the problem solved after reboot the HV and Veeam 

Userlevel 7
Badge +17

Hi @M.Mamdouh . Yeah, we’ve had a couple posts by others on here with the same issue which shared all they needed to do was reboot, thus why I shared to try that first. Glad to hear it resolved your issue. And thanks for sharing what worked with the Community. Don’t forget to mark if one of the provided comments helped you resolve this, so others who may come across your post with a similar issue may benefit.

Best!

Hello,
I have the same problem on a client using Veeam 11 community,
Veeam on Windows 2008 R2 and Hyper-V on a 2022 server.
After installing KB5025230 on w2022 we were left without access.
However, I can no longer remove this KB in w2022. Any solution?

Userlevel 6
Badge +4

Hello

UAC donesn t need to be disabled.

You just need to create localaccounttokenfilterpolicy registry key.

hello,
I added the key to my hyper-v server, restarted it, but the problem continues.
remembering that my Veeam server is w2008 R2. I didn't find any KB that fixes the problem as reported.

Userlevel 4

@Julio CZ 

 

If you are seeing DCOM errors on VBR or HyperV Server then the issue is related to DCOM.

Please refer https://www.veeam.com/kb4376

 

 

hello,
thank's for your time.
Yes, I'm going to have a huge problem, considering that I didn't find any update for server 2008R2. I'm already using a higher version of Veeam, VR11.

 

My DCOM log:
192.168.10.50 is my Veeam Backup

The server-side authentication level policy does not allow the server\xyz SID (S-1-5-21-612518617-895926409-3094583133-500) from address 192.168.10.50 to activate the DCOM server. Increase the activation authentication level to at least RPC_C_AUTHN_LEVEL_PKT_INTEGRITY in the application.

 

thanks,

Userlevel 4

@Julio CZ 

 

You can take a backup of registry and add the below Dword32 values on VBR and HyperV Servers. You need to reboot the servers after the changes.

 

Path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM 
Reg: AllowAnonymousCallback 
Value: 1 

Path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole\AppCompat 

Key: RequireIntegrityActivationAuthenticationLevel  

Value: 0

 

Let me know if it works.

 

Additionally also test your WBEM Test by following the attached document 

 

Ref:  https://support.microsoft.com/en-us/topic/kb5004442-manage-changes-for-windows-dcom-server-security-feature-bypass-cve-2021-26414-f1400b52-c141-43d2-941e-37ed901c769c

Comment