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Resolving SQL Backup Error - Code 0x80040e14 (Dispatch error #3092) / failed: 112(There is not enough space on the disk.)

 

Issue

Backup operation fails with the following error:

Failed to perform internal backup                                                               

Code = 0x80040e14

Code meaning = Dispatch error #3092/ failed: 112(There is not enough space on the disk.)

Source = Microsoft SQL Server Native Client 11.0

 

Root Cause

This error typically occurs due to insufficient space for temporary transaction log (T-log) files during SQL backup operations.

 

Resolution Steps

1. Verify Transaction Log File Size

  • Contact the SQL DB Team to check the size of the transaction log file.
  • Confirm the required space for temporary log storage.

 

2. Check Drive Availability

  • If lacks sufficient space, proceed to request a new temporary disk.

 

3. Request Disk Addition

  • Add a new temporary disk to the server.
  • Disk size should be based on SQL DB Team's recommendation plus 10 GB buffer.

 

4. Configure SqlTempLogPath Registry Value

Depending on the backup method, update the registry as follows:

A. Veeam Backup & Replication

Key Location: HKLM\SOFTWARE\Veeam\Veeam Backup and Replication

Value Name: SqlTempLogPath

Value Type: String Value (REG_SZ)

Value Data: <Path to the new disk location, without trailing backslash>

 

B. Veeam Agent for Microsoft Windows (Machine-Level Backup)

Key Location: HKLM\SOFTWARE\Veeam\Veeam EndpointBackup

Value Name: SqlTempLogPath

Value Type: String Value (REG_SZ)

Value Data: <Path to the new disk location, without trailing backslash>

 

C. Cluster-Aware Backup (Managed by Veeam Backup & Replication)

Key Location: HKLM\SOFTWARE\Veeam\Veeam Backup and Replication

Value Name: SqlTempLogPath

Value Type: String Value (REG_SZ)

Value Data: <Path to the new disk location, without trailing backslash>

 

Reference: https://www.veeam.com/kb2642

 

5. Restart Backup Services

  • Restart the following services:
    • Veeam Log Shipping Service or Transaction Log Backup Service

 

6. Monitor Backup

  • Monitor the transaction log backup for at least 5 intervals to ensure stability.

 

7. Revert to Original Path

  • Once backups are successful:
    • Revert the SqlTempLogPath registry value to the original path.
    • Restart the Veeam Log Shipping Service or Transaction Log Backup service again.

 

8. Cleanup

  • Remove the temporary disk added earlier.

 

Additional Notes

  • Always ensure the path in the registry does not have a trailing backslash.
  • Document the changes and notify once resolved.

Thanks for sharing your issue and problem resolution. I assume this would be for a physical server. If SQL is in a VM, you would only need to add disk space to the Log volume & extend it. No registry change required. Good to know this is available though. 


When I first read the subject I thought it was an issue you were looking for help with.  😂 

Great to see a problem and resolution.  Thanks for the share.