Question

Windows PC Backup Failed - Access Denied


Hi wondering if anyone can help with an error I am getting on a backup

 

I have a few hyper v VMs backing up and a couple of Windows 10 machines.

1 machine is causing a bit of hassle and was wondering if anyone has seen this before.

I see this warning message in the GUI:

26/03/2024 13:55:22 :: Collecting recovery media files Details: Access is denied  

 

I see this in the logs:

[26.03.2024 13:57:35] <01> Error    Failed to add recovery media files to the backup
[26.03.2024 13:57:35] <01> Error    Failed to build WIM file at C:\WINDOWS\TEMP\oovnnf03.5ok\sources\boot.wim (System.Exception)
[26.03.2024 13:57:35] <01> Error       at Veeam.Core.Common.CWimBuilder.Build(String wimPath, Int32 imageIndex, ITaskLog taskLog, ICancelFlag cancelFlag, IWimBuilderAction bootFilesExtractionAction, IWimBuilderAction adkFilesExtractionAction)
[26.03.2024 13:57:35] <01> Error       at Veeam.Core.Common.CWinREFilesCollector.CollectFiles(CWimBuilderOptions options, ICancelFlag cancelFlag)
[26.03.2024 13:57:35] <01> Error       at Veeam.EndPoint.CWinReArchiveCollector.CollectArchive(String path, IStopSessionSync sessControl)
[26.03.2024 13:57:35] <01> Error       at Veeam.EndPoint.CWinReArchiveCollector..ctor(IStopSessionSync sessControl)
[26.03.2024 13:57:35] <01> Error       at Veeam.EndPoint.CRecoveryMediaFilesBackuper.Do()
[26.03.2024 13:57:35] <01> Error       at Veeam.EndPoint.CRecoveryMediaFilesBackuper.Do(CBackupTaskSession taskSess, IOibAlg oibAlg, CBackupClient sourceClient, IBackupRepositoryClient repositoryClient, IStopSessionSync sessControl, CRepositoryAccessor repositoryAccessor, Boolean agentsDisableReCollectionWarning)
[26.03.2024 13:57:35] <01> Error    Failed to copy file 'C:\Program Files\Veeam\Endpoint Backup\Veeam.EndPoint.Recovery.exe' (System.Exception)
[26.03.2024 13:57:35] <01> Error       at Veeam.Core.Common.CCopyAdditionalFilesAction.CopyFiles(CWimAdditionalFile[] additionalFiles, String mountPoint, ICancelFlag cancelFlag, Boolean searchInWinSXS, Boolean throwException)
[26.03.2024 13:57:35] <01> Error       at Veeam.Core.Common.CCopyAdditionalFilesAction.Do(CWimBuilderOptions options, String mountPoint, ITaskLog taskLog, ICancelFlag cancelFlag)
[26.03.2024 13:57:35] <01> Error       at Veeam.Core.Common.CWimBuilder.Build(String wimPath, Int32 imageIndex, ITaskLog taskLog, ICancelFlag cancelFlag, IWimBuilderAction bootFilesExtractionAction, IWimBuilderAction adkFilesExtractionAction)
[26.03.2024 13:57:35] <01> Error    Access is denied (System.UnauthorizedAccessException)
[26.03.2024 13:57:35] <01> Error       at Veeam.Backup.Common.LongPathCommon.CopyFile(String source, String target)
[26.03.2024 13:57:35] <01> Error       at Veeam.Core.Common.CCopyAdditionalFilesAction.CopyFiles(CWimAdditionalFile[] additionalFiles, String mountPoint, ICancelFlag cancelFlag, Boolean searchInWinSXS, Boolean throwException)
[26.03.2024 13:57:35] <01> Warning  Collecting recovery media files Details: Access is denied

 

 

Thanks in advance for any help,

Joe


4 comments

Userlevel 7
Badge +21

Is this log from one of the Windows 10 machines?  If so with the Access Denied error, I would assume at this point permissions related and would need more investigation.

Hi Chris,

Small error on my part I meant windows 11.

But, Yes this is from one of the windows 11 machines

Its strange because im using admin creds for all windows 11 pcs and its just this one with the error.

 

On a further note: The user logged into the PC is the same as the admin creds I am using to run the backup. Could that be the issue? 

I cant run the backup with local admin creds as I am storing to a NAS.

Userlevel 7
Badge +21

Hi Chris,

Small error on my part I meant windows 11.

But, Yes this is from one of the windows 11 machines

Its strange because im using admin creds for all windows 11 pcs and its just this one with the error.

 

On a further note: The user logged into the PC is the same as the admin creds I am using to run the backup. Could that be the issue? 

I cant run the backup with local admin creds as I am storing to a NAS.

I cannot see the logged in user credentials being the issue but are you able to use another Admin just to test rather than the logged-on user?  It would be a way to narrow it down possibly.

Userlevel 7
Badge +17

@loughraj - another way to possibly narrow down where the ‘access’ issue is, is to look at the other Win11 machines which are fine and look at the log process for those to see where Veeam is accessing at each step. Maybe something stands out that’s different between the success and failure computers?

Comment