Question

Weird replication job issue

  • 23 January 2023
  • 4 comments
  • 1280 views

Userlevel 7
Badge +3

Hi, everyone!

 

I have a weird error popping up in a replication job for one of my client’s and I need some insight. We have a replication job with a number of VMs that are replicating to a local repository. For some reason, the job has started failing and saying the job can’t continue because the replica has been found in an inaccessible state. I’ll paste an example below.

 

I have tried rescanning the repositories and rescanning the managed servers, but no luck.

 

Retry of Replication job finished with Failed. Job details: Failed to create processing task for VM Error: Found replica VM *** with connection state inaccessible. Cannot proceed further

Failed to create processing task for VM *** Error: Found replica VM *** with connection state inaccessible. Cannot proceed further

Processing *** Error: The request could not be performed because of an I/O device error. Failed to write data to the file [\\.\***Drive]. Failed to download disk 'Device '\\.\***Drive''. Shared memory connection was closed. Failed to upload disk. Skipped arguments: [>]; Agent failed to process method {DataTransfer.SyncDisk}. Processing *** Error: The request could not be performed because of an I/O device error. Failed to write data to the file [\\.\***Drive]. Failed to download disk 'Device '\\.\***Drive''. Shared memory connection was closed. Failed to upload disk. Skipped arguments: [>]; Agent failed to process method {DataTransfer.SyncDisk}.


4 comments

Userlevel 7
Badge +20

Is there connection to storage from the virtualization environment?  It seems there could be connectivity issues.

Userlevel 7
Badge +3

Is there connection to storage from the virtualization environment?  It seems there could be connectivity issues.

There might very well be. I felt like there’s a piece of this puzzle that I am missing, and I think that may very well be the case. Someone is looking into it behind the scenes. I think you may be right on this.

Userlevel 7
Badge +20

Is there connection to storage from the virtualization environment?  It seems there could be connectivity issues.

There might very well be. I felt like there’s a piece of this puzzle that I am missing, and I think that may very well be the case. Someone is looking into it behind the scenes. I think you may be right on this.

I just googled the error and then read a post on the VMware forums that indicated such so it seemed like a likely cause.  Best of luck and hopefully that is it! 😊

Userlevel 7
Badge +20

Is there connection to storage from the virtualization environment?  It seems there could be connectivity issues.

There might very well be. I felt like there’s a piece of this puzzle that I am missing, and I think that may very well be the case. Someone is looking into it behind the scenes. I think you may be right on this.

The state inaccessible means that the storage the VM is on is inaccessible, likely the datastore is offline or failed, or corrupted. Had this before with someone using Synology as the replication target, all their VMs were reporting disk sizes of 0KB suddenly as it freaked out and we discovered it’d been corrupting data.

Comment