Question

Veeam Backup for Microsoft Azure appliance errors after applying updates


Userlevel 3

Hi, Yesterday, we applied the available updates to our Veeam appliance through Veeam Updater UI. There were several updates available and they all were successfully installed and the appliance were rebooted all fine. After applying the updates, we started to see this warning in our Azure portal under this Veeam appliance vm:

"Virtual Machines in your subscription are running on images that have been scheduled for deprecation. Once the image is deprecated, new VMs cannot be created from the deprecated image. Upgrade to newer version of the image to prevent disruption to your workloads."

As a result, our Azure site recovery replication for this appliance was broken between our primary region UK South to the secondary region UK West. When tried removing and reenabling the replication, it throws the error below:

"Site recovery extension does not support the Linux operating system kernel version running on the source machine. Ensure that the VM is running a supported Linux Operating system."

Although snapshots and backup policies are working as expected. Looks like the yesterday's updates have upgraded the Kernel version that is not compatible with some Azure feature. Any suggestions how can we get this resolved? Many thanks


6 comments

Userlevel 7
Badge +21

I see you already posted on the forums so I would suggest a support ticket also for the issue to get the logs analyzed.  It is very clear it is the kernel but unsure what the fix would be.

Userlevel 7
Badge +19

Agree with Chris here...I’d open a Veeam Support case to let them review what may have happened.

Userlevel 7
Badge +4

This happens because your appliance was probably created with the first image of v5. This image is scheduled for deprecation.
What you could do is create a new Veeam Backup for Azure appliance and perform a configuration backup and configuration restore in the new appliance. The new appliance is using a new image, so it won’t be a problem anymore.

 

https://helpcenter.veeam.com/docs/vbazure/guide/configuration_backup_and_restore.html?ver=60

Userlevel 3

We have already raised a support case with Veeam on this issue. @wesmrt yes, when we deployed this appliance last year, it came with v5.

Userlevel 7
Badge +4

We have already raised a support case with Veeam on this issue. @wesmrt yes, when we deployed this appliance last year, it came with v5.

ALmost sure the problem is this that I said.
It’s not really a problem, but if you want to protect the VB Azure with Azure Site Recovery, then I believe the only solution is creating a new appliance and perform the configuraiton restore. It’s actually pretty simple and everything will be imported and ready to use.

Userlevel 7
Badge +21

We have already raised a support case with Veeam on this issue. @wesmrt yes, when we deployed this appliance last year, it came with v5.

ALmost sure the problem is this that I said.
It’s not really a problem, but if you want to protect the VB Azure with Azure Site Recovery, then I believe the only solution is creating a new appliance and perform the configuraiton restore. It’s actually pretty simple and everything will be imported and ready to use.

Didn’t know this, thanks for sharing @wesmrt 🙂

Comment