Urgent - Restoring problem (OS volume)

Very small environment - ten users and two quite old servers Fujitsu Primergy TX1310 M1 with Windows Server 2012 R2 Foundation. They have the same hardware, the only difference is in disks models and capacity. The first one is a domain controller (+DNS, DHCP, home folders, other shares). The second one is joined to domain with installed Veeam B&R 12 Community + MS SQL Server. Both servers are built on internal LSI Software RAID (four disks, 2x RAID 1). AD server has two partitions on LUN 0, the first one is OS volume. Recently we had serious power problems and AD server stopped to work properly - no licenses, no services, no RDP etc. I was able to log in locally but there was a problem with networking - the interfaces worked very slow and sometimes stopped. I was not able to start services nor change their settings - the service property window was frozen during saving. I wasn’t able to install any update because of the network problems. After next and next etc. restart it started with the license, but no networking again. SFC didn’t worked (the error). When restarted in Safe mode with CMD line SFC fixed some disk problems. But it didn’t help.

I decided to use my Veeam’s backups. I have two restore points for the server’s OS Volume. Because the network is unavailable I created recovery media (USB stick) from the backup server agent (with drivers, without network settings). I exported the backup to an external USB drive. There was no problem with restoring OS volume from the last backup point in Advanced mode (to be sure the mapping is correct). It took more than 2 hours but there was no error. During first boot of the restored system I got BSOD - critical process died. I wasn’t able to run repair or safe mode - always BSOD. 

I decided to go the older restore point (created 10 days ago). This time I created the media ‘without drivers’, and like the first time I exported backup to the external drive. Now I cannot event start restoring because it’s stuck at “Recovery environment is initializing”. Tried many times waiting so long - it doesn’t work anymore. Because for the moment I have only remote access to the server with Veeam B&R I created the ISO media recovery - again with drivers, downloaded to my station and using Rufus burned to another USB stick. And it’s the same - I mean that the recovery agents hangs on “Recovery environment is initializing”.

What am I doing wrong or what I should do to restore it? I cannot use VM because the OS is WS2012R2 Foundation and it cannot work in VM. I need to do it ASAP :(


Userlevel 7
Badge +14

I don’t know if you have paid licenses, but if you do - Please go ahead and call Veeam support and get assistance to help you bring this back up immediately.

In case you don’t, can you try booting both UEFI and BIOS to see if there is a difference?

Any chance you can test booting the USB stick on a different computer just to confirm if it works right away?

I tried from other USB port. Waited more than 40 minutes with initializing env screen and finally it started to recover. It should finish in ca. 80 minutes I hope... What about that BSOD after restoring the backup? No chance for repair/Safe mode. It started booting but I was not able to do anything.


(Community edition, no support)

The same after restoring :((( “CRITICAL_PROCESS_DIED”. Useless backup :(

Userlevel 7
Badge +14

It’s hard to guess the reason for the bluescreens. Maybe the server already had issues long before it crashed and therefore your backup only contains a corrupted state. Does Directory Services Restore Mode also not work? For that case you could try to boot from a Windows server setup ISO and do another SFCSCAN on the restored OS volume.

By the way, Community Edition comes with best effort support which means you can still open a support case. I wouldn’t count on that and probably you won’t get a solution (in time) but it’s still worth a try.