Solved

Upgade to v11 keeps failing

  • 26 November 2021
  • 19 comments
  • 2286 views

Userlevel 2

I am currently trying to upgrade to version 11 . The first upgrade failed with an error as it could not start the services. I followed this fix

https://community.veeam.com/blogs-and-podcasts-57/failed-to-connect-to-veeam-backup-and-replication-server-how-to-fix-remote-channel-sink-urinotpublished-remote-connection-refused-and-failed-to-start-the-service-1263 

I am now having to repair the installation as the fixes did not work and the services would not start. I have just tried to run the repair and I am receiving a different error "veeam configuration database is in use by the backup server " I have no idea how to proceed.

icon

Best answer by Mildur 29 November 2021, 17:58

View original

19 comments

Userlevel 7
Badge +4

You can remove the Veeam Software completely from the server, reinstall it again with pointing it to the same database.

If that is no help, reinstall Veeam with a new database and import your configuration backup (which you have hopefully done before the upgrade).

https://helpcenter.veeam.com/docs/backup/vsphere/vbr_config_restore.html?ver=110

 

If that is no help, a support case with veeam would be the best solution.

Userlevel 7
Badge +8

I think the new DB with the configuration restore would be a good option for sure.  But as Mildur said try the other options as well.

Userlevel 7
Badge +5

Try to check the health of that machine, range of possibilities of that error are multiple.

Userlevel 2

Thanks for the reply. I did do a few searches on backing up the config before the upgrade and I couldnt find much help, must have not been too clever with my investigation. So all the backup jobs are installed in the database and wont get removed if I uninstall the product completely? Does it ask you if you want to remove them during the uninstall process? Can I backup my sql server database, if you are sugessting that is where they are stored? 

 

Thanks again. 

Userlevel 7
Badge +4

TI did do a few searches on backing up the config before the upgrade and I couldnt find much help, must have not been too clever with my investigation. So all the backup jobs are installed in the database and wont get removed if I uninstall the product completely? Does it ask you if you want to remove them during the uninstall process? Can I backup my sql server database, if you are sugessting that is where they are stored? 

 

Thanks again. 

 

@James0000000 

If you follow the upgrade guide next time, you will find the link todo the configuration backup:

Upgrading to Veeam Backup & Replication 11 or 11a - User Guide for VMware vSphere

Running Configuration Backups Manually - User Guide for VMware vSphere (veeam.com)

 

If you uninstall the product, the configuration database will not be deleted. You can reconnect to the database with a new installation (the database will be upgraded if needed) or an existing one (the same vbr version needs to be used as the db version).

 

Please do a backup of the sql database first before you try do to anything else.

KB1471: How to manually backup a SQL DB (veeam.com)

Userlevel 2

Hello, thanks for the continued help. I have uninstalled the software and restarted the server. Unfortunately, I’m still receiving the same warning when I’m trying to install. Just wondering if there what could be causing this warning and what will I need to do if I continue the installation. 

 

Thanks. 

Userlevel 7
Badge +4

@James0000000

If you choose Yes, your new vbr installation will take over this database. Make a db backup first. Make sure, that no other VBR is connected to the database.

 

If that not works, please open a support case with veeam.

 

Userlevel 7
Badge +8

@James0000000

If you choose Yes, your new vbr installation will take over this database. Make a db backup first. Make sure, that no other VBR is connected to the database.

 

If that not works, please open a support case with veeam.

 

Yes backup the DB and say Yes as Mildur explained.  This message is coming from your previous VBR server that was using the DB so it is OK to say Yes to proceed.  This will allow the current server to take over the DB.

Userlevel 2

Great thanks. I already have a backup of the previous database as instructed earlier. Unfortunaltey I already opened a case with Veeam and this work is being done for a charity and we only have the community edition. My case was closed by Veeam as they are too busy to respond.

I would guess that I need to do some sort of databse restore after the installation? Just trying to find out how to do it, as most the the articles I can find are around restoring databases with veeam, but not the actual veeam database. 

 

Thanks again. 

Userlevel 7
Badge +4

@James0000000

Please use Yes and connect to the existing database and run the installer until he has done all steps. It should work to get your vbr server working again.

If that is not working, restore the database with the help of sqlcmd.

https://www.howtogeek.com/50295/backup-your-sql-server-database-from-the-command-line/amp/

 

The community is not really able to help you any further, if the reinstallation with the database is not working for you. Only veeam support knows the db structure and it‘s not supported to play around in the database without veeam support. Next time, a veeam configuration backup (or db backup) before the upgrade would be really helpful.

If you don‘t get support because you don‘t have an active maintenance contract, you have two options. Buy a VUL Backup Essentials License and get paid support or rebuild your jobs from start.

 

Userlevel 2

Thanks again. Looks like I’ve hit a brick wall as I cant even get the veeam software to install even after uninstalling it and trying to re-install it. I can’t even set the backups up from scratch. I seem to be getting various services that are failing to start during the install. e.g. veeam failed to start service 'veeamawssvc' . I’m thinking about starting a new post on the forums as I think I’m probably going off track from the orgianl issue. Thanks

Userlevel 7
Badge +4

If you talk about the R&D Forums, then you need to open a support case first. Posting technical issues without a case number is theoretically not allowed (Forum Rule Nr. 1).

Veeam R&D is not support. They cannot analyze debug logs over the forum. :)

 

You could start with reinstalling your Veeam windows server from start. Then you have a fresh start without any leftover.

Userlevel 7
Badge +7

Hello @James0000000 , what’s about setting up your server completely from scratch? I think there are some problems with the Windows installation….

Userlevel 7
Badge +8

Hello @James0000000 , what’s about setting up your server completely from scratch? I think there are some problems with the Windows installation….

I have seen this before and had to do the exact same thing by deploying a new VM and then reinstall Veeam and load my configuration backup.  Easy way to move to new OS too. :smiley:

Userlevel 2

Unfortnately these works are for a charity and we dont have the funds to purchase the software and log a support call 😞 . It wont be possible to re-install the veeam server as we have a number of other roles and software installed which doesnt help the situation. Oh well its funny in life how trying to help those in need is always a stuggle. Thanks fo the previous help, looks like I’ve exhausted the support available here. 

Userlevel 7
Badge +8

Hi @James0000000, there are some ways forward with this.

 

You could install a new SQL instance and then when you install Veeam, point it to an “existing” instance instead of letting Veeam reinstall the same database. My guide for this is here: Database Considerations: Veeam Backup & Replication / Veeam ONE on Windows Server 2022 - Part One | Veeam Community Resource Hub

 

You will need to recreate your backup jobs and re-add your passwords etc as part of this as it will be seen as a new Veeam installation, however you can still add your existing backup repositories to utilise your existing backup chains and continue as before!

 

Hopefully this helps! :slight_smile:

Userlevel 2

Hi @James0000000, there are some ways forward with this.

 

You could install a new SQL instance and then when you install Veeam, point it to an “existing” instance instead of letting Veeam reinstall the same database. My guide for this is here: Database Considerations: Veeam Backup & Replication / Veeam ONE on Windows Server 2022 - Part One | Veeam Community Resource Hub

 

You will need to recreate your backup jobs and re-add your passwords etc as part of this as it will be seen as a new Veeam installation, however you can still add your existing backup repositories to utilise your existing backup chains and continue as before!

 

Hopefully this helps! :slight_smile:

Thanks fort the reply, but its not even possible to re-install veeam on the server at the moment becuase various services are failing to start during the install.

Userlevel 7
Badge +8

Hi @James0000000, there are some ways forward with this.

 

You could install a new SQL instance and then when you install Veeam, point it to an “existing” instance instead of letting Veeam reinstall the same database. My guide for this is here: Database Considerations: Veeam Backup & Replication / Veeam ONE on Windows Server 2022 - Part One | Veeam Community Resource Hub

 

You will need to recreate your backup jobs and re-add your passwords etc as part of this as it will be seen as a new Veeam installation, however you can still add your existing backup repositories to utilise your existing backup chains and continue as before!

 

Hopefully this helps! :slight_smile:

Thanks fort the reply, but its not even possible to re-install veeam on the server at the moment becuase various services are failing to start during the install.

If you go to C:\ProgramData\Veeam and then get the install logs, what do they say? Feel free to DM if you don’t wanna post anything publicly.

Userlevel 2

Thanks for the reply. 

 

Not sure which install logs you want the info from but the backupsuite log file has the following at the end. It jsut goes into a loop of trying to restart then. If you cancel the rest of the setup fails.  

 

[06.12.2021 21:52:35][INFO] Service name: VeeamExplorersRecoverySvc
[06.12.2021 21:52:35][INFO] Service process: Not specified
[06.12.2021 21:52:35][INFO] Starting service...
[06.12.2021 21:52:35][INFO] Service successfully started.
[06.12.2021 21:52:35][INFO] Service name: VeeamAwsSvc
[06.12.2021 21:52:35][INFO] Service process: Not specified
[06.12.2021 21:52:35][INFO] Starting service...
[06.12.2021 21:53:05][ERROR] Failed to start service ‘VeeamAwsSvc'. 
Click Retry to attempt to start the service again. Click Cancel to continue installation without starting the service.
 

Thanks

Comment