Question

Installation Veeam agent for Windows 5.0.3.4708 not working on Windows 11


Userlevel 2
  • Not a newbie anymore
  • 3 comments

I just installed the latest available version of Veeam agent for Windows on Windows 11 and it doesn't work.
The service does not start

 


14 comments

Userlevel 7
Badge +8

Hi,

 

Have you seen:

Likely the same issue.

Userlevel 7
Badge +5

Hello @Franck, just like @MicoolPaul  has described above, there are certain steps to be able to install the Veeam Agent without running into this error as I have read in different forums on this issue. The following folders need to be deleted

  • C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\Microsoft SQL Server Local DB\Instances”\VeeamEndPoint
  • C:\ProgramData\Veeam\EndpointData

Access the following Registry path: HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Endpoint Backup 

  • Create the following value under this key:
    Name = Recreatedatabase 
    Type = DWORD 
    Value = 1 
    Start Veeam Endpoint Backup service
    Allow some time for the new database instance to be created (5 minutes should be enough).
  • Run regedit.exe and delete the Recreatedatabase value from HKEY_LOCAL_MACHINESOFTWAREVeeamVeeam Endpoint Backup key.
    Move VeeamBackup.mdf and VeeamBackup_log.ldf replacing the existing files in the target folder
    From:    C:Windows.oldwindowsSystem32configsystemprofile
    To:        C:WindowsSystem32configsystemprofile

Then restart your device and start the Veeam Endpoint Backup service.

Userlevel 7
Badge +7

Hello @Franck, just like @MicoolPaul  has described above, there are certain steps to be able to install the Veeam Agent without running into this error as I have read in different forums on this issue. The following folders need to be deleted

  • C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\Microsoft SQL Server Local DB\Instances”\VeeamEndPoint
  • C:\ProgramData\Veeam\EndpointData

Access the following Registry path: HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Endpoint Backup 

  • Create the following value under this key:
    Name = Recreatedatabase 
    Type = DWORD 
    Value = 1 
    Start Veeam Endpoint Backup service
    Allow some time for the new database instance to be created (5 minutes should be enough).
  • Run regedit.exe and delete the Recreatedatabase value from HKEY_LOCAL_MACHINESOFTWAREVeeamVeeam Endpoint Backup key.
    Move VeeamBackup.mdf and VeeamBackup_log.ldf replacing the existing files in the target folder
    From:    C:Windows.oldwindowsSystem32configsystemprofile
    To:        C:WindowsSystem32configsystemprofile

Then restart your device and start the Veeam Endpoint Backup service.

This is great advice as I have seen this happen with the windows.old directory before on my own laptop. 👍

You should be good with the advice above. 👆

Userlevel 2

Unfortunately it doesn't work for me

@Iams3le 

Userlevel 7
Badge +7

Unfortunately it doesn't work for me

I might suggest that you remove the app completely and clean up any leftover files, then reboot and reinstall again.  I have the same Agent version running on my laptop with Windows 11 in the Beta channel so build 22593.1 and it is working without issue.

Userlevel 2

@Chris.Childerhose 

I deleted the app and all files about Veeam but after the new install the service doesn’t start 

 

Userlevel 7
Badge +7

@Chris.Childerhose

I deleted the app and all files about Veeam but after the new install the service doesn’t start 

 

This is the only KB that I can find that may help otherwise open a Support ticket to get further assistance - KB4259: Veeam Agent for Microsoft Windows can't be started or installed after upgrade to Windows 11

Userlevel 2

@Chris.Childerhose  Thank you for your help i resolve my problem with this 

https://forums.veeam.com/veeam-agent-for-windows-f33/can-t-install-veeam-agent-for-windows-5-0-1-on-windows-11-t78276.html

New-Item -Path 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer\Parameters' -Force

 

New-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer\Parameters' -Name 'SQLArg0' -Value "-T1800" -PropertyType String -Force

 

 

Userlevel 7
Badge +5

@Chris.Childerhose  Thank you for your help i resolve my problem with this 

https://forums.veeam.com/veeam-agent-for-windows-f33/can-t-install-veeam-agent-for-windows-5-0-1-on-windows-11-t78276.html

New-Item -Path 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer\Parameters' -Force

 

New-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer\Parameters' -Name 'SQLArg0' -Value "-T1800" -PropertyType String -Force

 

 

Thank you very much @Franck for letting us know. Exactly same steps shared by @MicoolPaul. Thank you @Chris.Childerhose for your input as well. 

Userlevel 7
Badge +7

@Chris.Childerhose  Thank you for your help i resolve my problem with this 

https://forums.veeam.com/veeam-agent-for-windows-f33/can-t-install-veeam-agent-for-windows-5-0-1-on-windows-11-t78276.html

New-Item -Path 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer\Parameters' -Force

 

New-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer\Parameters' -Name 'SQLArg0' -Value "-T1800" -PropertyType String -Force

 

 

Great.  Glad to hear that was resolved.  Be sure to mark an answer to your issue to help others out. 😃

i have exectly this problem on windows 11 but how i can fix this? anyone have a step by step guide?

Userlevel 7
Badge +7

i have exectly this problem on windows 11 but how i can fix this? anyone have a step by step guide?

Just follow the articles noted in this thread as there has been great details given.

i have exectly this problem on windows 11 but how i can fix this? anyone have a step by step guide?

Just follow the articles noted in this thread as there has been great details given.

 

i am note sure how i can do this

Userlevel 7
Badge +7

i have exectly this problem on windows 11 but how i can fix this? anyone have a step by step guide?

Just follow the articles noted in this thread as there has been great details given.

 

i am note sure how i can do this

Run the two PowerShell commands above noted to see if that fixes the issue for you.

Comment