Solved

File does not exist. Failed to open storage for read access. Failed to restore file from local backups


Userlevel 4
Badge

Hi All,

 

I trust everyone is doing well. Please assist one of our Backup Copy is not running due to the below error.

 

File does not exist: [********.vib].Failed to open storage for read access[******.vib]. Failed to restore file from local backups. Agent failed to process method (DataTransfer.RestoreText).

 

Thanks in advance. :)

icon

Best answer by BrianNgcobo17 5 October 2022, 09:24

View original

15 comments

Userlevel 7
Badge +21

My first question would be was anything deleted on the repository as it seems that Veeam is trying to piece together the backup chain but there are missing VIB (Incremental) files?

Also is there a backup job running when the Backup Copy job is trying to run?  This can lock the files so they need to be scheduled apart.

Also check the logs - C:\ProgramData\Veeam\Backup to see what they might say.

Userlevel 4
Badge

Good morning Chris,

 

Much appreciated, the file is missing and it causing the error. I’ve escalated the issue to VEEAM Support.

 

Thanks a mil. :)

Userlevel 7
Badge +21

Good morning Chris,

 

Much appreciated, the file is missing and it causing the error. I’ve escalated the issue to VEEAM Support.

 

Thanks a mil. :)

Glad to see you’ve got this sorted. The question is, was this accidentally or maliciously deleted, or have you got an issue with your underlying storage platform? What are you using for your storage and how do you access it? For example is it a Synology over SMB?

Userlevel 7
Badge +9

You can check the ‘History’ section in the VBR console, might be able to shed some light on user’s actions

Userlevel 7
Badge +21

Good morning Chris,

 

Much appreciated, the file is missing and it causing the error. I’ve escalated the issue to VEEAM Support.

 

Thanks a mil. :)

Not a problem glad I was able to help.  Be sure that you mark an answer to the post so others can see what helped you out in case they have similar issues. 😁

Hi Team,

 

I hope everyone doing good.

Please assist one of our backup job is getting below error.

Error: File does not exist. File: [4THQUARTER-41 - 192.168.147.41D2022-11-03T220045_1CC0.vib].
Failed to open storage for read access. Storage: [4THQUARTER-41 - 192.168.147.41D2022-11-03T220045_1CC0.vib].
Failed to download disk '0BA70EF1'.
Reconnectable protocol device was closed.
Failed to upload disk.
Agent failed to process method {DataTransfer.SyncDisk}.

hola, buenas noches..yo estoy teniendo este error, y nose como solucionarlo:

 

26/12/2022 11:20:11 :: Failed to pre-process the job Error: No se puede realizar la solicitud por un error del dispositivo de E/S
Failed to read data from the file [E:\HV02REPOBACKUP\backup_discos\backup_discosD2022-12-23T125116_F71B.vib].
--tr:Error code: 0x0000045d
Failed to open storage for read/write access. Storage: [E:\HV02REPOBACKUP\backup_discos\backup_discosD2022-12-23T125116_F71B.vib].
--tr:Failed to open storage [HostFS://E:\HV02REPOBACKUP\backup_discos\backup_discosD2022-12-23T125116_F71B.vib] for write access.
--tr:R

I’m getting this error.
I’m happy this thread is marked as “SOLVED”!
But how was it resolved?

Userlevel 7
Badge +21

I’m getting this error.
I’m happy this thread is marked as “SOLVED”!
But how was it resolved?

One of the VIB files was missing in the chain and the poster contacted support to resolve it.

During a specific VM (named AVSRV) backup using Veeam Backup & Replication 10 (Build 10.0.1.4854 P20201202, I encountered the following error:

Proccessing AVSRV Error: File does not exist. File: [AVSRVD2023-04-25T235114_D9C3.vib].
Failed to open storage for read access. Storage: [AVSRVD2023-04-25T235114_D9C3.vib].
Failed to download disk 'AVSRV_1-flat.vmdk'.
Shared memory connection was closed.
Failed to upload disk.
Agent failed to process method {DataTransfer.SyncDisk}.

Below error show all job backup

 

Error: Storage version [-1839657838] is not supported for read-only access. Failed to open storage for read access. Storage: [File Server Backup - 167.0.0.18D2023-06-25T231533_CB84.vib]. Failed to restore file from local backup. VFS link: [summary.xml]. Target file: [MemFs://frontend::CDataTransferCommandSet::RestoreText_{945f74f9-6824-4193-939b-8f38a334247a}]. CHMOD mask: [-2100856788]. Agent failed to process method {DataTransfer.RestoreText}

Userlevel 7
Badge +21

Below error show all job backup

 

Error: Storage version [-1839657838] is not supported for read-only access. Failed to open storage for read access. Storage: [File Server Backup - 167.0.0.18D2023-06-25T231533_CB84.vib]. Failed to restore file from local backup. VFS link: [summary.xml]. Target file: [MemFs://frontend::CDataTransferCommandSet::RestoreText_{945f74f9-6824-4193-939b-8f38a334247a}]. CHMOD mask: [-2100856788]. Agent failed to process method {DataTransfer.RestoreText}

Can you please create a new post with more information in it.  Things like the Operating System version, Veeam version, is this a VM or Physical backup (Agent - Win or Linux), etc.  Based on seeing CHMOD to me it is a Linux backup but to be certain we need more information and putting this in a new post will help you more than being in an existing thread.

Also check the logs as well to post more information - if Windows then they are here - C:\ProgramData\Veeam\Backup

Is there any details how this was resolved,  as I currently have environment getting the same error?

Userlevel 7
Badge +3

Definitely looks like something is missing from your backup chain. Rescan your repository and see if that makes a difference. Check under the Backups>Local and see if you see that restore point as orphaned and grayed out. You may have to remove it from configuration.

 

Was anything deleted that you know of?

Userlevel 7
Badge +3

Is there any details how this was resolved,  as I currently have environment getting the same error?

Rescan your repository and then check your restore points, under the backups section. See if you see the missing file in there and see if it is greyed out. If it is, try and remove it from configuration. You can also try reseeding the backup chain back to the backup job by editing the job, and in the Target section, where you choose your repository, there’s a Map Backup option under it. If you click that and choose the correct job from the list, it should re-map everything in the repository to that job. This might fix it. If you just outright are missing the file, you’ll probably have to run a new active full, because your backup chain is broken, at this point.

Comment