Question

Failed to check whether remote Installer service is available.


Userlevel 3
  • Comes here often
  • 10 comments

Prompt this Failed to check whether remote Installer service is available.This is a newly created account。The configuration is the same as the previous account


18 comments

Userlevel 6
Badge +2

Prompt this Failed to check whether remote Installer service is available.This is a newly created account。The configuration is the same as the previous account

where is give this error?

Userlevel 6
Badge +2

can u give details?

Userlevel 3

你能提供细节吗?

添加 Windows 主机时

Userlevel 3

你能提供细节吗?

添加 Windows 主机时

 

Userlevel 6
Badge +2

what is you specified IP? storage IP or ur win server IP?

Userlevel 3

what is you specified IP? storage IP or ur win server IP?

server

Userlevel 7
Badge +5

@fjl other user account configured on VBR Server ?
Do I have correctly understand ?

Userlevel 3

@fjl other user account configured on VBR Server ?
Do I have correctly understand ?

I had an account before, but it was disabled due to security issues; A new account has been created for use. But as long as the previous account is disabled, the new account cannot connect to the Windows host; But there are some servers that can be connected.

Userlevel 6
Badge +2

Okey. Firstly, u can check ur Veeam Services because maybe ur installer service is not running. If u havent these service u need re-setup again Veeam backup for windows

Userlevel 3

Okey. Firstly, u can check ur Veeam Services because maybe ur installer service is not running. If u havent these service u need re-setup again Veeam backup for windows

I had an account before, but it was disabled due to security issues; A new account has been created for use. But as long as the previous account is disabled, the new account cannot connect to the Windows host; But there are some servers that can be connected.

Userlevel 6
Badge +2

Is This error give on Veeam Agent Backup? Am I understand true

Userlevel 3

Is This error give on Veeam Agent Backup? Am I understand true

这个报错,就是的。😂

Userlevel 7
Badge +19

Hi @fjl -

Please share what process SPECIFICALLY you are trying to do? Are you using Veeam Backup Server? Are you using the Windows Agent? Are you using Veeam Backup server to push the Agent to a Windows Server? Are you trying to backup a physical or virtual machine? What is the network segmentation of your environment, if there is one? Are all your Veeam components on the same subnet? Is DNS set up correctly?

Just an initial guess, but by what I can tell from the error you shared, the Veeam Services on the remote Windows server/computer you’re trying to communicate with have not started, or are not available. If this is a managed server in Veeam Backup server, for example, I’d remove it, then re-add it to reinstall the Veeam Services back on the remote computer.

If possible, please share more details on what you’re attempting to do.

Thank you.

Userlevel 3

Hi @fjl -

Please share what process SPECIFICALLY you are trying to do? Are you using Veeam Backup Server? Are you using the Windows Agent? Are you using Veeam Backup server to push the Agent to a Windows Server? Are you trying to backup a physical or virtual machine? What is the network segmentation of your environment, if there is one? Are all your Veeam components on the same subnet? Is DNS set up correctly?

Just an initial guess, but by what I can tell from the error you shared, the Veeam Services on the remote Windows server/computer you’re trying to communicate with have not started, or are not available. If this is a managed server in Veeam Backup server, for example, I’d remove it, then re-add it to reinstall the Veeam Services back on the remote computer.

If possible, please share more details on what you’re attempting to do.

Thank you.

I am using a Veeam Backup server, and the connected host is the server physical machine. The VBR and physical machine are in the same network segment, and the network is not a problem. Because some hosts across other network segments are OK. And I have tried to add it after deletion, but still reported an error.

Add as many details as possible, by providing details you’ll make it easier for others to reply

Userlevel 7
Badge +19

Ok, so you’re trying to add a physical Windows computer to the Veeam server for an Agent backup?

Look on the physical Windows computer and see if there are Veeam services there. If there is, verify they are started? If the Veeam services are there and they are started, manually uninstall them, then reinstall them. The Veeam Installer and Transport service msi installers can be located on the Veeam server at the following location:

C:\Program Files\Veeam\Backup and Replication\Backup\Packages\<VeeamTransport.msi> and <VeeamInstaller.Svcmsi>

Try that and let us know if you are then able to communicate with the computer.

Userlevel 3

Ok, so you’re trying to add a physical Windows computer to the Veeam server for an Agent backup?

Look on the physical Windows computer and see if there are Veeam services there. If there is, verify they are started? If the Veeam services are there and they are started, manually uninstall them, then reinstall them. The Veeam Installer and Transport service msi installers can be located on the Veeam server at the following location:

C:\Program Files\Veeam\Backup and Replication\Backup\Packages\<VeeamTransport.msi> and <VeeamInstaller.Svcmsi>

Try that and let us know if you are then able to communicate with the computer.

The customer used an agent for backup, but the physical machine's account had security issues, so the account was replaced. Reconnecting the scan will result in an error.

Userlevel 3

Ok, so you’re trying to add a physical Windows computer to the Veeam server for an Agent backup?

Look on the physical Windows computer and see if there are Veeam services there. If there is, verify they are started? If the Veeam services are there and they are started, manually uninstall them, then reinstall them. The Veeam Installer and Transport service msi installers can be located on the Veeam server at the following location:

C:\Program Files\Veeam\Backup and Replication\Backup\Packages\<VeeamTransport.msi> and <VeeamInstaller.Svcmsi>

Try that and let us know if you are then able to communicate with the computer.

OK,thanks。After I start work tomorrow, give it a try

Userlevel 7
Badge +19

Ok, keep us posted.

If the account being used is a local account to the computer, and not a domain account, that could also be the issue. Make sure to use the username format: hostname/username ; if a domain account, make sure to use: domain/username. Also, if it’s a local account, you may need to disable UAC on the remote Windows computer, as well as make a registry modification. To do this, look at my comments in this previous post:

Hope these suggestions help!

Comment