Question

veeam backup&replication failed to connect to host


Userlevel 3
  • Comes here often
  • 10 comments

Hi everyone,

recenly i’m doing some test on the veeam backup&replication community edition on my Dell R710 which is running server 2019 standard. And at the first time, i can add a hyper-v server which is running server2019 (standalone) to the backup job, but once i deleted the job, i cannot add any hyper-v again.

It always shows :

Failed to connect to host 10.178.3.41

Access denied or timeout expired. (sometimes is invalid namespace)
Check if you have local administrator privileges on computer '10.178.3.41'.

Possible reasons:
1. Invalid credentials.
2. Specified host is not a Hyper-V server.

================

what i did for this issue:

  1. https://www.veeam.com/kb1914
  2. https://www.scribd.com/document/421024195/Veeam-Backup-Invalid-Credentials-Error-Adding-a-Hyper#
  3.  

  4. I added both the target server and the server with the veeam installed to the domain
  5. created the local admin account for both server, using same account and pwd
  6. using domain admin account cannot work
  7. checking the port and disable the firewall , also the turn off the defender.
  8. checking the network is fine, dns is fine.

Now I'm really lost, how should I solve this problem.


30 comments

This worked for me:

Credentials format: user@hostname

Same error trying to add Hyper V host in the Azure.

Tried all the above. No solution yet?

 

Failed to connect to host 48.216.227.99

Access denied or timeout expired. (sometimes is invalid namespace)
Check if you have local administrator privileges on computer '48.216.227.99'.

Possible reasons:
1. Invalid credentials.
2. Specified host is not a Hyper-V server.

Hyper-V is not domain joined, I seem to have tried all the common fixes to no avail.

Regedit didn’t help, local Administrator account is active, doesn’t work.

Credentials format: user@hostname, doesn’t work.

 

Userlevel 5
Badge

@andysl 

I believe this is related to changes made Microsoft to DCOM. The below article may help

https://www.veeam.com/kb4376

 

Can you let me know the OS of VBR Server and HyperV Server.

Is HyperV in a cluster? Was this working fine before?

Can you also review Windows Event Viewer logs on the VBR server and HyperV Server

Userlevel 5
Badge

The below article shall help

https://www.veeam.com/kb4376

 

Comment