Question

VEEAM SureBackup and VXRAIL

  • 27 September 2021
  • 7 comments
  • 72 views

Userlevel 2

Production Environment is a four Node VXRail VSAN Cluster. Backup Server is separated on a Physical Machine with local Storage and Backup Jobs are running fine.

Want to use SureBackup to proof that my Virtual Machines are could be recovered after been backed up.  Setup everything what is needed for SureBackup but the Job went wrong.

At the End i figured out that something goes wrong on the vPower NFS which uses Port 1063 and Port 2049. But even i change the Port 1063 to 1058 there is no success.

Have someone a clue what ports are needed for VXRail to work?

 


7 comments

Userlevel 7
Badge +5

Not sure on specific ports but check this URL as it lists all Veeam ports - Used Ports - User Guide for VMware vSphere (veeam.com)

Userlevel 7
Badge +5

Hi, what error do you get? And what is the physical server that’s protecting the environment?

 

Does it have Windows Storage Server edition installed? I’ve seen this repeatedly get installed with the NFS service by default, which messes up instant recoveries and SureBackups.

Userlevel 2

@Chris.Childerhose the check for the Veeam port did i first

@MicoolPaul Physical Server is a PowerEdge R740xd. Windows Storage Server edition is not installed.

These are the errors:

Failed to connect backup datastore to the ESXi host

Failed to add NFS datastore for NFS host . Failed to mount NFS volume: Fault "PlatformConfigFaultFault", detail "Operation failed, diagnostics report: Mount failed: Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Unable to connect to NFS server" 

"Operation failed, diagnostics report: Mount failed: Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Unable to connect to NFS server" 

Userlevel 7
Badge +5

Morning @HansWalter 

 

So the issue reported is VMware can’t connect to the NFS share.

 

Validate the following:

 

There are no firewalls between ESXi and your Veeam Server

If Windows Firewall is enabled on the Veeam server, you’ve enabled firewall rules to allow connectivity from the ESXi servers on the NFS port.

Run the following command from command prompt or PowerShell before starting SureBackup

netstat -abno > output.txt

Then start SureBackup and once it’s initialised and waiting for connectivity from ESXi run the command again but change the name of the output file.

 

Once you’ve got them both, compare the two outputs, you should see the NFS port on the second output but not the first. If you don’t see any change then something else is already bound on the same port that NFS wants to mount on, hence the connectivity won’t work. The command I’ve given you should also output the executables bound to the ports, search for “Veeamnfssvc.exe” I believe it’s called. If Microsoft’s NFS server role is installed there will be a port conflict (hence the mention of Windows Storage Server but the role could still have been manually installed)

 

These are the two main reasons why NFS doesn’t connect in my experience.

So Problem is solved with some tricky findings.​​​​​​

Since the Dell PowerEdge R740xd uses iDRAC (Remote Access) it shows up at first Network Card with IP-Address 169.x.x.x and guess what VEEAM use this as Default Connection. So disabled it and voila it uses the Network Card with the right IP Address in the right Network.

After Port checking correct the wrong Port 1063 to Port 1058 and check if Port 2049 is free.

Added vPowerNFSDisableIPAuth (DWORD) = 1 registry value to the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Veeam\Veeam NFS\ and restart Veeam vPower NFS Service.

Userlevel 7
Badge +5

So Problem is solved with some tricky findings.​​​​​​

Since the Dell PowerEdge R740xd uses iDRAC (Remote Access) it shows up at first Network Card with IP-Address 169.x.x.x and guess what VEEAM use this as Default Connection. So disabled it and voila it uses the Network Card with the right IP Address in the right Network.

After Port checking correct the wrong Port 1063 to Port 1058 and check if Port 2049 is free.

Added vPowerNFSDisableIPAuth (DWORD) = 1 registry value to the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Veeam\Veeam NFS\ and restart Veeam vPower NFS Service.

Glad to hear you got it fixed.

Hi. I have done the same with VxRail but as veeam introduced this security registry in 9.5 u4 we would like to keep using it. In the case of vxrail they hay an ipv6 discovery address (internal) as a vmk0 so we can’t disable it. Another solution in mind? I’ll open an SR with veeam and keep you posted

Comment