Solved

Weird looking Agent


Userlevel 2

Any of you have any suggestions to this problem?

 

https://forums.veeam.com/post471381.html#p471381

 

 

icon

Best answer by dips 20 December 2022, 12:53

View original

28 comments

Userlevel 7
Badge +22

Hi @User64,

 

Few thoughts:

  • Check settings > Ease of Access to see if it’s an accessibility feature breaking this.
  • After changing DPI (and ensuring consistent between multiple monitors if there are multiple), give the device a reboot and check. I have similar issues with Excel that require me to keep DPI the same across multiple monitors or else it grabs the DPI from another monitor and throws everything out of alignment and won’t resolve until a reboot or task manager force killing processes!
  • Do you have another device (even something like an iPhone would suffice) to remote desktop onto this PC? This would force the rendering of the app via a different pipeline and would rule out any GPU driver issues.
  • I personally believe this is more likely an issue with .NET framework or something similar, if it’s not caused by an accessibility function, can you confirm the dependencies are all on there: https://helpcenter.veeam.com/docs/agentforwindows/userguide/system_requirements.html?ver=50 I’d attempt an update of the .NET framework to latest, I’m mentioning this specifically as there was talk of games, and lets be honest, people try all sorts of upgrade/downgrade tricks with stuff like .NET to get games to work, which could have let Veeam install due to an updated registry key that wasn’t properly downgraded.
Userlevel 7
Badge +17

OK… then I have no further idea except to install the machine from scratch (which is not possible regarding to your description above).

I think, this is a problem outside of the Veeam agent, because I have never seen this kind of behavior before on any of my machines (workstations or server). And I have installed it on many different Windows versions and on machines with very different hardware and configurations….

Userlevel 7
Badge +7

Just throwing this in. It might be worth trying to upgrade your drivers using this if you are on the Intel platform: https://www.intel.co.uk/content/www/uk/en/support/detect.html

One other thing to look at would be DirectX: https://support.microsoft.com/en-gb/topic/how-to-install-the-latest-version-of-directx-d1f5ffa5-dae2-246c-91b1-ee1e973ed8c2

Userlevel 7
Badge +21

One last thing to maybe try installing GeForce Experience which will update the drivers as well and you can try both the Gamer Driver and Studio driver?  Not sure but one last thought.  😁

Userlevel 7
Badge +7

One final thing I have is if you right-click on the Veeam Agent, do you see an option that says ‘Run with Graphics Processor’? 

Userlevel 7
Badge +7

Do you have the NVIDIA Control Panel installed? 

If not, it might be worth installing as it gives you the option to select which Graphics Processor should be used by a particular application, especially on dual GPU systems. 

Userlevel 7
Badge +7

The only thing left I can think of is trying Safe Mode and see if you get the same view. I’ve run out of ideas, sorry!

Userlevel 7
Badge +21

I was one of the one replying to you in that thread.  Maybe you need to try removing the Agent completely and reinstalling it?  Support is the only other option at this point.

Userlevel 7
Badge +21

Do you have a system with dual display adapters?  Just curious as I know if you do and need both drivers updated, another option is switching the graphics in the Bios to dedicated maybe if the system has that?  Only other suggestion I can think of.

Userlevel 7
Badge +21

Would be interesting to check Device Manager to see if both show?  Best of luck.

Userlevel 7
Badge +21

Ok.  Not sure what else to suggest at this point.

Userlevel 7
Badge +17

Is the Veeam agent the only program with this problem?

You mentioned games, some of them have weird graphic modes….

Userlevel 7
Badge +17

You say, the PC is quite old… which OS version are you using?

Userlevel 7
Badge +17

Ok… Windows 10 22H2 is not officially supported by Veeam up to now….

https://forums.veeam.com/servers-workstations-f49/windows-11-22h2-not-officially-supported-by-veeam-t83134.html

 

I think this will be with VBR 12 and the Agents V6 fully supported. It will probably be GA at the end of January, but this is still subject to change….

Userlevel 2

yeah...well..It was like this before 22H2 got installed.

Userlevel 2

Thank you for your time. Yeah, it is probably some sort of weird quirk somehow. Would be very nice to figure out exactly what it was though...and it is a bit conspicuous that it is only Veeam having problems and NO other programs on the PC in question...

 
Userlevel 2

Thank you. I have the latest Nvidia drivers and DirectX gets updated through WU. Thanks though. :)

Userlevel 2

Thank you!

I doublechecked the Ease of Access settings, and everything seems untouched. I also selected a standard “Windows” theme but it didnt help.

I only have one screen attached to this PC. It is a Samsung TV. I have tried to TeamViewer into the PC and it behaves the same (I believe TeamViewer is using its own drivers so tht is a good test?)

I verified that Microsoft .NET Framework 4.5.2 is installed and also installed 7.01 (I believe it was latest)

I am going to install a few WU’s and reboot to see if it helps, but Im not holding my breath :)

Userlevel 2

I tried to right-click on the Veeam Agent in the systray and the program itself, but I cannot see this option anywhere. Is there a spesific place I need to right-click?

Any other way to turn it off/on?

Userlevel 7
Badge +7

Hi, 

Try on the Desktop icon.

Userlevel 2

Unable to find that option anywhere.. :/

Userlevel 2

Yeah, I have the Control Panel installed, but I only have one gfx-card.

Userlevel 2

Oh, I have tried that as well. Thanks anyways.

I understand that it is a free product and the support and will to fix rare problems like this will be somewhat lacking.

I will try and find another product to replace Veeam.

Thank you again.

Userlevel 2

Thanks again! :)

This computer has a NVIDIA GeForce GTX 1060 3GB, and kids are using it inbetween to game so its not possible atm to turn it off ...so to speak.

Yeah..Im out of ideas as well. Seems its some sort of quirk in this particular setup, google search does not show any others with same problem either it seems.

 

Userlevel 2

Addition: There might be a graphics card integrated on the motherboard...but its not in use afaik.

Comment