Veeam v12.1 Issues?


Userlevel 7
Badge +19

Happy New Year Community!

Has anyone who’s upgraded VBR to v12.1… have there been any notable issues reported? I know with the upgrade, which supports upgrade of vSphere to 8U2, there is a CBT bug within vSphere when upgrading VM disks. That isn’t a Veeam issue though...rather a VMware issue. Simple fix for that is simply don’t upgrade vSphere to 8U2. 🙂 Other than that, has there been anything discussed ‘in the wild’ as it were on upgrade issues I have not yet heard about? I’d like to upgrade, but want to make sure there’s no egregious bugs before doing so. 

Cheers all.


44 comments

Userlevel 7
Badge +19

Thanks for sharing @Jimmy_C 

Since upgrading to V12.1 our unstructured data copies no longer work correctly.  What would run under 10 minutes now takes 12 hours.  We’ve opened a ticket with support and hope to have this issue resolved soon.What we’re seeing is the copy job copies the same recovery point over and over and over again.  More to come.

Appears there is a bug in the NAS offsite copy SQL routine.  Support sent us a patch to apply to SQL and the problem is resolved.

Here is Supports response - “Found that in 12.1 the NAS copy job does not seem to be filtering out duplicate points when it checks what should be copied. This results in it trying to copy the same point repeatedly. In the previous version it consistently only had 1 point to copy, but now it's basically trying to copy the same point 90-100 times. I found a similar issue being discussed with RND, and it looks like a change to one of the Microsoft SQL stored procedures is the culprit.”

A big THANKS to Veeam Support for fixing the problem!

 

Hi here we have the exact same problem as you descirbed. Yet support has not provided any resolution and ticket is open since more than a month now. Ticket number is 03145067 if somebody could take a look please.

Regards,

 

Userlevel 7
Badge +19

Hi @JimmiMSY -

Product Managers monitor the Forum for cases, not here. If you want someone from Veeam to address your case, you'll need to post over there.

Thank you. 

Userlevel 2

There is a patch that is applied to SQL that eliminates the COPY problem for unstructured files.  You can have support refer to Case #07075462.

Support updated my case with a sql fix after mentioning this topic in ticket.

Will update if it solve my issue.

Thanks.

Userlevel 7
Badge +21

Support updated my case with a sql fix after mentioning this topic in ticket.

Will update if it solve my issue.

Thanks.

Let us know but if you want attention from Product Management then you need to post on the Forums not here - https://forums.Veeam.com

 

Sure it is not the right place but hey, “SQL fix” did fix my problem and it is here that I found material to feed to support. Without that I think I’ll have to wait for next patch release ( support told the fix will be included in next patch release ).

Userlevel 2

Glad I could assist!  I’m sure as others go to V12.1 they will run into the same issue until such time the fix is incorporated.

Userlevel 7
Badge +21

Great to hear the next patch will fix the issue permanently.

Userlevel 1

Hello.
After 12.1 upgrade I have an error on a proxy veeam when “disk discovering” on rescan :
 

[16.04.2024 16:19:18.936]    <17>   Error (3)    Access denied or timeout expired.

[16.04.2024 16:19:18.936]    <17>   Error (3)    Check if you have local administrator privileges on computer “xxxxxxxxx”

Privileges are ok (admin account)
Antivirus exceptions are ok

A ticket opened at support, waiting solution.

Userlevel 6
Badge +2

Hello.
After 12.1 upgrade I have an error on a proxy veeam when “disk discovering” on rescan :
 

[16.04.2024 16:19:18.936]    <17>   Error (3)    Access denied or timeout expired.

[16.04.2024 16:19:18.936]    <17>   Error (3)    Check if you have local administrator privileges on computer “xxxxxxxxx”

Privileges are ok (admin account)
Antivirus exceptions are ok

A ticket opened at support, waiting solution.

If I understand the problem correctly, you are getting an error on the proxy machine, right?
If so, have you first checked the credential information of the Proxy machine and the User you are using?
Additionally, I think you upgraded the proxy server. Apart from that, did you create a new proxy server and take action? Finally, can you access vCenter via the proxy machine? If you cannot access it, you may receive this error.

Userlevel 1

Hello….

If I understand the problem correctly, you are getting an error on the proxy machine, right?
If so, have you first checked the credential information of the Proxy machine and the User you are using?
Additionally, I think you upgraded the proxy server. Apart from that, did you create a new proxy server and take action? Finally, can you access vCenter via the proxy machine? If you cannot access it, you may receive this error.

Thank you.

I get this error on the VBR console when I try to “rescan” the proxy machine.

Yes I all checked account & privileges. 

I have no error on backups, and all works fine during backups.

The error is only when I rescan the proxy (or this proxy machine in “managed servers”).

I upgraded my proxies after my VBR, I didn’t create a new one : it was an existing proxy. 

I added an other “managed server” in backup infrastructure and it didn’t give me this error.
 

Yes I can accès the vcenter.

Userlevel 7
Badge +21

Hello….

If I understand the problem correctly, you are getting an error on the proxy machine, right?
If so, have you first checked the credential information of the Proxy machine and the User you are using?
Additionally, I think you upgraded the proxy server. Apart from that, did you create a new proxy server and take action? Finally, can you access vCenter via the proxy machine? If you cannot access it, you may receive this error.

Thank you.

I get this error on the VBR console when I try to “rescan” the proxy machine.

Yes I all checked account & privileges. 

I have no error on backups, and all works fine during backups.

The error is only when I rescan the proxy (or this proxy machine in “managed servers”).

I upgraded my proxies after my VBR, I didn’t create a new one : it was an existing proxy. 

I added an other “managed server” in backup infrastructure and it didn’t give me this error.
 

Yes I can accès the vcenter.

Try editing the Proxy and going through the wizard which should tell you what step it fails at.  I have seen during upgrades where older leftover components are in the Add/Remove Programs which you need to manually uninstall then use the wizard to deploy the latest.

Userlevel 7
Badge +19

Hello.
After 12.1 upgrade I have an error on a proxy veeam when “disk discovering” on rescan :
 

[16.04.2024 16:19:18.936]    <17>   Error (3)    Access denied or timeout expired.

[16.04.2024 16:19:18.936]    <17>   Error (3)    Check if you have local administrator privileges on computer “xxxxxxxxx”

Privileges are ok (admin account)
Antivirus exceptions are ok

A ticket opened at support, waiting solution.

At the very least, you can remove the Proxy & readd it. If any of your Jobs use this Proxy explicitly, just temporarily change them to use Proxies "Automatically". Remove the Proxy; remove it as a Managed Server; then readd as Managed Server; then readd as Proxy. If any Jobs had this Proxy explicitly added, reassign it to the given Job(s). 

Userlevel 1

Hello.
Thanks.
I ve done all actions you give to me

Veeam Support ask me to upgrade my Postgresql database 15.1 to 15.6.

I ll do it tomorrow and will see if it solve some problem

Userlevel 7
Badge +21

Hello.
Thanks.
I ve done all actions you give to me

Veeam Support ask me to upgrade my Postgresql database 15.1 to 15.6.

I ll do it tomorrow and will see if it solve some problem

Let us know how this goes as it will be good for others to know if this is something they made need to do.

Userlevel 1

Hello.
The postgresql update was not the solution… 


I have an other problem (this is why the support asked me to upgrade to v12.1) : I have a gateway server (for s3 storage) with Windows11 23H2. This gateway worked for 1 backup in v12 when I installed it, and then it said :

"Disks and Volume discovery failed Error : L'explorateur d'objet spécifié est introuvable"

"Microsoft Windows server discovery failed Error : L'explorateur d'objet spécifié est introuvable"

"Host Discovery Failed."

The support told me this OS version cant be used as gateway/proxy server and so I installed v12.1 compatible with this OS… But it still don’t work. 

 

Userlevel 7
Badge +21

Hello.
The postgresql update was not the solution… 


I have an other problem (this is why the support asked me to upgrade to v12.1) : I have a gateway server (for s3 storage) with Windows11 23H2. This gateway worked for 1 backup in v12 when I installed it, and then it said :

"Disks and Volume discovery failed Error : L'explorateur d'objet spécifié est introuvable"

"Microsoft Windows server discovery failed Error : L'explorateur d'objet spécifié est introuvable"

"Host Discovery Failed."

The support told me this OS version cant be used as gateway/proxy server and so I installed v12.1 compatible with this OS… But it still don’t work. 

 

I would suggest you keep working with support since what they suggested does not work so they can review the logs further.

Userlevel 1

Yes, I wrote an answer to my Veeam Cases every time I do a try on my problems. 
I write here to inform the other users and maybe to have someone who know how to do with my problems.

Comment