Question

Veeam EM and Backup Server connection error


Userlevel 1

Hi,

I try to add VBR server to Veeam EM, there is no problem. But sessions tab I see “Database Replication” failed.

And the logs like that;

“The SQL Server machine hosting the configuration database is currently unavailable. Possible reasons are a network connectivity issue, server reboot, heavy load or hot backup.
Please try again later.

Error:
relation "licensing.cc.ınstancestobackupslinks" does not exist”

VBR build is 12.1.0.2131, is not community license, and db is postgre.

Thanks,

 

 


10 comments

Userlevel 7
Badge +7

Hi @oktay 

Welcome to the Community!

Is this a new install of Veeam Enterprise Manager? Is VEM using MSSQL?

Userlevel 1

Hi,

Thanks for your response.

VBR is using PostgreSQL, and Veeam EM is using PostgreSQL, too. Yes, Veeam EM is new installation on same server with VBR. 

And also I checked VBR and Veeam EM DB connection  succeed. (https://helpcenter.veeam.com/docs/backup/em/dbconfig_launch.html?ver=120)

Thanks,

Userlevel 7
Badge +17

Do you have any jobs running in VBR? I wonder if the config db is locked at the moment because of jobs/tasks running? Maybe those errors will clear out?

At the very least, you could open a SR with Veeam Support and they can confirm, or provide a solution.

Userlevel 7
Badge +21

I was about to ask as well if jobs are running on the server causing the message that you see?  Also it seems that having Postgres on its own server seems to help more versus all on the same server as VEM and VBR.

https://forums.veeam.com/tape-f29/posgresql-the-sql-server-machine-hosting-the-configuration-database-is-currently-unavailable-t86270.html

 

Userlevel 7
Badge +17

Yeah...I was curious about running EM on the same server myself, but saw in the Guide and a few Forums post it’s supported, and can run fine. Personally, I’d run it on a different server, but with a physical server in play...may be best to run on 1? Depending on goals/constraints, etc. I’d create 2 VMs for VBR & EM. That being said..EM “should” run ok on same server as VBR, assuming the resources are sufficient. @oktay , I assume you have adequate resources (CPU/Memory/Disk) on your server? Reference the VBR and EM Guides for minimum requirements.

Userlevel 7
Badge +21

Yeah, running VEM/VBR on same server is fine as we do it on most, but it is the DB itself whether SQL or Postgres that is best on its own server versus the same server as Veeam.  With Veeam driving everything and constantly updating the DB having Postgres moved to a separate server might help here, but ensure no jobs are running.

Userlevel 1

Thank you all for your responses. I will open SR.

Thanks.

Userlevel 7
Badge +21

Thank you all for your responses. I will open SR.

Thanks.

Keep us posted on what they say and if there is a fix to help others here in the community.  👍🏼

Userlevel 4
Badge

@oktay since v12 and v12.1 you need the “new” port 9405 for certificate communication between vbr and em.. maybe you can check this also.

Daniel

Userlevel 7
Badge +17

Hi @oktay -

Did you open a SR with Veeam? Did Support get your error resolved? Can you post what they did to get you working?

Thank you.

Comment