Veeam V12 PostgreSQL Config DB SQL Queries fail



we are monitoring the customer backups via PRTG.

Till now, we had a SQL Skript, wich got the latest result and reported it to PRTG:

SELECT latest_result FROM bjobs WHERE name = @prtg;

That worked fine with MSSQL Express, but now with PostgreSQL we have to use a PostgreSQL Sensor in PRTG. Thats no problem, but it always failes with: “GSS/SSPI authentication but IntegratedSecurity not enabled” when I try to use the postgres user, or with: 28000: SSPI-Authentication for user Administrator failed”. For debugging I tried to change the access settings in the pg_hba.conf file but nothing seems to work.

Is there a way I can still run queries to the config database? Or do I have to go via the PowerShell Snappin from Veeam?

PS: We don’t use the Enterprise Manager, because you need the Enterprise Plus license for that and our customers don’t have that license.


Thanks alot.


Userlevel 7
Badge +16

You need to enable the Integrated Security option within the PSQL server.  I had to do this when setting up an external CentOS box with PSQL on it.  Took some fiddling but I got it working.  Not with PRTG mind you but should help.

Hi Chris, i did search for that but couldn’t find anything about that online. Do you have an artikel that describes how to enable IntegratedSecurity?



Userlevel 7
Badge +16

I don’t have a link, but it has to do with creating a local DB user with the proper roles and permissions to use for any connections to the database.  I am not a PSQL expert and just played around with things.  😂