Veeam V12 PostgreSQL Config DB SQL Queries fail

Userlevel 1



we are monitoring the customer backups via PRTG.

Till now, we had a SQL Skript, wich got the latest result and reported it to PRTG:

SELECT latest_result FROM bjobs WHERE name = @prtg;

That worked fine with MSSQL Express, but now with PostgreSQL we have to use a PostgreSQL Sensor in PRTG. Thats no problem, but it always failes with: “GSS/SSPI authentication but IntegratedSecurity not enabled” when I try to use the postgres user, or with: 28000: SSPI-Authentication for user Administrator failed”. For debugging I tried to change the access settings in the pg_hba.conf file but nothing seems to work.

Is there a way I can still run queries to the config database? Or do I have to go via the PowerShell Snappin from Veeam?

PS: We don’t use the Enterprise Manager, because you need the Enterprise Plus license for that and our customers don’t have that license.


Thanks alot.


Hello All, maybe it will be useful for someone with the same issue. We fixed ours by setting up correct method in file: 

C:\Program Files\PostgreSQL\15\data\pg_hba.conf

our file looks like this: 

# TYPE  DATABASE        USER            ADDRESS                 METHOD

# "local" is for Unix domain socket connections only
local   all             all                                     scram-sha-256
# IPv4 local connections:
host    all             all               scram-sha-256
# IPv6 local connections:
host    all             all             ::1/128                 scram-sha-256
# Allow replication connections from localhost, by a user with the
# replication privilege.
local   replication     all                                     scram-sha-256
host    replication     all               scram-sha-256
host    replication     all             ::1/128                 scram-sha-256

Userlevel 7
Badge +21

I don’t have a link, but it has to do with creating a local DB user with the proper roles and permissions to use for any connections to the database.  I am not a PSQL expert and just played around with things.  😂

Userlevel 1

Hi Chris, i did search for that but couldn’t find anything about that online. Do you have an artikel that describes how to enable IntegratedSecurity?



Userlevel 7
Badge +21

You need to enable the Integrated Security option within the PSQL server.  I had to do this when setting up an external CentOS box with PSQL on it.  Took some fiddling but I got it working.  Not with PRTG mind you but should help.