Solved

VO365 Cannot upgrade from 5.0.2.22 to 5.0.3.33


Userlevel 4

Hello,

 

I cannot upgrade from 5.0.2.22 to 5.0.3.33 from the VO365 console, I receive an error message: “certificate verification failed certificate is not valid”, do you have any ideas?

 

Thanks in advance,

 

Omar De Souza.

icon

Best answer by MicoolPaul 25 February 2022, 15:35

View original

22 comments

Userlevel 7
Badge +8

Hi,

 

Are you trying to download the patch from the console? Have you got any SSL Interception tools such as web filters in your network?

 

Can you access the Veeam website directly and download the patch?

 

Or is this when trying to update the other components in your platform after the console is patched?

Userlevel 7
Badge +8

I might suggest you download the patch from the Veeam website and try that what to see if it works versus the console. As Michael mentioned something seems off for downloading do you use a Proxy server on the network that may cause this?

Userlevel 4

Hi,

I’m trying to do the upgrade from the Console, with the upgrade button.

So I’ll try to do it manually instead and let you know.

Thanks,

Omar De Souza.

Userlevel 4

Hi,

 

The upgrade worked fine from the manual installation, is weard that it didn’t work from the console.

 

Thanks for your help,

 

Omar De Souza.

Userlevel 7
Badge +8

Hi,

 

The upgrade worked fine from the manual installation, is weard that it didn’t work from the console.

 

Thanks for your help,

 

Omar De Souza.

Glad to hear that it worked.

Userlevel 7
Badge +8

Hi,

 

The upgrade worked fine from the manual installation, is weard that it didn’t work from the console.

 

Thanks for your help,

 

Omar De Souza.

Haven’t seen anything announced that Veeam is having issues and didn’t have the problem myself so I’d suggest checking any proxy (as in network proxy, not Veeam proxy) configurations on the server

Seeing the same thing here.

Veeam Backup for Microsoft Office 365 - version 5.0.1.252

Trying to upgrade to 5.0.3.1033; errors with “Certificate verification failed: Certificate is not valid.”

 

Userlevel 7
Badge +8

Seeing the same thing here.

Veeam Backup for Microsoft Office 365 - version 5.0.1.252

Trying to upgrade to 5.0.3.1033; errors with “Certificate verification failed: Certificate is not valid.”

 

Then try the ugprade media as the other person did.  I would then file a support ticket for Veeam to check this out.

Userlevel 4

Seeing the same thing here.

Veeam Backup for Microsoft Office 365 - version 5.0.1.252

Trying to upgrade to 5.0.3.1033; errors with “Certificate verification failed: Certificate is not valid.”

 

Here the link: https://www.veeam.com/kb4203

Thanks for the link. FWIW we are seeing the same thing from an Azure VM with no proxy.

Userlevel 7
Badge +8

I’ve crossposted to the R&D forums for more eyes on this. Has anyone raised a support case with Veeam on this one yet or got any logs to share?

 

https://forums.veeam.com/veeam-backup-for-office-365-f47/vbo365-unable-to-update-t79464.html

Userlevel 7
Badge +8

Just to update everyone, I’ve looked into this further and can see the Veeam.Backup365_5.0.3.1033.msi signature is being treated as invalid when trying to update direct from Veeam, about to raise a case with them.

Userlevel 7
Badge +8

Appears to be an invalid certificate signing the MSI, I’ve raised with Veeam, hopefully they’ll fix swiftly.

Userlevel 7
Badge +8

Appears to be an invalid certificate signing the MSI, I’ve raised with Veeam, hopefully they’ll fix swiftly.

Good find on this one.  Hopefully they do fix it.

Userlevel 7
Badge +8

Had confirmation that Veeam R&D are aware and the next release will have an updated certificate!

Userlevel 7
Badge +8

One extra thing to add, I asked the question “with v6 so close to release, will we get a v5 patch that includes the new certificate” and I’ve been told, yes we will!

Userlevel 7
Badge +8

One extra thing to add, I asked the question “with v6 so close to release, will we get a v5 patch that includes the new certificate” and I’ve been told, yes we will!

That is good to know if required to upgrade to V6.

Userlevel 7
Badge +6

Thanks @MicoolPaul for taking care of this problem :thumbsup:

Userlevel 7
Badge +8

There is now a KB related to this from Veeam - KB4281: Veeam Backup for Microsoft Office 365 upgrade fails with "Certificate is not valid" error

 

Userlevel 7
Badge +8

Thanks for sharing @Chris.Childerhose!

I know this is an old topic but will this work for the community edition as well? I have a client that has O365 Backup 4.0.0.1345 Community Edition installed and get the same error. Will the same patch work?

Userlevel 7
Badge +5

Hi @mattbjorkman.72 

 

With 4.0.0.1345 you should directly update to the newest release of VB365 with the ISO:

https://www.veeam.com/kb4285

As I saw in the R&D Forums, you are using also Veeam Backup & Replication 9.5 (VBR) on the same server (which is not recommended). You must update it first to V10 or later before updating your VB365 application to version 6.

I don‘t see your VBR build in the forum post, but you can follow this post for the upgrade path:

https://www.veeam.com/kb2053
 

I‘ll answer you also in the forum in a few minutes.

 

Thanks

Fabian

Comment