Question

Veeam Upgrade issue.


I recently updated a client from Veeam 11, I think .816 to the latest version available. Everything went as usual as I do these quite often but this one is throwing a pop up that states, "unable to upgrade plug-ins under the current user, please open the console under an account with administrative privilege's:" when I launch Veeam. I am logged in as a local administrator account and have updated this client in the past with no issues.

I just click on okay and it opens up like normal. I also checked for any updates to the managed machine and there is upgrade option. This is a stand alone Veeam system with no remote components.

I don't think it's going to impact the functionality but will know more after tonight's job run.

Appreciate any feedback!

Thanks,
Poettone!


13 comments

Userlevel 7
Badge +5

With which account did you do the upgrade?

Userlevel 5
Badge +1

Not sure this would go anywhere, but when you start the console, is UAC prompting for elevated priviledges?

Userlevel 7
Badge +5

Not sure this would go anywhere, but when you start the console, is UAC prompting for elevated priviledges?

This was my train of thought, just did not elaborate 😎

 

Userlevel 7
Badge +6

Can you grab the install logs and share the errors from that? Could be a file permission check failure, DB permissions, or a whole host of things I could speculate. Logs will help pinpoint this quickly.

 

It’ll be the install logs though, not the normal application logs

Userlevel 7
Badge +4

Why not opening a support case with Veeam? (saw your Post in the R&D forums).

The plugins, which the console wants to update are plugins like Nutanix or our Cloud Product Integration. 
After you have updated the veeam console, veeam will need to copy the updated plugin versions from the backup server to the client with the console. This must be done after each update of the vbr server.

Userlevel 7
Badge +5

Not sure this would go anywhere, but when you start the console, is UAC prompting for elevated priviledges?

Will be vital only when this is enabled!

Userlevel 7
Badge +5

@Poettone, I will suggest you read through this. https://forums.veeam.com/veeam-backup-replication-f2/veeam-b-r-console-needs-admin-rights-to-start-t32617.html

With which account did you do the upgrade?

Oh, we recently changed administrative accounts and are now using another one (which isn’t the same account) the original version 10 was installed with.. so possibly that even though it’s also an admin account? I will try to login with the old one if still there and see if that helps..

 

Thanks all!

Not sure this would go anywhere, but when you start the console, is UAC prompting for elevated priviledges?

No prompts at all.. UAC is off in fact. Thanks though.. 

With which account did you do the upgrade?

Oh, we recently changed administrative accounts and are now using another one (which isn’t the same account) the original version 10 was installed with.. so possibly that even though it’s also an admin account? I will try to login with the old one if still there and see if that helps..

 

Thanks all!

Using the other account produced the same error message.. Worth a shot though!

Why not opening a support case with Veeam? (saw your Post in the R&D forums).

The plugins, which the console wants to update are plugins like Nutanix or our Cloud Product Integration. 
After you have updated the veeam console, veeam will need to copy the updated plugin versions from the backup server to the client with the console. This must be done after each update of the vbr server.

I can surely open a ticket with Veeam, that’s no issue, but with limited time and client availability and that fact that it shouldn’t impact the backup’s it was more of a like, to get rid of the error.

I did check programs and see two plug-in features installed “Azure and Google” but they use neither and those were updated at the same time the minor revision update was done. 

Again they have a very simple setup, one machine, one console, no proxy’s no cloud services etc.. I may remove the plug-in applications and go from there.

 

Thanks!

 

Userlevel 7
Badge +6

Why not opening a support case with Veeam? (saw your Post in the R&D forums).

The plugins, which the console wants to update are plugins like Nutanix or our Cloud Product Integration. 
After you have updated the veeam console, veeam will need to copy the updated plugin versions from the backup server to the client with the console. This must be done after each update of the vbr server.

I can surely open a ticket with Veeam, that’s no issue, but with limited time and client availability and that fact that it shouldn’t impact the backup’s it was more of a like, to get rid of the error.

I did check programs and see two plug-in features installed “Azure and Google” but they use neither and those were updated at the same time the minor revision update was done. 

Again they have a very simple setup, one machine, one console, no proxy’s no cloud services etc.. I may remove the plug-in applications and go from there.

 

Thanks!

 

Logs will be fastest way through this, you’ve said you’ve swapped admin accounts, does the account account have appropriate DB access?

Userlevel 7
Badge +1

Interesting; my primary lab environment has it also and it is from an installation upgraded many times. Everything works; but have to do that on entry to the B&R app.

Comment