Question

immutable wasabi with VBO 365

  • 28 November 2023
  • 5 comments
  • 44 views

Userlevel 6
Badge +1
  • Comes here often
  • 34 comments
Adding Wasabi Immutable Bucket

I was trying to add wasabi bucket with immutable as backup repository, but it showed an error, any suggestion to solve this error ?


5 comments

Userlevel 7
Badge +20

Hi,

 

Is this a new bucket or a pre-existing bucket? I’d firstly try to create a new bucket and see if the issue reappears.

Which region is the Wasabi bucket within?

 

Can you let us know the region/language settings on your machine, I notice the screenshot seems to format the time as 21.51 instead of 21:51 and I’m wondering if there’s an issue with a particular locale on Windows. If so Veeam support will likely already be aware, but you should raise a case with them otherwise.

Userlevel 6
Badge +1

@MicoolPaul but when i try to add same immutable bucket to VBR backup repository, it didn’t give any error. but when i try to add to VBO365 as backup repository it always showed same error

Userlevel 7
Badge +20

Hi, so are you already using that bucket for another purpose? You shouldn’t share buckets between different Veeam products or installations, appreciate you might’ve just been adding it to test however.

Userlevel 6
Badge +1

@MicoolPaul even if I use different bucket with immutable on bucket, it still gave me an error like that

Userlevel 7
Badge +6

Can you let us know the region/language settings on your machine, I notice the screenshot seems to format the time as 21.51 instead of 21:51 and I’m wondering if there’s an issue with a particular locale on Windows. If so Veeam support will likely already be aware, but you should raise a case with them otherwise.

 

Keen eye there.  I’m wondering if this could be causing an issue as well.  Interesting that on his machine, it’s formatted 21:51 but on the server it’s 21.51.  Best I can tell, Amazon S3 protocol requires time formats to be ISO 8601 compatible, and using a decimal to separate the hour and minute fields rather than a colon does not comply with ISO 8601.  I suspect that if the time locale on the server is converted to a compatible format, this error may go away.  The first link below references ceph, but this line in particular gives me pause.  I suspect support would have him change to a standard time format, at least for testing purposes, but I assume as well that even if it’s a bug based on the format, the support methodology is going to be to change the time format to a standards-based format.  It might actually be the only option if this is what the hold-up is actually.

 

The "x-amz-object-lock-retain-until-date" header is in the wrong format.

The same commands for Amazon S3 returns header that formatted in ISO 8601 standard:

 

https://en.wikipedia.org/wiki/ISO_8601#Times

 

Comment