filestream feature must be enabled on the target server

Userlevel 3
  • Comes here often

We had case #03228597 open with Veeam support for this issue. 

  • We noticed that when trying to restore a particular database, we received the error ‘filestream feature must be enabled on the target server’
  • Filestream feature was not enabled on the source DB/MSSQL server
  • Restoring other DBs from the same source server worked without issue
  • After some back and forth with support, they identified this as a bug:

Unfortunately, we discovered this is a bug in our current version of Veeam. This has been already reported to R&D and will be under work and fixed most likely in our next major patch.

No other fix available for the moment.

  • ​​​​​​​We asked for an ETA for a fix, or if there was an official workaround:

To sum up on this topic , the error that you are facing has the scope of a warning and it is dependent on the SQL AOG Database configuration where Filestream feature is disabled . 

As we are highly interested in having our customers with the best product experience, our Product Management team with help of R&D confirmed this can be corrected from our end without having any needed changes on the AOG setup that our customer is having reason for having it fixed with one of the major upcoming versions . 

As the product development process falls beyond Veeam Technical Support team scope , unfortunately at this moment we cannot confirm with Product Management any release date for having the version that corrects this warning available yet you have the option to het notified via email when a new release is available if you subscribe to (downside right corner) . 

  • The outcome was not very helpful, so as it stands we have no idea when this issue might be fixed.
  • Raising this here in case anyone else is seeing this problem (it might be worth testing your SQL restore process...) 
  • If anyone else has seen this issue, and has some ‘sensible’ workarounds then please do share


Userlevel 7
Badge +19

Thanks for sharing this bug @EMcS 

Userlevel 7
Badge +21

Have not seen this issue myself but thanks for sharing the details around your case.  Hopefully this helps others with similar issues.

Hello EMcS, thank you for sharing . Ticket 03228597  is not valid Veeam Support ticket number. Maybe there is a typo .

Userlevel 3

Hello EMcS, thank you for sharing . Ticket 03228597  is not valid Veeam Support ticket number. Maybe there is a typo .

You’re correct! #07155122 is the case number. Support closed the case, as it is waiting for product management and a new release… 😒

We have the exact same problem here, FILESTREAM feature is not enabled on staging SQL server.

Same error with restore db or export to bak.