RMAN Plugin Backup - ORA-01012 Error

  • 11 November 2020
  • 1 comment

Userlevel 7
Badge +15

Yesterday I got an error for two oracle databases which are backed up via the VEEAM RMAN plugin.

Strange - there are several database instances on this system, all but the two are working fine. And these two had worked up to then, too…

And… I did not change anything in the VEEAM and plugn configuraton :grinning:


After some discussion and research with our Oracle admin - bingo.

He had moved these two databases to another Home directory and did not change the corresponding entries in the /etc/oratab. So - as shown in the picture - the backup of the database and the recovery logs worked, but the creation of the AUTOBACKUP failed and the ORA-01012 error was given.

After the entries were corrected all worked fine again.

Perhaps some of you will face similar issues, too. I did not find anything for this problemin the forums with a quick search.

1 comment

Userlevel 7
Badge +11

Ahh, that is a tricky one! Thank you for sharing :thumbsup_tone1: