How to fix Veeam FLR error -Secondary GPT header LBA 209715199 exceeds the size of the disk (86401630720)

  • 8 October 2023
  • 8 comments
  • 594 views

Userlevel 7
Badge +7
  • Veeam Vanguard, Veeam Legend
  • 198 comments

This error happened to one of our clients. The backup chains’ status is good without any issues.

VBR v12 guest file restore---happen error message is as below:

Secondary GPT header LBA 209715199 exceeds the size of the disk (86401630720)

Agent failed to process method {Mount.GenericMount)

 

 

I tried to change the mount server of the repository, but I still had no luck.

This VM has only one virtual disk (C:) with 9GB of free space. I cannot restore files from any existing restore points. (actually, I cannot mount any restore point to the mount server).

I tried to create a new test backup job to back up the VM and tried to restore the guest file from the first restore point (full backup chain) but got the same error. So, I expend the C drive to add 10GB more storage space to it, then rerun the backup job.

Now, I can mount the incremental restore point, but I still cannot mount the full backup restore point.

This issue is solved, but all the existing restore points cannot be mounted before expanding the C drive of the VM.

If you need to restore a file from those existing restore points, you can use the instant recovery or restore VM file to mount it to the existing VM and then copy a file from the mounted disk.

I hope you enjoy this post.


8 comments

Userlevel 7
Badge +21

Glad you were able to fix the issue and share with the community.  👍

Userlevel 7
Badge +11

Thank’s for share this with us @CarySun 

Userlevel 7
Badge +7

@wolff.mateus you are welcome!

Userlevel 7
Badge +14

@CarySun Have you tried to use the Linux FLR (Linux and other)? I remember an odd case where a VMDK was somehow shrinked and the OS volume remained the same size. The Linux FLR worked for that case.

Userlevel 7
Badge +7

@regnor I didn’t try it. They don’t have any Linux servers to be helper hosts, but good to know.

Thank you!

Userlevel 7
Badge +7

@regnor I tried it today. I forgot I could select “Use a temporary helper appliance”., and it will create an FLR helper appliance at the Hyper-V host.

Unfortunately, it’s not working for my case. The restore point seems to mount, but no file structure is showing. It’s empty.

 

Userlevel 7
Badge +6

Thanks for sharing.  I believe I have a server that has this issue but we had to pause backups as these were going direct to Wasabi and the client had a poor internet connection so I had to pause troubleshooting.  In my case, I am attempting to get a good backup (vs restoring) and I found information that referenced shrinking the disk which I had tried, but I’ll try expanding instead and see what happens.  I’m just picking backup on that project and was catching up on posts and found this - which I think may apply.  Either way, thanks for posting.

Userlevel 7
Badge +7

@dloseke This is a rare issue for me. Good luck!

Comment