Question

Problem with postgresql backup via blueprint

  • 10 September 2022
  • 3 comments
  • 96 views

Userlevel 2

Hello,

I’m not able to backup my postgres database via blueprint anymore. I already did a complete new installation of k10 (with current 5.0.7 release), but I still have the following problem.

 

In the Kanister-job that makes the DB dump, everything looks fine. I can see the logical size and also the kopiaOutput JSON being created. 

Also in the kanister svc logs, the DB dump seems to be working

2022-09-10T23:39:33.003580826+02:00 {"ActionSet":"k10-backup-postgres-bp-postgres-postgresql-smarthome-state2tbht","File":"pkg/controller/controller.go","Function":"github.com/kanisterio/kanister/pkg/controller.(*Controller).logAndSuccessEvent","Line":652,"Phase":"pgDump","cluster_name":"e3672d3c-1bc6-44d8-bacb-b2401e6368ba","hostname":"kanister-svc-7c8754b554-dnqns","kanister.io/JobID":"c978c3a9-3150-11ed-944a-5a2238b22591","level":"info","msg":"Completed phase pgDump","time":"2022-09-10T21:39:33.002161239Z","version":"5.0.7"}

 

But in the next step I get "error":"Failed to render template: \"kopiaOutput\" not found"

2022-09-10T23:39:33.003580826+02:00 {"ActionSet":"k10-backup-postgres-bp-postgres-postgresql-smarthome-state2tbht","File":"pkg/controller/controller.go","Function":"github.com/kanisterio/kanister/pkg/controller.(*Controller).logAndSuccessEvent","Line":652,"Phase":"pgDump","cluster_name":"e3672d3c-1bc6-44d8-bacb-b2401e6368ba","hostname":"kanister-svc-7c8754b554-dnqns","kanister.io/JobID":"c978c3a9-3150-11ed-944a-5a2238b22591","level":"info","msg":"Completed phase pgDump","time":"2022-09-10T21:39:33.002161239Z","version":"5.0.7"}
2022-09-10T23:39:33.286971214+02:00 {"ActionSet":"k10-backup-postgres-bp-postgres-postgresql-smarthome-state2tbht","File":"pkg/controller/controller.go","Function":"github.com/kanisterio/kanister/pkg/controller.(*Controller).logAndErrorEvent","Line":635,"Phase":"pgDump","cluster_name":"e3672d3c-1bc6-44d8-bacb-b2401e6368ba","error":"Failed to render template: \"kopiaOutput\" not found","hostname":"kanister-svc-7c8754b554-dnqns","kanister.io/JobID":"c978c3a9-3150-11ed-944a-5a2238b22591","level":"info","msg":"Failed to render output artifacts","time":"2022-09-10T21:39:33.286013918Z","version":"5.0.7"}

Can someone help me with that? 


3 comments

Userlevel 2

It is related to the upgrade to Ubuntu server 22.04. But I’m not sure if it’s OS related, or a problem with the updated kubernetes/microk8s version.

After the upgrade the version was 1.23.9. I also tried now on 1.24.3 and 1.25.0.

In 1.24.3 I have the same error as in the post above, in 1.25.0 it’s a different error in the kanister job:

Snapshotting k10-admin@38d76db0-99c5-43e1-8217-6108ef485b1a.postgres-postgresql.postgres-bp:/kanister-backups ...
pg_dumpall: error: could not translate host name "postgres-postgresql.authentication.svc.cluster.local" to address: Try again

 

Userlevel 2

Hello lemassacre,

 

The last error above looks to be related to DNS, so when the blueprint is attempting to run it's trying to find postgres-postgresql.authentication.svc.cluster.local there is no address correlating with this… What installs of PostgreSQL did you use to create the PostgreSQL. 

Thanks

Emmanuel

Hello @EBrockman, do you know if this was resolved? we too have the same problem:

Job failed to be executed

Failed snapshots for workload

 Failed to create backup Kanister phase

 ActionSet Failed

 Failed to render template: "kopiaOutput" not found

"”  percentCompleted: "10.00"
                state: failed
        file: kasten.io/k10/kio/kanister/operation.go:159
        function: kasten.io/k10/kio/kanister.(*Operation).WaitForActionSet
        linenumber: 159
        message: ActionSet Failed
      file: kasten.io/k10/kio/exec/phases/backup/snapshot_data_phase.go:905
      function: kasten.io/k10/kio/exec/phases/backup.RunKanisterSnapshotActions
      linenumber: 905
      message: Failed to create backup Kanister phase
    file: kasten.io/k10/kio/exec/phases/backup/snapshot_data_phase.go:369
    function: kasten.io/k10/kio/exec/phases/backup.processVolumeArtifacts
    linenumber: 369
    message: Failed snapshots for workload
  message: Job failed to be executed"”
 

Comment