Solved

Windows Warnings about logs


Userlevel 4

I'm getting several warning is the windows logs. It seems to all be to do with the logging

 

Cannot write into storage C:\ProgramData\Veeam\Backup\Utils\Util.VolumesHostDiscover.log Text: System.ObjectDisposedException: Cannot access a closed file

 

I have deleted the logs and they recreate and the events are recorded but throw this warning.

 

This is a Community edition of VBS 11

icon

Best answer by Mildur 16 May 2021, 22:26

View original

12 comments

Userlevel 7
Badge +17

Which Windows Version are you using?

 

I have found a similiar message in the forums from 2015 which was solved with an Veeam patch.

 

Userlevel 4

This is a Server 2019. 

Userlevel 7
Badge +17

Could you please give us some more information about your environment?

  • Exact Veeam version
  • What do you try to backup? vSphere, Files with Agent… And at which versions are these components?
Userlevel 4

The latest version downloaded a week ago. I am backing up,one server and three workstations using the agent. All as per my Veeam server version 11.0.0.837

Userlevel 7
Badge +17

Ok, do you get the errors right from the beginning or did the errors start after some time?

Did you install Windows updates before the errors started.

Did you see the newest Veeam Server update?

https://www.veeam.com/kb4126

 

Is the backup finished or does it crash?

Userlevel 4

Had these from the beginning 

this months Windows patched no change 

backups run fine. 
 

will look at KB4126 is this pertinent?

Userlevel 7
Badge +17

This is at least a component in your environment with an update available.

 

But as this error seems not to be common, I assume an problem with your windows installation or probably with the network connection.

Userlevel 4

Well its only warnings and the logs get written to, so I had best just ignore do you think as the patch mentions noting about these errors. I suspect its a permission error somewhere

Userlevel 7
Badge +21

Well its only warnings and the logs get written to, so I had best just ignore do you think as the patch mentions noting about these errors. I suspect its a permission error somewhere

Not all bug fixes are mentioned in the update list so it’s entirely possible it was fixed. It could very well be a permissions issue, have you amended the permissions for any of the Veeam folder structure and does the service account that is running Veeam have sufficient permissions?

 

Alternatively it could be an anti-virus without suitable exceptions, have you got AV installed on the server?

Userlevel 4

Permissions appear correct. I do have AV on the server. I assume I should excuse these files ?

but as you suggest it’s only a warning and the logs work. Just a bit untidy. 

Userlevel 7
Badge +12

You can follow this KB for recommended AV Exclusion

 

https://www.veeam.com/kb1999

Userlevel 7
Badge +21

Permissions appear correct. I do have AV on the server. I assume I should excuse these files ?

but as you suggest it’s only a warning and the logs work. Just a bit untidy. 

Yep, what AV are you using? Is it signature or heuristics driven?

Comment