Solved

Adding hyper v host fails with "invalid credentials" or "spedified host is not a hyper v server"


Userlevel 3

Adding hyper v host fails with "invalid credentials" or "spedified host is not a hyper v server"

icon

Best answer by Danyang007 24 January 2024, 16:50

View original

20 comments

Userlevel 7
Badge +16

Hi @Danyang007 -

Welcome to the Community. Have you looked at the User Guide for assistance? Make sure you've met the prerequisites and use an Administrator account to add your Host, in the format  DOMAIN\USER or MACHINE\USER. 

Userlevel 7
Badge +6

Can you provide more information?

What version of Hyper-V?

Is the host standalone or in a cluster?

What version of Veeam?

Have you checked the Helpcenter and made sure all pre-reqs are met? https://www.veeam.com/documentation-guides-datasheets.html?productId=8&version=product%3A8%2F221

 

Userlevel 3

Hi @MarkBoothman 

The Hyper v version is 10.0.17763.1

Its standalone

Veeam version 12.1

Veeam Server is Windows Server 2019

Problematic server is also Windows Server 2019

All prerequisites are met.

The server is not on a domain.

 

credentials format is server01\Administrator (inbuilt Administrator)

I already added one server succesfully, but the other two servers is refusing to add

 

Userlevel 7
Badge +6

can you get to the other 2 servers via UNC and successfully browse resources?

Userlevel 3

Hi @MarkBoothman,

Yes I can.

Using both IP\c$ and IP\Admin$ format.

Userlevel 7
Badge +6

how about %hostname%\admin$ ?

Userlevel 3

I could reach the share using %hostname%\admin$ for one of the server

 

The other server failed when I used %hostname%\admin$

 

Sorry tried again and both servers are reachable using %hostname%\admin$

Userlevel 7
Badge +16

Hi @Danyang007 -

Some common issues adding HV to Veeam are:

  • Credentials (sometimes using .\user works, as noted in 1 of the posts I’ll share below)
  • HV server has firewall enabled; temporarily disable, try to add, then re-enable
  • UAC is enabled; disable then attempt, then if required..re-enable
  • HV host needs to be fully patched, rebooted, then re-attempt to add
  • If role was just added and not yet rebooted, reboot, then re-attempt to add

Some of these fixes are found in a few of the following previous Hub posts:

 

Try these and see if you can then connect.

Userlevel 7
Badge +16

Also, even though you were able to connect with your other Hosts, if your HV host isn’t on the domain, and are trying to use a local admin account, you may need to add a registry fix to enable a local admin to be used to connect to by Veeam or any other service. See my comment which helped this user for another issue in the post below:

 

Userlevel 7
Badge +16

Lastly, make sure DNS is setup correctly since this HV Host is not on the domain

Userlevel 3

Hi @coolsport00 ,

Thank you for your response.

Will try your suggested steps and hopefully it works

Userlevel 7
Badge +16

Sure...keep us posted!

Userlevel 3

Hello Guys,

I finally resolved the issue thanks to @csmithconvergence writeup.

The resolution is to install Microsoft KB 5034127 on the Veeam server. i restarted after the installation and everything went smoothly.

https://catalog.s.download.windowsupdate.com/c/msdownload/update/software/secu/2024/01/windows10.0-kb5034127-x64_7ac59afbc502ef9dc77f7584b31110ea0b23a566.msu

 

Got it fixed with the help of Veeam support.

In 2022 there was a MS update that hardened DCOM security. It started out as disabled by default, then it turned into being enabled by default with a reg key you could implement to bypass it. In March of 2023, an update enforced it. This DCOM hardening was preventing the non-domain-joined Veeam server from passing the target server’s local admin credentials through to join it to the backup infrastructure. 

Further details: KB4376: Access to Hyper-V or Veeam B&R Components Fails After DCOM Hardening is Enabled

The resolution is to install Microsoft KB 5005102 on the Veeam server: Microsoft Update Catalog

This information was really hard to come by, so I hope this makes it easier for the next person to resolve their issue. This KB does not get applied through normal monthly updates, so simply patching the server will not help.

Thanks everyone for your input along the way!

Thank you guys, you were all amazing.

Userlevel 7
Badge +16

Great to hear!..and thanks for posting what worked for you.

Userlevel 2

Hello Guys,

I finally resolved the issue thanks to @csmithconvergence writeup.

The resolution is to install Microsoft KB 5034127 on the Veeam server. i restarted after the installation and everything went smoothly.

 

Got it fixed with the help of Veeam support.

In 2022 there was a MS update that hardened DCOM security. It started out as disabled by default, then it turned into being enabled by default with a reg key you could implement to bypass it. In March of 2023, an update enforced it. This DCOM hardening was preventing the non-domain-joined Veeam server from passing the target server’s local admin credentials through to join it to the backup infrastructure. 

Further details: KB4376: Access to Hyper-V or Veeam B&R Components Fails After DCOM Hardening is Enabled

The resolution is to install Microsoft KB 5005102 on the Veeam server: Microsoft Update Catalog

This information was really hard to come by, so I hope this makes it easier for the next person to resolve their issue. This KB does not get applied through normal monthly updates, so simply patching the server will not help.

Thanks everyone for your input along the way!

Thank you guys, you were all amazing.

 

So glad this was helpful for you - thanks for the note and the acknowledgement!

This info has been super helpful! I have a similar issue, however, I am running Server 2022 and KB5005102 is not an available update for that OS. I’ve tried changing the DCOM hardening settings, modifying UAC, ensuring local Administrator accounts are used. Nothing has worked. 

Userlevel 7
Badge +16

@Jmaeser82 - would be best if you contact Support for them to try and address your connectivity issue.

Userlevel 3

Hello @Jmaeser82 

Has this issue been fixed?

KB5005102 is for Windows Server 2016

KB 5034127 is for Windows Server 2019, might even work for 2022

So there may be an updated KB verion for Windows Server 2022 

I know you have tried those steps you listed. Have you tried windows update on that server?

Maybe a Windows update can fix the DCOM hardening setttings and fix the issue, just maybe.

 

 

Thanks for checking in @Danyang007! I was able to resolve and I’m embarrassed to admit, it was the username format. On the Veeam server, I simply added the username/password instead of <hyper-v hostname>\<local admin username> and I was good. I was able to reverse the DCOM setting I changed previously and everything essentially worked out of the box on 2022. 

Userlevel 3

@Jmaeser82 

Thank you for coming back to drop your resolution.

Glad it was resolved. 

Comment