Question

More than one backup was found for the same job


Userlevel 6
Badge +1

Running VBR v12.0. Created a backup job. Ran the job and got an error so went back in and try to edit the job. I got the error below. First time, I encountered this error. The backup log just showed the same information. I have a similar job running in our “staging” VBR but not having any error. The backup job is a storage snapshot and does handle SQL transaction logging. 

I saw in the Veeam’s Forum the same error message but this was for a backup copy job. 

What do you think is happening here?

 


15 comments

Userlevel 6
Badge +1

Oops sorry about that. Below is the screenshot of the volumes being backed up. I will let you know what Veeam support would find out about this issue.

 

 

Userlevel 6
Badge +1

My ticket has been opened with support for about a week now and I haven’t gotten a convincing solution or at least cause of the issue. I have sent my backup config db, hopefully they see a persistent object ID or something causing the issue.

I have had this issue before, and I just ended up deleting and recreating the job.

For SQL, I would setup a maintenance job to do all the SQL backups, then just backup that data. I have had issues with SQL aware veeam backups in the past.

Userlevel 7
Badge +10

Running VBR v12.0. Created a backup job. Ran the job and got an error so went back in and try to edit the job. I got the error below. First time, I encountered this error. The backup log just showed the same information. I have a similar job running in our “staging” VBR but not having any error. The backup job is a storage snapshot and does handle SQL transaction logging. 

I saw in the Veeam’s Forum the same error message but this was for a backup copy job. 

What do you think is happening here?

 

Hi @spider32 are you sure this job NOT contains VM included in another job that starts at the same time? 

Userlevel 6
Badge +1

I already did recreate the job and gave me the same error. The 2nd time it showed the same error, I disabled the job. However, it continued to send out SQL notification error which means that this job was still running in the background. The only way to stop the notification is to delete the job. We are able to process tlogs successfully on our staging VBR server before we moved the job to our production VBR server. 

Userlevel 7
Badge +10

Please can you share an image of job configuration particularly tab with server added? 

Thanks 

Userlevel 7
Badge +10

Oops sorry about that. Below is the screenshot of the volumes being backed up. I will let you know what Veeam support would find out about this issue.

 

 

Hi @spider32 with this image I can suppose the issue is due to the datastores used as object to backup. I mean in this case 

Only backup a VM if a VMX file exists on the specified datastore. But job processes all the VM's which has VMDK's on the datastore. If you have other backup job using specific VM that can be have vmdk across different datastores you receive a failure. I'm not sure this scenario is in your environment but I 'd check if it's true. 

My 2 cents

Userlevel 6
Badge +1

I already deleted the job that had an issue. Below is a screenshot of the working job. This is identical to the job having an issue except on the VBR this is one is running in. 

 

I will open a ticket with support. Thanks.

Userlevel 6
Badge +1

This ticket still open with support. No resolution yet. Tried to create a backup job and added VMs as the backup object instead of the volume. Still go the same error. Sent a copy of the DB to support (2nd time). Hopefully, they determine the issue and resolution soon. 

Userlevel 6
Badge +1

Just a quick update. Support still working on this one and I will escalate since it has been a month now since this was opened. I think this can be fixed by running SQL query/command but finding out what caused the duplication would be great.

Userlevel 6
Badge +1

@Andanet, I’m sure that this is the only job that backups the VMs in our production VBR. The same job is in our staging VBR but this has been disabled (their schedules are also a couple of hours apart). 

Userlevel 7
Badge +21

May want to contact support and open a case cause this could be tricky to fix if needing to modify the database at all.

Userlevel 7
Badge +21

I already deleted the job that had an issue. Below is a screenshot of the working job. This is identical to the job having an issue except on the VBR this is one is running in. 

 

I will open a ticket with support. Thanks.

The screenshot is not here for us to see.

Userlevel 6
Badge +1

Finally, this was resolved after a month of Veeam taking a look at it. Veeam unable to find root cause for the issue however. The guy who helped me out basically made modifications on the Veeam config DB to delete a duplicate job entry. Once that was done, the problem disappeared and has not re-occurred. 

Userlevel 7
Badge +21

Keep working with Support as I am sure they will get it sorted out for you.  Keep us updated so we know once you have an answer and fix.

Comment