Solved

Set-VBRViReplicaJob : Broker service has not started hierarchy collection for host


Hi All,

 

I recently migrated some replicated VM’s on our VMWare infrastructure to a new DVSwitch and updated VLAN names, so I had to update all the Veeam replication jobs, when i tried to automate this using the Veeam powershell library I got the following error on 95% of the jobs.

 

I did a little investigation but didnt manage to figure out what the difference was between all the failed jobs and the 3 that successfully updated. Has anyone ever seen this error message before ?

 

Set-VBRViReplicaJob : Broker service has not started hierarchy collection for host xxxxx

 

Here is a simplified version of the script i was using:

# get all replication jobs
$jobs = Get-VBRJob | Where-Object TypeToString -eq "VMware Replication"

foreach ($job in $jobs) {
$jobOptions = Get-VBRJobOptions -Job $job

# get list of network objects on new target dvswitch
$destSwitchNets = Get-VBRViServerNetworkInfo -Server "<server with new dv switch>" | Where-Object SwitchName -eq "NEW SWITCH"

# build array of source and destination network objects
$srcNetworks = @()
$destNetworks = @()

foreach($net in $jobOptions.ViNetworkMappingOptions.NetworkMapping){
$srcNetworks += $net.SourceNetwork
$destNetworks += $destSwitchNets | Where-Object NetworkName -eq $net.TargetNetwork.NetworkName
}

# update job with new network mappings
"'$($job.Name)' remapping $($jobOptions.ViNetworkMappingOptions.NetworkMapping.TargetNetwork.NetworkName) -> $destNetworks"
Set-VBRViReplicaJob -Job $job -EnableNetworkMapping -SourceNetwork $srcNetworks -TargetNetwork $destNetworks
}

Thanks for any help that can be provided.

 

icon

Best answer by dionmitchell 21 June 2024, 08:12

View original

5 comments

Userlevel 7
Badge +21

Good to hear that you resolved the issue albeit manually.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Userlevel 7
Badge +19

Ah, ok. Thanks for the update @dionmitchell . Since you resolved this, albeit maybe not the way you hoped, go ahead and mark your last comment there as best answer since you took care of this manually...again, so others will benefit.

Best.

Hi @dionmitchell - just following up on your post here. Did you ever resolve this? Did you maybe work with Veeam Support to find a resolution? If so, can you share what was done? 

Best.

Hi @coolsport00 I followed this up on the Veeam forums → https://forums.veeam.com/powershell-f26/set-vbrvireplicajob-broker-service-has-not-started-hierarchy-collection-for-host-t93889.html but never got the chance to test the suggested action of rescanning the VMware environment as I completed updating the jobs manually.

 

Thanks

Userlevel 7
Badge +19

Hi @dionmitchell - just following up on your post here. Did you ever resolve this? Did you maybe work with Veeam Support to find a resolution? If so, can you share what was done? 

Best.

Userlevel 7
Badge +21

Have never seen this one before.  Maybe a search in the forums might provide some better results - http://forums.veeam.com

I work with PS a fair bit but not for replica jobs.  Hopefully some of our PS gurus will see this and can help. 😎

Comment