Solved

Warning when running VM backup - SetVmCustomConfigOption failed


Userlevel 4

I am testing some VM backups in a customer environment.  We get the following warning when running the backup of a test VM:

6/22/2021 8:18:11 AM :: SetVmCustomConfigOption failed, vmRef 'vm-117256', options ['SCSI0:0.ctkEnabled':'True','SCSI0:1.ctkEnabled':'True']Fault "NoPermissionFault", detail "<NoPermissionFault xmlns="urn:vim25" xsi:type="NoPermission" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><object type="VirtualMachine">vm-117256</object><privilegeId>VirtualMachine.Config.AdvancedConfig</privilegeId></NoPermissionFault>"Permission to perform this operation was denied.

The backup appears to completed successfully with this warning on the VM.   Any thoughts on the reason for this warning?  Running Veeam 11.0.0.837.  Vcenter version is 7.0.2.00200

icon

Best answer by Chris.Childerhose 22 June 2021, 16:48

View original

13 comments

Userlevel 7
Badge +8

Looks like the upgrade to Cumulative Patch P20210525 may have done the trick.  Job is now running without the warnings.   Thanks Chris!

Glad to have helped. :grin:

Userlevel 7
Badge +6

Nice! Glad you got it sorted. 

Userlevel 4

Looks like the upgrade to Cumulative Patch P20210525 may have done the trick.  Job is now running without the warnings.   Thanks Chris!

Userlevel 7
Badge +8

When I see this:

'SCSI0:0.ctkEnabled':'True','SCSI0:1.ctkEnabled':'True']Fault "NoPermissionFault", detail

I would say, the user you use for connecting to vCenter does not have the permission to enable CBT on this VM/VMDK.

https://helpcenter.veeam.com/docs/backup/vsphere/required_permissions.html?ver=110

 

Further to this here is the exact vSphere permissions link - Backup - Required Permissions for VMware vSphere (veeam.com)

 

Userlevel 7
Badge +7

When I see this:

'SCSI0:0.ctkEnabled':'True','SCSI0:1.ctkEnabled':'True']Fault "NoPermissionFault", detail

I would say, the user you use for connecting to vCenter does not have the permission to enable CBT on this VM/VMDK.

https://helpcenter.veeam.com/docs/backup/vsphere/required_permissions.html?ver=110

 

Userlevel 7
Badge +6

Wonder also what the job properties looks like. Is Direct SAN used? Hot add? NBD? Did the job try SAN or Hot Add & couldn't so failed over to NBD? If so, is there a NFS permission issue somewhere? 

Userlevel 4

No scripts

Userlevel 4

Pretty basic backup of a single VM.  No encryption, no App Aware, no Guest File Indexing.  Backing up from NetApp NFS datastore using snapshots.  I will get the latest patch and apply.  

Userlevel 7
Badge +3

Just wanted to add:

  • Are you running any scripts prior and after the backup?
Userlevel 7
Badge +8

Hi @dmarkham ...need more info here. How is the test backup job for the VM configured? Do you have AAIP and/or guest processing settings configured? Other settings? (i.e. encryption, etc)

 

Thanks.

Agreed more information needed for sure. 👍

Userlevel 7
Badge +8

This one - https://www.veeam.com/kb4126

 

Userlevel 7
Badge +6

Hi @dmarkham ...need more info here. How is the test backup job for the VM configured? Do you have AAIP and/or guest processing settings configured? Error looks possibly like could be credentials issue with ap-aware integration processing maybe? What are other settings? (i.e. encryption, etc)

 

Thanks.

Userlevel 7
Badge +8

Do you have the latest Veeam patch that supports U2?  I would try applying that and run the job again.

Comment