VB365: Processing site XYZ finished with warning: Failed to backup list: XYZ. Unknown Error


Userlevel 7
Badge +6

Just a quick information.

Currently there could be an issue with Veeam Backup for Microsoft 365 and Sharepoint. Some sites will be backed up with the following warning:

Processing site XYZ finished with warning: Failed to backup list: XYZ. Unknown Error

I have seen this with 2 different customers and Veeam support is aware of this issue and actively working with Microsoft on it. At the moment I don’t have any further information, but I’ll keep updating this post.

Update 1:

I just found out that there's already a hotfix available: https://www.veeam.com/kb4326

I haven't tested it so far, but will report back next week. Also here's the corresponding R&D forums post: https://forums.veeam.com/veeam-backup-for-microsoft-365-f47/warning-on-my-sharepoint-site-t81314.html

Update 2:

It looks like the issue itself is gone since Saturday; perhaps Microsoft did change something on their side. I did implement the hotfix anyways and experience any problems.


9 comments

Userlevel 7
Badge +6

Yikes!  Time to let my team know that manage this and Devs.

Userlevel 7
Badge +6

Hi,

 

Thanks for sharing this. So this started last night. I’d spun up a VB365 VM in Azure for a test, and left it to backup overnight. This morning it said job interrupted, noticed it was a year out of date for patches (v5), updated to v6 and told it to re-run, then saw you make this topic and saw my job fail in the same way.

 

My M365 Admin centre only has an incident with Exchange, not SharePoint, so what the heck do they think an incident should be 😬

Userlevel 7
Badge +6

Who knows what Microsoft has changed again...and probably an incident for a 3rd party backup solution isnt worth an incident for Microsoft 😅

Updated my post with a link to the hotfix for this issue.

Userlevel 7
Badge +6

Backup of the MS stuff gets more difficult every day…. 🙁

Userlevel 7
Badge +6

I’ve just used that R&D post to ask if there will be a patch for v5 as well, since that’s what Veeam are still using for their template VMs within Azure...

Userlevel 7
Badge +6

I’ve just had confirmation there will be NO patch for v5. V6 is gonna be mandatory to protect your SharePoint Online instances now!

Userlevel 7
Badge +6

I’ve just had confirmation there will be NO patch for v5. V6 is gonna be mandatory to protect your SharePoint Online instances now!

Well that is one way to force you to v6.  🤣

Userlevel 7
Badge +6

I have updated my post again. For one it looks like the issue got fixed by Microsoft. And the hotfix itself didn’t cause any problems.

Userlevel 7
Badge +6

I have updated my post again. For one it looks like the issue got fixed by Microsoft. And the hotfix itself didn’t cause any problems.

Nice to see it patched.

Comment